Welcome! Log In Create A New Profile


Problem getting ramps 1.4 to work

Posted by HereIgoAgain 
Problem getting ramps 1.4 to work
March 12, 2012 12:09PM
Just found this forum so thought I'd try here too. sorry if this is becomming a multi-post.
I purchased what I think should be Ramps 1.4 full electronics kit for mendel from the future is 3d a couple of months ago to replace the gen3 electronics on my mendel. the kit suggests an Arduino 2560. After putting it all together I ran the arduino 1.0 (and arduino 0023 firmwares). If I choose the 2560 chip, the software compiles but hangs when uploading. If I choose the 1280 chip the software compiles and uploads. From this I conclude that I don't have a 2560 chip but instead have a 1280 chip. With the Arduino 1.0 software, I can upload and run the example blink and fade programs from arduino. I then downloaded the EricZalm-Marlin b4833d5 software, edited the configuration.h file to select 33 for the mother board, compiled and uploaded the software successfully. I then installed and tried replicator-g, reprap, and proterface and cannot connect to the board no matter what i do. Since I bought the Ramps already assembled, I can't see the chip to know exactly what it is. I contacted the company to ask them about the chip and they told me that "You should check the top or bottom of the Arduino board to find the exact version. The 1280 and 2560 have different silk screening on the back. The 2560 looks like this and has 2560 printed below the Mega logo on the top side. The 1280 has the shape of Italy printed on the back. You should select the correct board when flashing the new firmware. " The bottom board of my ramps setup has nothing on it but a black board, no pictures, no silk screening ?? I'm sure there is a simple answer to this that i am missing....just wish I could figure it out. I'm powering the ramps with 2 yellow 12v and 2 grounds on the top board. On the bottom board is a connection for power but I am assuming that the connection on the ramps boards provides power to the board. Any suggestions ?
Re: Problem getting ramps 1.4 to work
March 12, 2012 09:45PM
Download Arduino 0023 from arduino.cc and try that. Everyone has problems with Arduino 1.0
Re: Problem getting ramps 1.4 to work
March 13, 2012 05:27AM
You dont need power to the ramps board, or even have the ramps board connected to the Arduino to load the firmware. The USB will provide sufficient power for loading the firmware
Re: Problem getting ramps 1.4 to work
March 13, 2012 05:55AM
have you tried reading the part number on the arduino chip itself.?

Sorry, only registered users may post in this forum.

Click here to login