Welcome! Log In Create A New Profile


Autotune problem

Posted by KilgoreTrout 
Autotune problem
September 03, 2012 08:49AM
I'm having some serious problem with my RAMPS - with temperature of the hotend. When i set 230 degrees it reaches for example 225 and then drops to 190 or sometimes 210. About 3 minutes later it drops to 160 and fluctuates around this value. I've got RAMPS 1.4 with Marlin.
So far i tried several times autotune with M303 or M303 S230 and every time it gives back different values and none of it makes noticable diffference. It worked well for about month now, but never as it should. I never had straight line with hotend temperature graph. For example i set 230 and it fluctuated around 220 +-10 degrees. Since yesterdahy it;s absolutely unusable and nothin seems to help. Please help me winking smiley

My PID settings:
// PID settings:
// Comment the following line to disable PID and enable bang-bang.
#define PIDTEMP
#define PID_MAX 255 // limits current to nozzle; 255=full current
#ifdef PIDTEMP
//#define PID_DEBUG // Sends debug data to the serial port.
//#define PID_OPENLOOP 1 // Puts PID in open loop. M104 sets the output power in %
#define PID_INTEGRAL_DRIVE_MAX 255 //limit for the integral term
#define K1 0.95 //smoothing factor withing the PID
#define PID_dT ((16.0 * 8.0)/(F_CPU / 64.0 / 256.0)) //sampling period of the

// If you are using a preconfigured hotend then you can use one of the value sets by uncommenting it
// Ultimaker
#define DEFAULT_Kp 29.58
#define DEFAULT_Ki 2.04
#define DEFAULT_Kd 107.11

// Makergear
// #define DEFAULT_Kp 7.0
// #define DEFAULT_Ki 0.1
// #define DEFAULT_Kd 12

// Mendel Parts V9 on 12V
// #define DEFAULT_Kp 63.0
// #define DEFAULT_Ki 2.25
// #define DEFAULT_Kd 440
#endif // PIDTEMP


Edited 1 time(s). Last edit at 09/03/2012 08:52AM by KilgoreTrout.
Re: Autotune problem
October 07, 2012 06:53PM
You could be overheating your power MOSFET. try pointing a fan at it or adding a heatsink or both.
Re: Autotune problem
October 18, 2012 04:31PM
it's been ok for a while, well maybe not ok but i found out what was the problem - mosfet was broken and it didnt have all its power
it was cooled since first use but it got broken any ways
I switched to second one and problem solved
Sorry, only registered users may post in this forum.

Click here to login