Welcome! Log In Create A New Profile


I have screwed myselfeye popping smiley

Posted by Erbanmap 
I have screwed myselfeye popping smiley
September 30, 2012 09:50PM
I had a working mendel based on the defunked techzone electronics. In the course of getting it to work I changed out the techzone end opti end stops for Makerbot optis. I recently tried to start using Replicator G with my mendel. It would not connect. So I thought I needed to upgrade my electonics. I got an assembled RAMPS 1.4 from Utilmachine.

I took the old part off and started to wire up the RAMPS. It is not even connecting to my PC. (Win7 64 bit Laptop) I removed the RAMPS sheild and connected it again to the PC and it found an unknown device. So I went through the process of get ardruino 27 and manully updating the driver. That worked. Then I replaced the shield and Nothing No lights no connected device nothing. I understand that I need to load firmware. But I can't figure out how to do this.

Is there a guide or something that will help me step through the process. I sort of figured that setting up had gotten easier not harder. In the package there was a diode. I don't know if I am supposed to install it or where.

Any help would be closely followed.
Re: I have screwed myselfeye popping smiley
October 01, 2012 08:00AM
Hi Erbanmap

Maybe you did, and hope you enjoyed yourself in the process!

But seriously

The arduinonis powered from the PC, isomyou have 2 powerins. Laptop and adapter
If you dont want this you need to solder the diode on the arduino pcb, just underneath the x driver socket

The endstops have 3 wires, make sure you skip each second 3 pin connector, the seconds are max endstops
See also wiki ramps there is a good drawing of the pcb

Hope this helps


Re: I have screwed myselfeye popping smiley
October 01, 2012 08:53PM
Yup that helped at least further along. I was able to connect to the Ramps. I uploadeded the Marlin firmware. All good.
I tried to connect with Replicator G 23. Sort of wierd character showed up but in the end failled to connect.
I tried to load firmware from Rep G. That worked. Then failled to connect. and LEDs come on showing red. They blink once when I try to connect then stay on red. So good I can put stuff in the RAMPS. Now I need to find the right stuff to put in. I am using Makerbot Opti endstops. My RAMPS has the optional optical end stop pin out. When I have the end stops connected the board does not come on. Are ultimaker end stops and MakerBot end stops wired differently? I put the white wire to "S" the black goes to GRD and the red goes to Vcc. I guess I have to tear the wiring harness apart to make sure what goes where. Do people who buy a prebuilt and assembled machine have this much fun?
Re: I have screwed myselfeye popping smiley
October 04, 2012 04:45AM

had similar issue with Rep G 37
now use pronterface make sure you have baudrates aligned and right motherboard selected - ramps is 33/34

on the end stops, for optos you need to disable the endstop pull ups in marlin
check with m114 for endstop status, may be reversed

have fun

Re: I have screwed myselfeye popping smiley
October 04, 2012 06:15AM
Is endstop status M114 now? I thought M114 is position report while M119 reports endstop status.

Generation 7 Electronics Teacup Firmware RepRap DIY
Re: I have screwed myselfeye popping smiley
October 04, 2012 05:53PM
Sorry typo
Appears I screwed myself toooooooo
Re: I have not
October 04, 2012 08:16PM
Well I whined to soon. I now have Rep G talking to my RAMPS. I have X, Y and Z working. I have the X endstop working. I did fry one of the step controlers so I have to wait till I get a new one. I was using the techzone thermal wire and thier AD module to get temp readings. So it looks like the RAMPS understands thermoresister instead. The good news is I have one. So tonight I will be working on getting it reading temp from my hot end.
Sorry, only registered users may post in this forum.

Click here to login