Welcome! Log In Create A New Profile


Ramps Z Stepper Issue- Update, Now a pin reassignment issue!

Posted by Clem 
Ramps Z Stepper Issue- Update, Now a pin reassignment issue!
October 18, 2012 04:20PM
Ok, I appear to have broken some part of my Ramps/Arduino setup, I can no longer get any movement on the Z-axis.

On trying to setup a LCD system I guess I must have shorted some pins or something (I'm not even sure I was doing it live ...) on the Z stepper board. As after I had connected the LCD and went to play firmware games the arduino wouldnt connect to the PC (connected then immediately connected).

Pulling some plugs and boards I zeroed the problem down to the Z stepper pololu board which seemed to be shorting the 5v rail and pulling the voltage down. Having removed this I was able to connect.

Now, having replaced the pololu board I cannot get the Z motors to move. Any pololu board in this slot (including ones confirmed to be working in X and Y slots) dont work. The motors work (tested in X and Y slots) but the Z slot doesnt work.

I hooked up a scope, Z-EN pin is high (always it seems), Z-step pin pulses when I command it to move and Ive seen some action on Z-Dir pin when trying to move up and down. The 12V pins seem to be doing the appropriate things and I have pinged the 4 motor rails and confirmed they connect to the pololu socket. I havent yet tested the 12V pulses out as I need a second kettle lead to run my PSU and scope ...

Any ideas as to what might be wrong guys ... starting to lose patience/run out of ideas ...

Edited 1 time(s). Last edit at 10/18/2012 07:03PM by Clem.
Re: Ramps Z Stepper Issue
October 18, 2012 07:02PM
Possible solution found:

Enable signals are negative logic ... i hate negative logic. High all the time is clearly the wrong thing to do in this case.

Im guessing my Z-EN pin on the arduino is broken somehow as the pin A8 on the ramps connects fine to the Z enable but still no action.

Ive had a look at the Pins.h in my marlin and that puts Z-enable as pin 62, this page puts that as a ground. Clearly I have misinterpreted something here! On the Arduino board (and the ramps schematic) z-enable is attached to the Analog 8 pin, but this is listed as pin 89 on the pinout linked ... still no dice.

So yeah ... I am stuck again. I would like to reassign the Z-enable to another pin. Preferably one of the digital ones on Aux 2 which is unused. Can someone tell me how to do this? or even just point me at a pinout that makes sense
Re: Ramps Z Stepper Issue- Update, Now a pin reassignment issue!
October 18, 2012 07:31PM
Woop ... figured it out ...

Obviously the Analogs on the arduino board are numbered as a continuation of the digitals ... and theyre all numbered sequentially in the software ... rather than say ... using the pin numbers of the chip? anyway ... bah ...

Assigned Z-enable to pin 40 ... applied some creative (if a little ugly) soldering ( ) and voila ... working z-motors ...

Now to work on that bloody LCD
Sorry, only registered users may post in this forum.

Click here to login