Welcome! Log In Create A New Profile


DID I FRY MY BOARD?!!! confused smiley

Posted by shane.evans36 
DID I FRY MY BOARD?!!! confused smiley
January 24, 2013 07:57AM
Hey Gang,

So I'm a HS Teacher and I have been playing around with trying to get a 3D printer in my classroom so i bit the bullet and bought a RAMPS 1.4 kit and QU-BD extruder to see if I can get one going.

BUT I'm kinda new to this (AKA NoooooooooooBie).

I was trying to setup the firmware for the 3D Printer (DIY using an old Denford Micromill 2000 Axes assembly.) and I cannot get it to do anything...
RAMPS 1.4 (w/ 5 Pololu Drivers)
Arduino Mega 2560
Repitier Firmware (also trying Marlin)
Repitier Host (also trying Cura)

Now here is my issue... I tried to set up the firmware to the best of my knowledge and was VERY overwhelmed by not knowing anything nor being able to find a step-by-step guide. I set up the firmware and uploaded it to the RAMPS board and tried to load up Repitier.
When I hit the connect button in the program the steppers did a mini spaz movement and then stopped.

I kept getting weird errors about the temp not showing up and 'Gen7'.

I come to find out later that 'Gen7' was the MOTHERBOARD setting and I was "Supposed" to change this to '33' (which is RAMPS.)
Now I figured out *fingers -crossed* all/most of the settings that need to be done.

I uploaded the firmware and everything is connected without errors but the steppers / heaters / etc will not do anything. The only thing that works is the temp sensor (reading ~20 deg C

PLEASE TELL ME I DID NOT RUIN AN $80 RAMPS bc the pins were supposed to do different things..... hot smiley

Any and all Help will be appreciated!
Re: DID I FRY MY BOARD?!!! confused smiley
January 24, 2013 09:58AM
Check the 12V power supply, make sure its getting to the pololu drivers and the heater mosfets.
Re: DID I FRY MY BOARD?!!! confused smiley
January 27, 2013 05:46AM
It might be easier if you tried the RAMPS 1.4 test firmware:


After this is uploaded to your RAMPS board, it does not require a connection to your computer (other than for power). Using this will help rule out any software issues, since the actual firmwares will shut down completely if there is a problem with temperature detection issue with your hot end (safety feature).

All this firmware does is moves all your axes back and fourth slowly, as well as turn your hot ends/heated beds on and off quickly. With this loaded, put all your axes in the middle and turn it on, hope for the best!

(good news) It is highly highly unlikely that you blew anything, as the setting simply tells which outputs are hooked up to which devices - if this is wrong usually things like "moving x in the positive direction" will "turn your heater on" and other weird things. You shouldn't have blown anything (you would be the first that I know of!)
Re: DID I FRY MY BOARD?!!! confused smiley
January 28, 2013 07:40PM
Thank you for your help! I think that all is well now!
Re: DID I FRY MY BOARD?!!! confused smiley
April 03, 2013 02:04PM
I was wondering if you might go into more detail on the test software. I installed and the only LED that lights up is LED1 but it seems that others have four that light. I have power connected in both 5A and 11A point. But that is about as far as I have gotten unfortunately. Only have one stepper driver setup and it doesn't do anything.
Re: DID I FRY MY BOARD?!!! confused smiley
April 03, 2013 05:04PM
For the future you should start a new thread about the test firmware. I just happened in here and noticed the new / different question.

It has been a while since I have had the test firmware on my board, so this is from memory and might be a bit wrong, but overall should be correct.

Your RAMPS board should have LEDs on it for the hot end, for the second hotend/fan and for the heated bed. These should cycle on/off in a sequence (hot end LED turns on, hot end LED turns off, secondary LED turns on, secondary turns off, bed heater LED turns on, bed heater LED turns off, repeat)

This should happen with only your Arduino powered (hooked up to your computer with USB only - 12v / 24v not required) Edit: Just read a post from Andrew Smith that says this is not the case... so hook up 12v for the test.

The motors, on all axes (I would have to check if the extruder does it too, but for sure x/y/z) should move slowly back and fourth, maybe 5 seconds forward and 5 seconds backwards, repeat.

Did you buy your RAMPS board or did you solder it yourself? Measured your 12v power supply?

Edited 2 time(s). Last edit at 04/03/2013 05:07PM by mitchese.
Sorry, only registered users may post in this forum.

Click here to login