temperature probe not working any more...
April 11, 2013 09:27AM
Hey all,

Desperation setting in here,

Had a working ramps controller and added a fan for pla purposes last night, tried to print something, it got ~10 minutes in and pronterface stopped working, machine stopped, etc. I closed out of everything power cycled the machine and tried again.

Suddenly the temperature probe is reading 195 all the time, I tried unplugging it.... it still reads 195. Tried switching the pins in pins.h in marlin and putting the probe on t2, it reads 55 but never changes with the temperature any more...

Out of desperation switched to Sprinter and has the exact same problem, even when switching the pins again.

The power supply should have enough juice to power everything at once and was working for a bit. Everything is still getting hot and power is working, just not reading the temperature.

I checked the resistance of the 100K thermistor and it is around ~.98KOhms and changes with the heat I place on it.

The wires for the extruder heater and the temp probe are insulated from eachother so that should not have placed any voltage into the temperature probe pins.

I am all up for a hack job if it means I can avoid buying a new ArdruinoMega board. I'm cheap and don't care if it looks bad for now.

Any thoughts on what I can do to resolve this?

Sorry, only registered users may post in this forum.

Click here to login