Welcome! Log In Create A New Profile


Blown MEGA usb port?

Posted by RickM 
Blown MEGA usb port?
December 23, 2013 11:38AM
Hi all,

I've got a Prusa i3 with a RAMPS 1.4 setup - a kit from reprapdiscount with the smart display.

Yesterday I went to use the printer, and did the usual stuff - turned on the ATX power supply, then plugged it into my laptop's USB port. However the laptop immediately rebooted, and the RAMPS reset itself (the smart display reset so I'm assuming the entire ramps board reset at the same time).

I then tried plugging into the USB port without the ATX power supply turned on, and whilst it powered the MEGA and RAMPS via USB, I cant connect via pronterface anymore. I've tried different USB cables, different ports, etc however it's simply not picking up that there is even a USB device attached.

I was wondering if anyone else had experienced anything like this? The printer still works fine using an SD card for printing, but wont communicate over USB (despite being able to draw some power via USB ).

Have I blown the USB port on the MEGA? Would it be worth picking up another MEGA board and trying that out?

Edited 1 time(s). Last edit at 12/23/2013 11:38AM by RickM.
Re: Blown MEGA usb port?
December 23, 2013 01:43PM
i would pull the RAMPS board off the MEGA, then see if it connects. load some different software, like Blinkey , from the adruno library, to see if the board functions. if that is good, inspect your RAMPS board for damage. if all looks ok then connect the RAMPS and the MEGA (reload whatever firmware), with out anything else connected, (remove mtor drivers) and see if it connects. then just step through other connections, power, then add each driver one by one (with power off) until you find what ever is killing the board.
Re: Blown MEGA usb port?
December 23, 2013 02:41PM
Ah good thinking, I'll give that a try. smiling smiley
Sorry, only registered users may post in this forum.

Click here to login