Welcome! Log In Create A New Profile


Heated Bed Issue

Posted by rcazwillis 
Heated Bed Issue
January 04, 2014 07:52PM
I am trying to get my heated bed working with Ramps 1.4 & Marlin. Bed came from Sainsmart and is the 12/24v version hooked to D8. I have a big power supply set to 12v on both power in points. Thermistor is reading room temp connected to T1. LC display shows B020/060. So it is showing temp should be at 60. However, I get zero voltage out of D8.

This is a new printer and the heated bed has never been hooked up. I think the mechanics are hooked up correctly.

#define MAX_BED_POWER 255

I don't know where to go from here. Help please.
Re: Heated Bed Issue
January 05, 2014 04:26AM
There should be an led on the ramps behind the mosfet that lights up when the bed is active. Is it coming on?
Re: Heated Bed Issue
January 05, 2014 11:06AM
No, the LED does not come on. The one for the hot end does when it is heating.
Re: Heated Bed Issue
January 05, 2014 11:08AM
which board to you have selected in the firmware?
Re: Heated Bed Issue
January 05, 2014 11:47AM
Board 33
Re: Heated Bed Issue
January 08, 2014 05:23PM
Last night the bed started to heat up. Now it does not shut off. Set temp to 60 and it heated to 90+. Never reached 100. Red LED is on. Choosing cool down on the lcd shuts down the extruder, but the bed remains hot. Any ideas?

On the plus side, the ABS part I printed turned out very nice.

Edited 1 time(s). Last edit at 01/08/2014 05:24PM by rcazwillis.
Re: Heated Bed Issue
January 08, 2014 06:43PM
Can you post a picture of your wiring. That sound like you have the supply reversed.
Re: Heated Bed Issue
January 10, 2014 08:20AM
I verified the supply and it is correct; positive to the positive on the board. Last night I let the magic smoke out of something. While heating up, something started smoking. Before I could get it unplugged the smoke had stopped. Now the bed does not heat up, but everything else works fine. Did I smoke a mosfet? How do I verify? Where do I get a replacement?
Re: Heated Bed Issue
January 10, 2014 08:38AM
A picture would still be useful. If it was the mosfet smoking you should be able to see signs of it on the surface. I think it is more likely to have been a track on the pcb or a terminal block though.
Re: Heated Bed Issue
January 10, 2014 09:16AM
I will take a few tonight.
Re: Heated Bed Issue
January 13, 2014 04:53PM
What's the power supply model/rated? Also does the supply wire support more than 16A?
Re: Heated Bed Issue
January 14, 2014 12:51AM
seems that i have the same issue here
recently i finished assembly my delta-Mendel printer and when i turn printer on and tell prointerface to print, or heat bed to 110° it start to heat bed, but when thermistor shows about 40° - voltage on D8 goes from 12V to 0 resulting in heated bed stops heating (it goes by inertia up to 60° but without power at the moment). No green light at heated bed while heating.
I can reboot printer, and repeat process.

i use RAMPS 1.4 and Marlin
board type set to 33

If i set 40° it beats between 40° and 45° (no green light on board tough)

On my other similar printer there is no such big delta in tamperature (it reach temperature and beats around 1 degree)

Here is the photos:

Heated bed:

Power supply model

Power supply wiring:

Edited 1 time(s). Last edit at 01/14/2014 12:57AM by AlexNZ.
Re: Heated Bed Issue
January 14, 2014 02:02AM
Measure the voltage either side of the big PTC fuse (the yellow blade shaped things). My guess is that the current draw for your heated bed is just high enough for it to work for about 20 seconds then it trips as it's over the current limit of the PTC fuse.

Also: Make sure that they're not actually touching each other.

They work by heat and will trip once the internal temp gets to a set value. The PTC fuse issue is a flaw in the design of RAMPS. If I use a RAMPS board for a printer, I personally replace them with thick wire, then put proper fuses in-line between the PSU and the RAMPS board. They're flaky, annoying and in the case of very high current shorts, dangerous (they can actually catch fire). They also take a very long time to trip (>20 seconds) which makes debugging a fault annoyingly hard.
Re: Heated Bed Issue
January 14, 2014 02:28AM
I measured voltage on a PTC fuse - it is 0.15V

and i don't understand why green led on heated bed not lit
Re: Heated Bed Issue
January 14, 2014 04:10AM
Just something that look weird in your picture...

Most ramps the first polyfuse is much larger than the second one..


Are you sure yours are the correct way around? if not you have the 5amp fuse on the 11amp rail...
Re: Heated Bed Issue
January 14, 2014 06:28AM
Here is what i got on fuses:

looks like top one is 11 and bottom is 5 amp...

Edited 1 time(s). Last edit at 01/14/2014 06:30AM by AlexNZ.
Re: Heated Bed Issue
January 14, 2014 12:38PM
For me problem seems to be solved: there was bad heated bed. i swap heated bed from another printer (exactly the same) and it works just fine. woo-hoo eye rolling smiley
Re: Heated Bed Issue
January 16, 2014 08:53PM
Definitely fried the mosfet. Black and melted. Where do I get a replacement? What part?
open | download - P1020458.JPG (79.2 KB)
Re: Heated Bed Issue
January 16, 2014 10:46PM
The standard MOSFETs on a RAMPS board aren't really good at high currents.

If you're staying under 30V (which is 99.99% of people) then I suggest something like the IRLB8743. Handles higher current, has a lower Rds(on) (= more volts to your heated bed), etc. It's used on RAMPS-FD and on other electronics like Gen7.


BTW: The IRLU8743 is almost identical to the IRLB8743.

Both devices are pin-out compatible with the STP55NF06L (so you just solder it in the exact same way).

Numerous electronics places sell them, so it'll depend where you're located as to what is convenient to you.

Digikey have the:
IRLB8743 for US$1.42 (at time of posting)
IRLU8743 for US$1.60 (at time of posting)

Note: I did look at E14/Newark, but their US site seems to not have the range the AU site does, which is a pity.

PS: The forum seems to be mangling the links, which is why I had to edit things. It "works" though the links are still not what I entered.

Edited 5 time(s). Last edit at 01/16/2014 10:54PM by Cefiar.
Re: Heated Bed Issue
January 16, 2014 11:06PM
Thank you. Very helpful.
Sorry, only registered users may post in this forum.

Click here to login