Welcome! Log In Create A New Profile

Advanced

Thermistor Troubles - SOLVED

Posted by chrissb 
Thermistor Troubles - SOLVED
February 08, 2014 11:43PM
Hey there everyone!

First time builder here. I've just finished the mechanicals/hardware for my Prusa i3, and I've spent the last day or so working on the electronics.

I'm using RAMPS 1.4 and Marlin firmware, and Pronterface to control/test the printer. I've got control working for each motor/axis, endstop switches working and software limits for each axis working. In other words, all movement looks to be good.

I'm currently trying to get the thermistor for the heated bed to work. It is a 100k EPCOS thermistor, and when I wire it to T0 on the RAMPS board it reads the correct value inside Pronterface - e.g. it shows approximate room temperature. However, I believe T0 is for the hotend thermistor? In the software, this is showing up as "T", whereas "B" is showing 0 - I assume "B" corresponds to the heated bed thermistor?

I've tried connecting the thermistor to both T1 and T2, and in either case, the software continues to show "B: 0". When I do this "T" goes back to zero again, as the thermistor is no longer connected to T0.

Is there some trick to getting the thermistor to work on T1 or T2? I'll attach my configuration file so anyone kind enough can take a look - I've set my temp sensors as shown below:

#define TEMP_SENSOR_0 1
#define TEMP_SENSOR_1 0
#define TEMP_SENSOR_2 0
#define TEMP_SENSOR_BED 1

However the software still doesn't recognise the thermistor when it's connected to anything other than T0.

Hopefully there's some simple novice mistake that I'm making! If anyone can lend a hand or point me in the right direction, I'd appreciate it greatly!

EDIT: One more thing I'd like to add - at the moment, the heated bed won't activate when I turn it on in software. I'm assuming that this is a firmware thing that won't let it turn on without the thermistor registering - is this correct?

Thanks for your time,
-Chris

SOLVED Edit:
Well, I can confirm it was a stupidly obvious rookie mistake. Apparently if there's nothing connected to T0, T1 and T2 won't work (or at least, won't show up in Pronterface) either. I didn't think about this because at the moment I'm still waiting on my hotend and the thermistor to go with it, so my only thermistor is for the heated bed. I've just put a 100k resistor in place of T0, and now T1 is registering the thermistor for the heated bed just fine.

Hopefully this helps someone else - if anyone else makes the same silly mistake!

Edited 2 time(s). Last edit at 02/09/2014 01:13AM by chrissb.
Attachments:
open | download - Configuration.h (28.6 KB)
Sorry, only registered users may post in this forum.

Click here to login