Welcome! Log In Create A New Profile


Thermistor is giving wrong value

Posted by Bas89 
Thermistor is giving wrong value
February 26, 2014 02:15PM
Hello everyone,
I'm completely new to making 3d printers, but I'm trying to build a delta printer. I've bought a freaduino board and a ramps v1.4. So far I finished the mechanics and connected all the electronics. So far so good but now I'm starting with the firmware.

I've downloaded the Arduino IDE and tried to install blink on my board and immediately ran into problems. First I stop the automatic installation of the driver from the board. Then I did a manually installation of the correct driver as decrypted on Arduino.cc, after this I tried to install blink. This didn't work. After searching al lot on the internet I founded out that my chip on the main board is a different one than the one on a original arduino board. This chip needed a extra driver for windows or something like that. I installed this driver which I found on the internet somewhere with the board plugged in. After the installation I could install blink with arduino 022. So after installing blink I installed the 3DR marlin firmware from richrap.com with some modifications to it. So far still so good winking smiley

But after all the struggling with the driver I installed the correct firmware on my board. After this I installed pronterface on the pc and started testing the printer. Just after starting up pronterface the first error occurred. The printer is shutting down because the max temp. form the extruder is triggered. But my extruder isn't warm at all. I have not started to heat the extruder. So after this I did a check on the temp. For the extruder pronterface is saying it is 357degrees Celsius with is not possible because the extruder is cold. The heatbed temperature is saying it is 14degrees with could be correct because I'm working in a cold room at the moment. When I switch the thermistors the same error occurs in pronterface, so my conclusion is that the thermistors are also not broken. Al the wiring is done correctly and there are no shorts.
I think my T0 is broken in so now I want to change T0 into T1 in the firmware but I don’t know how to do it so my question is if someone could help me with this. And I’am not sure if this would solve my problem

My Configuration h. (temperature part) is

#define TEMP_SENSOR_0 1
#define TEMP_SENSOR_1 0
#define TEMP_SENSOR_2 0

My pins.h is
#define E0_STEP_PIN 28
#define E0_DIR_PIN 27
#define E0_ENABLE_PIN 24

#define TEMP_0_PIN 1
#define TEMP_1_PIN -1
#define TEMP_2_PIN -1
#define TEMP_BED_PIN 2

#define HEATER_0_PIN 4
#define HEATER_1_PIN -1
#define HEATER_2_PIN -1
#define HEATER_BED_PIN 3

Hopefully someone can help me with this problem. If someone has the same problem as me with the freaduino board let me know and maybe I can help you out with it
Re: Thermistor is giving wrong value
February 27, 2014 04:54AM
It might also throw the maxtemp error from heatbed after switching the thermistors. So verify if the maxtemp error is still coming from T0. Maxtemp error basically comes from a short circuit, so measure the resistance between T0 measurement pins. If the resistance is near zero without the thermistor connected, there is probably a fault in your RAMPS board.

edit: And you cannot use Pin 1. It is a dedicated pin for usb communications.

Edited 1 time(s). Last edit at 02/27/2014 04:58AM by jkoljo.
Re: Thermistor is giving wrong value
February 27, 2014 02:43PM
Indeed there is a fault somewhere in my ramps board. The two pins for the thermistor for the extruder give me a value close to zero when I measure it. The other pins are giving me around about 6.2 kohm. Is it possible to use the pins for the extruder 2 and exclude the pins for extruder one.
If its possible do you know how I need to put it in the sofware. Pin 3and4 and pin 5and6 seem to be correct.

Thanks for your help!!
Re: Thermistor is giving wrong value
March 06, 2014 04:54PM
Hi Bas89,

Sorry..I didn't quite understand..what is the resistivity of your thermistors?
It should be something around 100Kohm.
If it is zero what is faulty then is the thermistor.

Edited 1 time(s). Last edit at 03/07/2014 01:33PM by ndujar.

Re: Thermistor is giving wrong value
March 07, 2014 01:27AM
I think he means he's measuring the RAMPS board inputs the thermistors connect to.

Hopefully he did this while the board was off, as this in itself could damage the thermistor inputs.

Edited 1 time(s). Last edit at 03/07/2014 01:29AM by Cefiar.
Re: Thermistor is giving wrong value
March 07, 2014 01:26PM
I measured indeed the pins on the board where you connect your thermistors to. And I did this while the board was of.

Does someone of you know if it is possible to use T2 for the extruder instead of T0? T1 is already in use for the heated bed.
Re: Thermistor is giving wrong value
March 07, 2014 01:46PM
It is absolutely possible. Just take the connector off the T0 and put it in the T2...However, then you will have to fiddle a little with the firmware, and that will only lead you to more trouble...

With the information you have provided, I still believe that the faulty device might be the thermistor, not the RAMPS. To definitely diagnose that, you can do two simple things:

  • Measure the resistivity in ohms and in Kohms of your thermistor. If it is zero then it is fried and you need a new one
  • With the printer on and the Pronterface connected to it, put different resistors (in the Kohm range) between the two pins of the suspected faulty input (T0). If the board is ok, it should give you different readings for each resistor. Just be careful not to touch any other pins to avoid any shorts and you will be safe...winking smiley

Edited 1 time(s). Last edit at 03/07/2014 01:47PM by ndujar.

Re: Thermistor is giving wrong value
March 07, 2014 01:52PM
I'm sure it is the ramps board. My T0 is 3.4ohm while the other pins are around about 6.2Kohms. Sow my board is fried.
Indeed as soon as I need to fiddle with the firmware I get in more trouble because I don't really understand that mutch the firmware. Do you have more experience with writing firmware?
Re: Thermistor is giving wrong value
March 07, 2014 02:03PM
Yes, I do have experience in writing firmware and I must say that it is bad...bad, bad...eventually you always end up forgetting something and you cannot be sure whether it was the firmware or the hardware...

I strongly reccomend you to make the simple test of switching the hotbed pins into the T0, just to make sure...

Re: Thermistor is giving wrong value
March 07, 2014 02:11PM
Thats something what I did already I change the thermistor of my extruder with the one from the heated bed and than T0 is still giving me to high values. After that I measured the pins and T0 is 3.4 ohm with is close to zero compared to T1 and T2, so unfortunatelly my ramps board is broken an I need to buy a new one ore change the firmware sad smiley
Re: Thermistor is giving wrong value
March 07, 2014 02:43PM
Hmmm..well, then firmware it is...
In my (fully functional) RAMPS 1.4 the polymeter measures 5.6Kohm between every pair of pins (T0, T1 and T2). If in your case you have 3 ohm then you're right, there is short somewhere...my apologies...

I'm sorry about that, but with the provided information I was unable to discard the easiest solution (i.e. replacing the thermistor...).

Anyway, assuming that your firmware is a Marlin (or a Sprinter), you have to find the pins.h file in the folder where you have the firmware.
Inside of it there is a line that reads like this:

* Arduino Mega pin assignment

Which you will see has the coincidence with the number 34 (RAMPS) that you set up in the configuration.h file

Go down there a few lines and where you find this:


Try swapping the value of the TEMP_0 with any value between zero and fifteen, being 12 and 14 the numbers with highest odds:


I hope it helps!

Re: Thermistor is giving wrong value
March 08, 2014 01:26PM
Firmware it is indeed. You don't need to say sorry for that, always important to dubble check the simple things. But your advise helped me a lot. I've changed the number to pin 10 and now my temperature for the hotend seems to be correct. Thank you verry mutch. On to the next problem or printing!!
Re: Thermistor is giving wrong value
March 08, 2014 01:30PM
grinning smiley haha! That's the spirit!!

You're welcome!

Sorry, only registered users may post in this forum.

Click here to login