Welcome! Log In Create A New Profile


Two steppers work, the others just wont. Please Help!

Posted by Laton 
Two steppers work, the others just wont. Please Help!
April 12, 2014 05:54PM
Just came into the final straights of assembling my kossel mini, after a rather long shipping delay.

The Problem now is rather peculiar. Most seems to be working, namely, the endstops, the fan the heater and the thermistor.

While the y-tower appears to be in working order, it moves when I press the buttons in Pronterface, the x and z-towers don't move at all. I had the same issue with the e-stepper, but that has worked itself out and might have had something t do with me not allowing cold extrusions (m302).

Still, tower x isn't working and tower z neither. I tried everything someone inexperienced would, including changing around wires, switching around the Pololu s and measuring whether there is some current on the drivers. All drivers had the same readings as the working ones. When rewiring the working plugs on the RAMPS to another tower the other towers worked, so I ruled out a problem with the steppers and the cables. I played around with the driver's potentiometers in order to see some effect, but without success. They are all set to apprx. 0,270 V. Then I touched the drivers with the measuring equipment, at least one of the otherwise dead steppers reacted immediately by twitching.

According to the build plan I used I only require the right set of power inlets to be powered as the 11A inlets are only required for the heated bed. The 5A set is powered by a 70W, 6A laptop DC. To test, I plugged the same cable into the 11A power inlet as well, but no change. Still only two of four steppers working.

After searching through the forum I also re-checked the jumpers below the board, they are all there and I doubt that jumpers tend to be faulty.
(Editsmiling smiley Unfortunately I might have fried the arduino board by connecting it to a connector with + & - the wrong way round. It smoked and the transformer (or whatever that thing next to the power-jack is called again) needs a replacement. The drivers are still in good condition, but something underneath could be broken, but than not for all connectors.

And on top of that, even though the LCD is lighting up when you press 'light', it isn't working properly either, I probably dont have the right library for the screen on hand. The make is based on this design, just without the fan-plug, as far as I see. sad smiley

I dont know what to look for anymore. Please help.


Edited 2 time(s). Last edit at 04/12/2014 07:44PM by Laton.
Re: Two steppers work, the others just wont. Please Help!
April 12, 2014 06:22PM

I just thought it cant be any worse. Well, I got the x-axis to work by juicing up the output of the potentiometer a little more. Unfortunately, the z-axis was still standing still. I replaced the driver, forgot to unplu git and since i plugged the z back in (under power) the x-axis stopped turning as well...
Re: Two steppers work, the others just wont. Please Help!
April 28, 2014 04:47AM
Seems to be have been a connection problem between the controller and the shield.
Sorry, only registered users may post in this forum.

Click here to login