Welcome! Log In Create A New Profile


Extruder motor not responding - SOLVED

Posted by Nived 
Extruder motor not responding - SOLVED
April 12, 2014 07:50PM
please help, I have just finished assembling a printer with ramps 1.4 + reprap discount smart controller running marlin. all axis, hot end, extruder fan, and heated bed work great.

The only thing i can not get to work is the extruder motor.
- i have tried swapping drivers and all drivers work
- tried running the extruder motor from the z-axis and the motor runs and is able to pull filament when connected to the z-axis
- made sure to heat up the hot end to 240 and the heat bed to 110.
- also tried editing the pins.h file to swap E0 and E1 and run the driver from the E1 slot

I do not have any endstops installed yet, but i do not see why this would prevent the extruder motor from turning.
i ran a test cube print and the printer goes through the motions of printing but does not pull any filament.

With being so close to printing, this problem is driving me nuts...
any input would be greatly appreciated


i swapped out the arduino mega and everything is working now

Edited 1 time(s). Last edit at 04/14/2014 01:04AM by Nived.
Re: Extruder motor not responding
April 12, 2014 10:39PM
nevermind.... re read your post... not applicable.

Edited 1 time(s). Last edit at 04/12/2014 10:40PM by Dust.
Sorry, only registered users may post in this forum.

Click here to login