Welcome! Log In Create A New Profile


Burnt component?

Posted by XiaZ 
Burnt component?
May 16, 2014 06:45AM
Hello everyone,
I'm kind of new to the forum (been couple of months since I joined the community), however I've built a Prusa i3x: everything was working fine, until one heatsink fell off the extruder stepper driver. I'm not sure what happened next, just heard a little buzz and then the LCD power lowers down, plus no axis moving anymore. Tried to re-upload firmware on Arduino Mega, but couldn't recognize the USB port on PC (while I could before this happened). I've dismantled the electronics, no evidence of burn components (might post photos if needed).
The point is that printer turns on fine, but power lowers down after a while, having the LCD light to power off, revealing no words written on the screen. It'd be really great and kind if anyone of you could help me.
Thanks in advance.

Xia Zhou

Edit: added a video showing how the LCD auto-turns off. Looks like something in the electronics overheating, but I don't know which part is damaged.

View My Video

As you can see on the video, the LCD shows random temperature values, showing the heated bed heating even if T1 is not connected at all.

Edited 4 time(s). Last edit at 05/16/2014 10:51AM by XiaZ.
Re: Burnt component?
May 17, 2014 03:25AM
sounds like you wounded your voltage regulator residing on your arduino mega. its the 3 legged + 1 tab chip right next to the round barrel power jack on the arduino. it's labeled AMS1117. it'll put out 5V at 1A and typically gets the arduino board pretty hot under normal printing use. The regulator will burn out if you look at it cross eyed so have several spares on hand (get a 10 pack on ebay for about $3). You can verify by plugging in a 5V source into the barrel jack, the lcd display and arduino will function normally (dont run your printer this way, this is only for debugging)

to replace the AMS1117, you snip the leads on the chip first and bend the body up a little bit against the bigger tab. then get out your solder iron and take off the snipped leads one at a time. if they struggle add a little 60/40 solder then try removing (lead free solder really sucks, so add lead to get it to flow easier). then add a little solder to the big tab after you heat it up and then remove the rest of the regulator with the tab. clean up the pads and attach the new regulator. should take about 10 minutes. dont tug to hard on any of the leads as you can tear off the surface mount pad from the board, then you'll have to use your spare arduino for sure.

-or- you can just use your spare arduino mega. what you don't have one? time to get one. The sainsmart mega works pretty good and has good build quality but only costs about $18 on ebay.
Re: Burnt component?
May 17, 2014 11:04AM
Dear robr45acp
thanks for the prompt answer given. Unfortunately, I'm not so good with electronics and stuff. I've attached a photo, is the one inside the red rectangle the Voltage Regulator you were talking about? Not labeled AMS1117 on mine, it has written 269-5G RG312 on mine.
I do apologize for not being so technical and specific.

Thanks very much in advance for your help.
open | download - IMG_0542.jpf (381.3 KB)
Re: Burnt component?
May 17, 2014 08:02PM
yep, that is the culprit. if you plug 5V into the barrel connector and the mega works, then its likely the 5V regulator is bad. the ramps sends 12V to the mega and that is directed into that regulator which makes 5V which powers the mega and the LCD. if the regulator goes out, you loose 5V and the mega and LCD stop working. if you can verify that the mega still works with external 5V then you have two choices. 1. replace the regulator or 2. cut the ramps diode that feeds the mega and power the mega with an external 5V supply. I'm leaning towards using an external 5V supply on my ramps since the regulator gets really hot during normal use. that way you remove yet another heat source from the board stack.
Re: Burnt component?
May 17, 2014 08:12PM
Dear robr45acp,
thanks for the clear explanation given, really appreciate that.
Unfortunately, I'm not able to power supply 5v directly to ArduinoMega, as my PSU is wired to RAMPS which is later fit on the ArduinoMega. I've been looking for some spare 5v plugs around my house, but didn't happen to find any. As soon as I'll be able to verify that, I'll be following your instructions.
Thanks very much in advance for your kind help.

Edit: found a spare 5v output plug in my house, while plugged ArduinoMega ON light is on (it does 2 blinks also near the spot labeled L), still it doesn't get recognized by Arduino IDE. Multimeter measured (20V scale): Pin 1 (Red) / Pin 2 (Black) gave me a result of -3.43

Edit (2): tried with a 7.5V output plug, since Arduino suggests to power supply 7-12V range, still board doesn't get recognized. Multimeter measured (20V scale): Pin 1 (Red) / Pin 2 (Black) gave me a result of -5.00

Edited 3 time(s). Last edit at 05/18/2014 09:52AM by XiaZ.
Re: Burnt component?
May 19, 2014 02:41AM
sounds like your arduino has other problems. time to switch to your spare. maybe the onboard usb translator is damaged.

I snipped the D1 diode on my ramps card and powered my arduino with an external 6V supply. it works as expected but more importantly it eliminated the excessive heat buildup under regulator on the arduino board.

by the way, your original problem was a rogue heatsink. I hope you purchased thermal cement to permanently bond the heat sink to the stepstick. also spread some of the cement onto the exposed tops of the header pins to provide some electrical isolation. you could use artic-silver adhesive but it's pretty expensive.

try this stuff on ebay

Heatsink Glue
Re: Burnt component?
May 19, 2014 05:49AM
I personally prefer the Arctic Alumina 2-part adhesive, as it's non conductive and non-capacitive. While Arctic Silver 2-part adhesive is supposedly non conductive, it's not non-capacitive. It shouldn't make a huge amount of difference, but I like to be careful. winking smiley

Note: Make sure to clean the heatsink and the top of the chip. Isopropyl works well. You want no residue of tape or any grease (skin or otherwise) on the heatsink or the chip, otherwise it may not stick properly and you'll be back where you started.

Edited 1 time(s). Last edit at 05/19/2014 05:51AM by Cefiar.
Re: Burnt component?
May 19, 2014 05:47PM
Hello there, today I bought a new Arduino Mega2560 Rev3: it still doesn't work.

Mega+RAMPS+LCD Shield via USB: faded text.
Mega+RAMPS+LCD Shield via PSU: LCD shows trash text.
Mega+RAMPS+LCD Shield via PSU (removed E stepper driver): LCD works for 5 sec, then switches to trash text again.
Mega+RAMPS+LCD Shield via PSU (removed E and X stepper drivers): LCD works fine.

Now, is it RAMPS damaged or the drivers? Could a couple of wounded drivers, short out the entire RAMPS board (making it not to work properly)?
I'm pretty much discouraged at the moment, please any help will be greatly appreciated.

Bought couple of spare drivers, turned trimpots all the way down (CCW), but the board still seems to be messed up.
By testing the driver boards, I've noticed that with stepper drivers plugged into the RAMPS, the shield loses power.
What component of the RAMPS board is this loss of voltage related to?
It the shield to be thrown away or repairable in your opinion?

Thanks in advance.

Edited 7 time(s). Last edit at 05/20/2014 08:41PM by XiaZ.
Re: Burnt component?
May 21, 2014 09:28PM
This seems to be that the 5V regulator on the Arduino Mega you have isn't capable of putting out the power needed to run everything. The backlight on most LCD's use a lot of current, which is probably the part causing the most issue. Note that when you power the Arduino Mega via USB, the regulator on the Arduino Mega is not used - it gets 5V direct from the USB port.

If you have an ATX PSU, you could use the 5V stand-by line to run your board. I think there are details on what you need to do/change on the RAMPS wiki page.
Re: Burnt component?
May 22, 2014 11:03AM

Thanks for your reply.
On the old ArduinoMega2560, the USB controller is damaged, so I'm not able to power it directly from the USB. Tried with a new Mega I just bought, LCD works fine.
It seems that something is driving less power into the drivers: measured one Stepstick (which I'm sure it's working) at the 12V and 5V pins, accordingly having 3,40V and 4,10V from multimeter reading.
When more then one driver is plugged into the RAMPS, LCD shows faded text or trash text.

Thanks in advance for your help.
Re: Burnt component?
May 22, 2014 07:32PM
This sounds like your drivers are fried.
Re: Burnt component?
May 22, 2014 09:41PM

It actually shouldn't be, just bought new stepper drivers and tested both of them (old and new ones): same values from 12V and 5V pins.
Re: Burnt component?
May 26, 2014 08:46AM
Hello everyone,
just bought a new RAMPS from reprapworld.com, shipped in 5 days as expected. However, the shield has not diode D1 installed: this should allow external power directly to Arduino (7-12V) through the barrel jack.
However, with RAMPS plugged to PSU (both 12V 5A and 11A), the power supply seems to turn off (led on PSU is off). PSU comes back to life as I plug 11A port only: multimeter shows 12V on those PS pins as well.
Extruder doesn't heat via pronterface, nor does X axis move (plugged motor/endstop/driver of X axis only).
Is there any way to find out what is wrong?
Re: Burnt component?
May 26, 2014 09:33AM
The 11A power rail is only for the heated bed. The 5A rail powers the RAMPS board, steppers, and nozzle heater(s). Ignore the 11A rail in your troubleshooting.....
Re: Burnt component?
May 26, 2014 09:42AM
Thanks for your reply.

Having 5A rail plugged only, PSU's led is off: measured 5A rail, I have 0V.
Having 11A rail plugged only, PSU's led is on: measured 11A rail: I have 12.

This RAMPS from reprapworld.com have no D1 diode installed: could its absence lead to a short?


Edit: Or maybe the D2, since 5A channel is bridged by that diode, else going to GND, which would explain PSU shutting off.

Edited 1 time(s). Last edit at 05/26/2014 11:57AM by XiaZ.
Re: Burnt component?
May 28, 2014 03:36AM
D2 could have been put in backwards, or it may have failed and gone short.
Re: Burnt component?
May 28, 2014 08:21AM
Thanks for your answer.
I thought the same thing, it doesn't look like it's backwards. I don't know how to test to verify if it's working (I'd rather not to de-solder the diode from the board), any idea?
Here are some pics of the board itself, I hope they can be useful.

Thank you very much.

BOTTOM [imageshack.com]
TOP [imageshack.com]
DETAIL [imageshack.com]
Sorry, only registered users may post in this forum.

Click here to login