Welcome! Log In Create A New Profile


No Power To Heated Bed

Posted by Miterez1 
No Power To Heated Bed
May 31, 2014 04:13PM
Hello all,

I have been using my printer for several months now. I just recently printed a part that took 22 hours and then after about an hour break I printed another part that took 7 hours. During both prints everything worked just fine.
When I went to preheat for my next print I got no temp. change on the heated bed.
First, my RAMPS board is from reprapdiscount.

LED 2 is NOT lit.
Voltage from my power supply is 11.99 and 11.96 at the RAMPS board. My PSU is rated 12V 30A.
I checked voltage at D8 and get nothing. Perhaps I'm measuring this wrong. Should I probe one of the D8 screws and put the negative probe to the ground at the PSU? (I'm such a tool and over think everything)
I checked heated bed Ω. It's good.
With the PSU unplugged and disconnected from the RAMPS board I checked Ω on both RAMPS fuses. They're good.
I checked diode (D2) and have a reading of 493 mV when I connect the negative multimeter probe to the cathode. I get 1419 mV when I reverse the probes.(the negative multimeter probe connected to anode.) I'm a newbie when it comes to digital electronics but the 1419 mV seems odd. I understand that a diode is essentially a check valve, but shouldn't the 1419mV value be lower?

I've read that it could be the MOSFET. I guess that is the next thing to check, right?
I have noticed that others have replaced the fuses with replaceable fuses. I would definitely like to do this but I'm not aware of what size/rating of fuse to get. Any help with this would also be appreciated.

Edited 2 time(s). Last edit at 05/31/2014 04:15PM by Miterez1.
Re: No Power To Heated Bed
May 31, 2014 10:15PM
The 2 pins on D8 are a constant +12V supply and the FET which switches to ground.

If neither pin has 12V on it, then F2 (the 11A PTC fuse) has tripped.

If you're going to swap it for another fuse, I'd recommend either a 10A or 15A auto fuse.

In the meantime, make sure that F1 and F2 do not touch each other. These devices work by heat and when they touch the heat transfers from one to the other, leading to one 'tripping' too low. If you haven't got a fan on your electronics, now is the time to think about one, even only till you replace the PTC fuse with another.

Given it was a very long set of prints, I think it's just tripped due to extra heat.
Re: No Power To Heated Bed
June 01, 2014 12:51AM
I rechecked D8 and both pins are 12V. The fuses are not touching each other. I decided to check for any physical damage on the bottom of the shield or the Arduino board and saw nothing wrong. At this point the printer has been off for many hours. Still no power to the bed. FWIW, I have always had a fan blowing across the entire RAMPS board. Is it possible to test the FET in-circuit?
Re: No Power To Heated Bed
June 01, 2014 05:49AM
If the LED is not illuminating (assuming its sound), and you have 12v on both D8 pins, then the Mosfet is not being switched on. You need to check if there is 5v on the Mosfet enable pin. The Arduino will put 5v on it any time you switch the heater on - until temp is reached. If you get no signal there, then the Arduino is not enabling it for some reason - faulty controller, thermistor faulty etc or the "fet is dud.

Edited 1 time(s). Last edit at 06/01/2014 05:51AM by waitaki.

Waitaki 3D Printer
open | download - mosfet.jpg (46 KB)
Re: No Power To Heated Bed
June 02, 2014 11:20PM
I took a reading on the Mosfet pin and I didn't get 5V. I'm planning to order this based upon posts that I have read stating that the current RAMPS MOSFET heats up much higher than these.

I checked continuity on my thermistor and I'm getting nothing. The good thing is that I have an extra one sitting around.
Now the real question is how do you carefully remove the small glob of plumbers putty without breaking the heated bed? eye rolling smiley
Re: No Power To Heated Bed
June 03, 2014 05:05AM
If the thermistor is open circuit then the Controller won't switch it on (no 5v to pin 1) but I would have thought that an under temp warning would have triggered. Anyway, change the thermistor first if it is indeed broken. Dunno about putty on it but that shouldn't be too much to remove. Did it come like that?

Waitaki 3D Printer
Re: No Power To Heated Bed
June 03, 2014 11:55AM
Now the real question is how do you carefully remove the small glob of plumbers putty without breaking the heated bed? eye rolling smiley
Plumber's putty? All plumbers putty I've ever used is non-hardening and it should just pop off although I'm not sure about it's thermal properties. Do you mean muffler putty? Or maybe something like JBWeld? If you mean one of those they'll scrape mostly off if you're careful.
Re: No Power To Heated Bed
June 05, 2014 02:41PM
Replaced my thermistor and hooked everything back up. Problem is SOLVED. Thank you very much!!

cdru, my mind was thinking JB Weld and I was typing plumber's putty. Plumber's putty would be such a great mess to clean up.tongue sticking out smiley

Since I have all my tools out I went ahead and picked up 15A and 5A automotive blade fuses. I kind of like this RAMPS fuse replacement method.(See photos near the bottom of the thread) I'm assuming there are no further changes that need to be made when strictly replacing the fuses, right?
Sorry, only registered users may post in this forum.

Click here to login