Welcome! Log In Create A New Profile


Motors going crazy, board heating up

Posted by kman1863 
Motors going crazy, board heating up
May 18, 2015 04:12PM
Hey guys, I seem to be in a bit of a fix here.

I have an Arduino Mega, RAMPS 1.4, and a 12v (30A 360w) power supply. I tried to send commands to my motors (bipolar steppers) via pronterface, but they have been extremely unreliable. Sometimes they twitch, sometimes they jump, other times they don't move at all. Recently, they simply rotate haphazardly in one direction, then another. Nothing much happens when I tweak the pots, except the motors' whining gets higher or lower. When I run the test code for the motors, they still do this. Last night I added jumpers on the pins underneath the Pololu drivers, which seemed to have little effect; the only difference was that the Mega got extremely hot. Today, I attempted to jump the endstop pins to see if this would change anything (I don't have endstops hooked up yet). I lost connection immediately and the Mega got too hot to handle under the IC. I removed them, and I still have no connection. It connected with my computer for a second when I pressed the two boards together quite hard-- could this mean I have a cold joint? I have absolutely no idea what's going on. I'm at a total loss. Any advice would be awesome. Thanks!


Edited 1 time(s). Last edit at 05/18/2015 04:13PM by kman1863.
Re: Motors going crazy, board heating up
May 19, 2015 09:32PM
I had similar problems with my Ramps, in case you havent done so look underneath the Ramps and Arduino to check for shorted pins. My Z axis had a tiny peice of solder bridging pins that resulted in sporadic movements. Also if you havent done so try a single axis at a time for motion to make sure your steppers are good. I had one of mine that would reboot the whole Arduino when I turned the electronics on. Remember to TURN OFF your electronics before plugging or unplugging things.
Sorry, only registered users may post in this forum.

Click here to login