RAMPS 1.4 stops working
May 26, 2015 04:04AM
I have got RAMPS 1.4 with Arduino MEGA. I have been printing for two days and I have just calibrated the printer. Than I lost connection. I tried several times reconnect and it happened again and again. I can heat the nozzle and the heatbed without problem, but if I try to move the stepper motor, the connection is lost after several turns of the motors (not extruder, but just with moving X and Y axis).

I have got one more Arduino MEGA but I do not want to switch them because I am scared I could break it down. I have tried load there new firmware with no success no far.

Any idea what to do?
Thank you,
Jan Knížek
Re: RAMPS 1.4 stops working
May 26, 2015 05:00AM
I'm guessing that your power supply voltage is sagging when you try to move your motor(s), so that the MEGA board resets and stops.

Try to isolate the problem... is it just the X axis or just they Y axis? If it's just one, then that's likely the problem. If it's either, then it's probably the power supply.

Check the connections to your motors to make sure they're not shorted out. If they're OK, check your power supply voltage.
Re: RAMPS 1.4 stops working
May 26, 2015 05:25AM
Thanks for reply.
It is on both axis. Do you mean to check whether there are really 12V on the output of the powersupply?
EDIT: I tried measure the voltage and it is sometimes under even 11V (one time it was even 2V, but not sure whether that was not my mistake). I lose the connection now even with heating of the nozzle or the heatbed. Only Z axis now seems alright. I will try to find another powersupply.

Edited 1 time(s). Last edit at 05/26/2015 05:53AM by knezi.
Re: RAMPS 1.4 stops working
May 26, 2015 09:18PM
What power supply do you have? I'm guessing it isn't powerful enough.

Try running your steppers with both heaters turned off.
Re: RAMPS 1.4 stops working
May 27, 2015 06:47AM
Thank you,
I have got from PC 350W. I substituted it with 450W and now it seems working. It is weird for me that it worked for a while even with 350W and 450W did not work until I unpluged and pluged all the wires.
It works now and hopefully will work.
Re: RAMPS 1.4 stops working
May 28, 2015 02:20AM
That sounds, like you have a bad contact somewhere. Bad solderjoint or broken cable.
Perhaps a possible shortcut...

Check your wires and boards, please
Re: RAMPS 1.4 stops working
May 28, 2015 04:30AM
Check your power connectors on the RAMPS for melting. The cheap Chinese knockoff of a Molex connector used on these fail well below what the part should handle, is a common problem, and is consistent with your description of "did not work until I unplugged and replugged all the wires . . . "

- Tim
Re: RAMPS 1.4 stops working
May 28, 2015 07:52AM
I will check everything out. Could be the problem bad wiring of endstops? E.g. short circuit on some wires which are connected to the endstops.
Sorry, only registered users may post in this forum.

Click here to login