Welcome! Log In Create A New Profile


Unwanted and unexpected z-movement during print

Posted by Gmuld 
Unwanted and unexpected z-movement during print
May 26, 2015 01:15PM
Hello everybody,

I am in the process of building an ox-cnc from openbuilds, but wanted to be able to use it as a 3d printer as well, so therefore I connected everything to a arduino with a RAMPS 1.4 board, according to the following link: [www.instructables.com]
For the X and Y axis, I use a nema 23 with DQ542ma driver with 213,333 steps per mm. (connected with timing belt)
For the Z axis, I use a nema 17 with DQ420ma driver with 800 steps per mm. (connected with lead screw)

I am using fusion 360 for cad and cam purposes, the gcode will be loaded to repetier for OSX, which sends it out to the ramps which should do the rest.
The ramps is running on marlin firmware and therefore I use the marlin post processor in fusion 360. This is not a standard, but found in on a forum. The code looks good!

So now more about the issue:
I try to make a part (as test) with a circle in a square, without any z displacement in the code. Halfway the circle the z axis starts to move upwards.
Every time at exactly the same moment and place. Print speed is not relevant for the moment that it occurs, but has effect on how fast the Z goes up.

I tried a lot of things already, but can’t get it sorted out and don’t understand what is happening, so I decided to ask it on the forum.

What I tried so far:
- Lowering steps per mm, so the board has less to process. (no difference)
- Replace cable towards Z-axis to prevent interference between the axis’s. (no difference)
- Try all three DQ420MA drivers on Z-axis. (no difference, accept that one driver gives faster displacement, while settings where equal)
- Try more different shapes and corners (they go ok without any z displacement)
- Run with power to the Z-stepperdriver, but without the pulse cables connected (this resulted in no z displacement)
- Switched the DQ542MA from the x axis for the DQ420MA from the z and changed current and step settings with jumpers. This resulted in no movement for z, but a strange behavior for the x axis.

I added an image of the electronic setup, which looks a little messy, since I am trying to get it working. I am planning to mill a nice case as soon as the machine is working properly.
Now I am wondering if someone has a clue about what is going on. I am trying to get it sorted out for four days now, learned a lot during this, but not the thing to solve it.

Thanks in advance and please ask if you need more information to help me out.

regards, Gertjan.
open | download - IMG_0180.JPG (539.3 KB)
Re: Unwanted and unexpected z-movement during print
May 26, 2015 09:28PM
Hi Gertjan,
How have you got Marlin configured? In particular, have you got Marlin configured as a Delta printer? Check Configuration.h

Also possible is something screwed in your pins.h file... maybe you have the same pin being used for both X and Z or both Y and Z?

Re: Unwanted and unexpected z-movement during print
May 27, 2015 02:43AM
Hello Frank,

Thanks for your reply. I forgot to mention that there is no problem when I move the machine with the controller in Repetier.

So I don't think it is caused by any mis-configiration regarding the things you mention.

But thanks for thinking! and I am looking forward to more reactions

Kind regqrds,
Sorry, only registered users may post in this forum.

Click here to login