Relay Board
July 02, 2015 02:40PM
I've recently layed out my first PCB. Having never done this before I have a question about diodes. I've added a diode to each relay. My thoughts in adding D1-D3 were to dissipate the voltage in the collapsing field when the relay is deactivated. Are the diodes wired correctly to do this?

thanks
Attachments:
open | download - Printer Accessory Board SSB Rev B sch.png (281.5 KB)
Re: Relay Board
July 03, 2015 01:59AM
Yes, looks good, just make sure the diodes are rated for a much higher voltage. The coil can produce high voltage spikes...
Look for "surpressor diodes" for that purpose
-Olaf
Re: Relay Board
July 05, 2015 11:37AM
o lampe thank you
Re: Relay Board
July 06, 2015 03:22PM
Are those the actual relay part numbers you're using? Or did you just use them for the symbols/layout? Those relays rated load is only 10 amps. If you're application is going to use PID or softPWM, your relays aren't going to like that electro-mechanically as well as being noisy. Finally, don't know if your schematic is otherwise finished or not, but based on how the wiring and symbols are laid out you have issues with a lot of your circuits.
Re: Relay Board
July 07, 2015 07:40PM
Well I thought the circuit was done but apparently not.

Those are the relays I am using on a test boar right now. I am setting up a printer that is not fully functional yet. I am using a RAMPS 1.4 / Arduino 2560 board set. The power source for this circuit is 12VDC @ 5A and fused as such.

The circuit using RL-1 (top left corner) is not suppose to have more than 5 amps applied to it. This circuit is suppose to power up RL-2 and a 2x15 pin header used for continuously running accessories, fans, lights etc.

Circuit using RL-2 (top left corner) is used as the supply for the RAMPS and Arduino boards. Ii is NOT meant to power the heated bed. The power source for this relay is 12 VDC @ 10 A.

Circuit using RL-3 (bottom left) was originally going to be used to power a smaller heated bed drawing about 13 amps. I left the relay on the schematic just because the hole size happens to be big enough for an automotive type 30A relay wires. The power source is 12VDC @ 20A.

My intention for RL-3 was to use the heated bed output on the RAMPS board to key RL-3 which will use an additional power source for the heated bed.

The voltage divider circuit receives the power necessary from one of the 12V sources from the RAMPS board and is returned thru the inductive sensor probe or at least that was the idea.

There are 6 LED's on this board. 3 of them are used to show that power has been applied and the polarity of the connection is correct. The other 3 LED's are used to show that power has been applied to the circuit in question.

There are a total of 4 separate power input sources on this board, all meant to be separate.
Attachments:
open | download - Display 2.jpg (432.9 KB)
open | download - Display 1.jpg (274.6 KB)
Re: Relay Board
July 10, 2015 03:02PM
Now that you described the circuits they make a bit more sense. It's Rube Goldberg-ish though. Just put a switch on the 11A input and get rid of both of the top relays. The one on the left isn't doing anything anyways. Your switch is already switching the power...the same power that would be powering the "Always on" accessories. And that one switch would control both the always-on as well as what you currently have wired as the 11A power supply so the same switch could just operate both. If you wanted the ramps/arduino powered to be able to be controlled independently from the always-on, just put a 2nd switch in place for that power. If you really felt the need, you could have the fuses for the always on and 11 separate so that if one short circuited the other wouldn't. Or just one common fuse for everything. Unless you're doing something crazy, you wouldn't draw > 10 amps for both setups either. You'd actually be safer (from a magic smoke point of view) with much smaller fuses...closer to what you'd realistically be drawing max.

Your heated bed relay is fine as long as you aren't rapidly turning on and off the bed. On the "19A-OUT" connector you have your + and - reversed btw.

For your sensor, what type of sensor are you using? PNP or NPN? A NPN doesn't need the voltage divider at all. A PNP does unless your sensor works at 5V (many do even though it's below spec) and you have a 5V source (like the arduino/ramps board) would. If you do need the divider, you look correct. Your resistors could go an one or two order of magnitude higher to drop wasted current if you wanted but isn't required.
Re: Relay Board
July 11, 2015 10:16AM
Thanks

My thinking at the time was just to use what I had on hand at the time. The relays were left over from an antenna-switching project I did a few years ago. Since the RAMPS board had an 11A specification I used the relay. The relay I used comes in both 10A and 15A versions. So you have to specify when ordering. However at the same time since I'm not heating the bed thru the RAMPS setup I should never approach the 11A limit. I have not researched how much current I would use with 2 hot ends that would most likely be the most I will ever use.

Each of the 3 "circuits" already has their own fuse, but reducing the fuse size makes sense.

Thanks for letting me know about the "19A-OUT" connector I will get the silkscreen changed.

I started out with a Printrbot printer and it uses a PNP type sensor so I added the circuit. I did not know that the NPN type does not need the divider. I have noticed that the NPN type seems to be used more and will most likely switch over the next time I order one.

Edited 1 time(s). Last edit at 07/11/2015 10:36AM by kd6hq.
Sorry, only registered users may post in this forum.

Click here to login