Welcome! Log In Create A New Profile

Advanced

Ramps 1.4 switching off.

Posted by Andries 
Ramps 1.4 switching off.
August 15, 2015 06:19AM
Please help!

I am a new to this 3d printing and is busy setting up my electronics for my printer. The setup I have is the ramps1.4 board with a smart lcd controller. I have uploaded the newest marlin software to the board but when I suply 12V power to the board it works for a few minutes and then all of suden it slowly start shuttings down and goes into a on/off loop with the power led1 flashing twice a second. The board works fine when it is connected to my laptop. Please help!
Re: Ramps 1.4 switching off.
August 15, 2015 06:29AM
Sounds like the 5V regulator on the Arduino is overheating, which is a common problem with Arduino/RAMPS electronics when you start powering other things off the 5V rail. Workarounds include:

1. Supply external 5V power to the Arduino.

2. Rewire the LCD backlight so that it takes power from +12V through a series resistor instead of from +5V.

3. Replace the Arduino by a Taurino, which has a higher-rated 5V regulator.

4. Replace the Arduino/RAMPS by more modern electronics with fewer limitations.

Edited 2 time(s). Last edit at 08/15/2015 06:32AM by dc42.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Sorry, only registered users may post in this forum.

Click here to login