Welcome! Log In Create A New Profile


Thermistor Error Ramps 1.4 (MAXTEMP)

Posted by melcher 
Thermistor Error Ramps 1.4 (MAXTEMP)
September 28, 2015 08:12PM

Im using Ramps 1.4 on arduino mega 2560 with Marlin firmware. I'm trying to connect via pronterface

My thermistors for both hot end and heated bed both started giving my MAXTEMP error and both show max temp for that particular thermistor table.

I get the error even if the thermistors are plugged in or not, and if tried swapping thermistors, reprogramming the pins and using T2, and Ive also tried using new thermistors and I keep getting the same error. I'm using 100K thermistors and these are my setting

#define TEMP_SENSOR_0 5
#define TEMP_SENSOR_1 0
#define TEMP_SENSOR_2 0

I've tried turning the bed sensor to 0 and just tried using the hotend and that doesnt work either. This was working until saturday so just curious if anyone has any experience with this. Is there a way check the pins to verify that they are working correctly? I've checked the thermistors with my multimeter and they show ~112K at room temp.

Thanks for any help!

Edited 1 time(s). Last edit at 09/28/2015 08:14PM by melcher.
Re: Thermistor Error Ramps 1.4 (MAXTEMP)
September 29, 2015 05:27AM
A max. temp error indicates a shortcut between the thermistor pins ( most likely on the header pins of the Ramps board )
Usually you see a min. temp error when there is no thermistor connected.
Sorry, only registered users may post in this forum.

Click here to login