SOLVED - Hotend & Heated won't heat via software
October 24, 2015 09:35PM
Hi guys, I'd love some advice on my ramps board.

I can heat the hotend and heatbed by using the Preheat function of the LCD screen and everything gets as hot as it should be. When I try and heat them through Repetierhost they don't heat up.

Would this be a firmware config issue? A ramps hardware issue? Blown MOSFET? I'm stuck and this is the last thing stopping me from printing.

Thanks in advance

Edited 1 time(s). Last edit at 10/26/2015 06:46PM by ixlix.
Re: Hotends & Heated won't heat via software
October 25, 2015 12:00AM
It's not RAMPS or MOSFET, since the LCD controller uses the same electronics to control the heaters as the PC . . . this is either firmware, or Repetierhost, and I tend to favor the latter . . .

What happens if you send gcodes to the printer directly, and not using the Repetierhost functions? And what do you get back from the printer from either attempt? Any chance you just aren't connected, or does movement work?

- Tim

Edited 2 time(s). Last edit at 10/25/2015 12:02AM by tadawson.
Re: Hotends & Heated won't heat via software
October 25, 2015 06:44AM
When you say directly, what do you mean? Through the manual control panel if Repetierhost? I will try and send some M109 commands tomorrow. When I run a print which has the heatup codes in it, it doesn't heat up. All the other things work as they should and gcodes for movement are fine.

Is it possible its stuck in Dry Run mode which ignores the hotend and heatbed?
Re: Hotends & Heated won't heat via software
October 26, 2015 06:46PM
Ok this has been solved. Re-uploaded the firmware and changed to Pronterface and i now have control of the hotend and heatbed. Thanks for your suggestion Tim.
Sorry, only registered users may post in this forum.

Click here to login