Welcome! Log In Create A New Profile


Servos do not work

Posted by showup 
Servos do not work
December 22, 2015 08:58PM
I am putting up a printer.
All steppers work.
Trying to setup the Auto Bed Leveling feature of Marlin. 1.1.0
Electronics setup: MEGA 2560 + Ramps 1.4 + A4988 drivers + 2004 LCD

Shorted vcc and 5v pins in Ramps 1.4 board to activate the servo voltage.
When i connect the servo to the servo pins the servo did turn to indicate that the servo pins supply voltage.
But when i give M280 P0 S* where * is between 0 to 180, nothing happens.

The Servo wiring connections are like from edge of the board to inside -ve, +ve, Signal.

What am i doing wrong?
Please help.
Re: Servos do not work
December 22, 2015 10:03PM
Here's what I would do:

1) Reverse the servo plug and see if it works (reversed polarity will not hurt the servo or the RAMPS board)
2) Make sure the servo is plugged into the pins your are addressing in your command: The pins closest to the reset button is for servo 0, then 1, 2, 3 (if properly set up in Marlin...)
3) Try the command with the other servo addresses (M280 P1 S90, etc) in case their NOT set up properly in Marlin (0 is pin D11, 1 is pin D6, 2 is pin D5 and 3 is pin D4)


Find me online at:

Check out my FolgerTech Prusa i3 (plexi) at MindRealm.net
Re: Servos do not work
December 23, 2015 04:02AM
Maybe your servos are asking too much current?
AtMegas 5V regulator isn't meant to drive any servo, especially digital servos draw a lot of current.

Remove the above mentioned jumper and feed the 5V servo header with a separate 5V/ 3-5A supply.
Re: Servos do not work
December 25, 2015 06:31AM
For some reason the P0 did not work for me.
I am not sure where the problem is.
I enabled the P1 and it is working fine.
So, now i am using P1.

Thank you for the support.
Re: Servos do not work
December 27, 2015 03:18PM
I am having the same problem P0 dosent work but P1 works, how do you enable P1?

Re: Servos do not work
December 27, 2015 04:29PM
asaenz you got my pm. The following message if for others who want to follow the thread.

This is what i did:
I searched the "#define NUM_SERVOS" in configuration.h and change it to 3
Changed the "#define Z_ENDSTOP_SERVO_NR" from 0 to 1

I hope this works from you.
Happy printing
Sorry, only registered users may post in this forum.

Click here to login