Welcome! Log In Create A New Profile


Stepper motors won't move

Posted by dlcomm 
Stepper motors won't move
March 22, 2016 08:16PM
I am running RAMPS 1.4 with Arduino Mega and Marlin firmware. My Y and Z axis each have dual Nema 17 stepper motors and I have not connected my X axis up yet.

So here is the issue... Upon power up, everything looks normal and seems to be working. I can easily turn one of the stepper motors by hand and it's pair will turn with it. As soon as I tell it (using the LCD display menu) to move the axis, the motor has a faint high pitch noise and the motor does not turn. It does however lock the motor (holds in place) and it's not possible to turn by hand at this point. Approximately 30 seconds later, I get Axis Limit hit.

Some history: Yesterday I was playing with it and only has a single motor attached to the Z axis. Everything seemed ok with the exception of a strange jumping part way through (near the end) of a movement. It didn't matter how long I spun the motor, just before it completed it would sputter a bit. Being a dumb ass, I was not careful with how I had my end stops sitting, as they we all piled together. Sure enough, I let the magic smoke out of my voltage regulator on the Arduino. I've ordered some new ones and in the mean time I have removed D1 and am pulling the 5 volt from my re-purposed HP server power supply. (It supplies 5 & 12 VDC and yes I checked to make sure there are no dips or surges with varying loads). The concerning part is that when the magic smoke decided to free itself, I saw the same message of Z axis limit hit.

My big concern, and thus I have immediately powered down until I can get some advise is that the power supply will provide considerably more current than the tiny voltage regulator that comes stock on the mega and if there is a more serious problem I could let more expensive magic smoke out if not very careful.

Any ideas as to where I should start looking???
Re: Stepper motors won't move
March 22, 2016 09:21PM
Further testing... the motors following each other is a result of them connected in parallel. They will do this even when unplugged from the board.

I am a bit frustrated trying to figure out the correct wiring to the ramps board and I have come across three different configurations, and they can't all possibly correct. With my build, since I am building a larger scale print (the the dual motors on 2 axis) I have cable extension added which change the colors of the wires but I will keep things as simple as possible.

With my motor sitting up (shaft at top connector facing me) I have black,red, green and blue.... Some diagrams show pretty much a 1 to 1 connection meaning if black is 1, it goes to pin 1 and follows the same order across. Others say the black and blue (pin 1 & 4 on the motor are paired so it would go black, blue,green, red to the board.... while others say black goes to pin 1, red and green are reversed with blue ending up on pin 4. Ugh....

Please help
Re: Stepper motors won't move
March 22, 2016 09:38PM
All diagrams showing stepper wiring colors should be taken out back and shot!

No two steppers from different manufacturers have the same colors, and even sometimes they differ from batch to batch from the same company.

from another post I did 15 days ago...

For movement you need

steppers drivers in the correct way (can be plugged in backwards or off by one very easily)

12v on the 12volt 5amp input (not 5v on it, which seem to be a common issue)

12v getting to the driver modules (fuses can blow etc and stop this, so measure its really there on vmot pin)

Stepper motors wired correctly, steppers are two coils, make sure first coil is on first two pins, and second coil is on last two pins of the ramps connector

Firmware, set to correct motherboard (or test firmware) As these define which pins are used for what, including step direction and enable for the stepper modules

Enough current getting to the steppers, this is limited with the vref pot on the driver module [reprap.org] for more info)

and that the axis isn't physically stuck (ie with the belts off, you can move it by hand easily)

For stepper wiring see [reprap.org] to determine which wires are a pair

Also since your new, check you have 3 micro stepping jumpers installed under the driver module.

NB never ever unplug or plug in a stepper motor while the power is on, this will kill your stepper driver.

Edited 3 time(s). Last edit at 03/22/2016 09:42PM by Dust.
Re: Stepper motors won't move
March 22, 2016 10:07PM
Thanks Dust,

Agreed with the color code thing.... "The only standard is that there is no standard!"
Yes, there is 12 V on the inputs and on vout pin of drivers.

The jumpers are installed for all 5 drivers and firmware is set for Ramps 1.4 with Mega 2560 (although I have an R3 so will still have to check to see if that is an issue). I have an electronics background and many many years ago worked on a lot of equipment with stepper motors, however this is the first time I am building something like this from scratch.

I haven't tried adjusting the current yet, however after verifying my wiring (which was correct) and simply disabling the end stops I was able to get the motors to move. I moved them + 50 mm let the stop and moved back to 0. Moving forward they jump quickly and seem to move back and forth a bit. Moving back they went nice and slow with smooth movement but when they got to 0 they literally sit and vibrate. Is this normal behavior???
Re: Stepper motors won't move
March 23, 2016 12:13AM
So I have narrowed the issue down to problems on the Ramps board. The Z axis socket or the transistor is bad as it is the only one sputtering regardless of how much current I supply the motors. I swapped the drivers with the Y axis and the problem stays with the axis. I also swapped the motors to confirm and the problem stays with that axis. Sigh... I will attempt to re-solder the sockets but I am thinking the issue is bigger than that.
Re: Stepper motors won't move
March 23, 2016 01:14AM
The stepper circuit is quite simple

Where step, direction and enable are all directly connected the the mega
MS1, MS2 and MS3 are the micro stepping jumper pins, they get connected to +5v or are disconnected (jumper off)

I would firstly check the soldering around the Z driver socket and the stepper plugs on the ramps.
And check the ramps mega pin connectors (in particular d46, d48 and a8)
Then check you have 12v on the vmot pin and 5v on the VDD pin and that the grounds are connected to power supply ground.

If that’s all fine, you could have a damaged mega... there isn’t much on the ramps other than bad solder that could stop this from working.
Also re upload your firmware, just in case.... (sometimes the firmware just gets broken and needs refreshed )

Do the steppers get energized? ie you can't turn them as power is flowing. If they do then enable is working, if they don’t... check out that enable line
If they do get energized check out the step pin.

Edited 1 time(s). Last edit at 03/23/2016 01:20AM by Dust.
Re: Stepper motors won't move
March 24, 2016 06:21PM
I have ordered a new Mega and Ramps board (as it's only $7 from my supplier). I will do the trouble shooting as you suggest and post back the results.

This issue occurred on my first run (prior to the voltage regulator getting smoked) and checking after the fact shows 7.1 volts being dumped on the 5 volt rail (which is why I decided to supply the 5 volts separately and remove the diode that sends the 12 volts to the mega). This may have caused more damage than it first appears and barring any bad solder joints / pins I won't know for sure until the replacements arrive.

One thing I did note was that both the Z and X axis have this problem and both are hard to insert the controllers so it's possible the sockets are bad. Your information will prove valuable for troubleshooting. THANKS!!!

To answer your question, yes the motors are energized however I haven't yet determined if this is a permanent or intermittent state for the duration they should be. They do stay energize for a while but then they seem to stop and I am not sure if they are supposed to remain that way or not. This could be an issue on the Z axis especially.
Re: Stepper motors won't move
April 03, 2016 02:25PM
I have checked and compared both the working socket and the faulty and it appears it's a problem on the mega pins. It looks like whatever shorted out to blow the voltage regulator also damage the mega (or the board was defective from the start since the motors did this long before the short).
Re: Stepper motors won't move
August 24, 2017 11:31PM
Looks like I have a similar issue.
I have the Arduino R3 Board with the matching CNC Shield and 4988 drivers. I checked the power of my controllers and they are all 1.31 volts, when I go to adjust them to the motor required voltage(3.75 volts) the set screw won't go any further. No power supply power only the USB cable to the laptop.
My steppers (model 42SHD0217-24cool smiley do not run right, they just jump back and forth, the X axis moves a quick forward and then quick back. The Y axis just sits and grinds forward then back. I figure this is caused by the low voltage. When I go to the Universal G Code sender and manually move X or Y that's when they do what they do. I am new to this stuff and I am scratch building a Laser Engraver, 18" long and 14" wide, my frame work is extruded aluminum 1"x1" rails and the cross beam (x axis) is a 1" X 2" X 14" extruded aluminum rail. I also notice when I move Y axis it is a bit stiff, my wheels are loose but not wobblie, my X axis moves much smoother by hand but some resistance.
Thanks for the help, I know it is a lot of stuff and I am just beginning to understand much of it.
Re: Stepper motors won't move
August 25, 2017 03:24AM
You seem to be confused...

the vref sets the current on the device. you want 1.5amp for your steppers

Vref = I_TripMax * 8 * Rs

now the Rs changes depending on what drivers you have
real pololus use a 0.05 ohm resistor
StepSticks use 0.2 ohm
clone pololus from china mostly have 0.1 ohm

ie you need

Vref = 1.5A * 8 * 0.05 = 0.6V (for a standard pololu)
Vref = 1.5A * 8 * 0.2 = 2.4V (for a stepstick)
Vref = 1.5A * 8 * 0.1 = 1.2V (for a clone pololu)

none are anything like that 3.75 you seem to be aiming for...

If you getting that number from the data sheet you should be aware that it is simply the current * Resistance, ie 1.5ampx2.5ohm = 3.75v
This number has nothing to do with the vref voltage.
This number is infact quite misleading, as the voltage used should be 2-4 times that, ie 12v on the vmot pin is good

The most common issue is lack of mirco stepping jumpers, you need some in place somewhere to set 1/16th micro stepping

If its one of these, note the 3 yellow jumpers under each pololu module. these set the microstepping

Edited 3 time(s). Last edit at 08/25/2017 04:27AM by Dust.
Re: Stepper motors won't move
August 25, 2017 01:33PM
Yes, you are correct, I am confused, I am not well versed in electronics but am willing to learn.
Thank you for the explanation, I will try to do as you have mentioned and let you know what I get. I have ordered some jumpers for the drivers.

Edited 1 time(s). Last edit at 08/26/2017 10:37PM by Bruk.
Re: Stepper motors won't move
August 28, 2017 05:30PM
Dust, I have installed the jumpers. My motors still don't move the X or Y axis, they just move ever so slightly and grind. My vref is 1.5 on all drivers, my drive belts are snug no binding on X or Y when I move them by hand. I am stuck. My,
motors are from here [casunmotor.com]
42SHD0001 Motor Type


Edited 2 time(s). Last edit at 08/28/2017 06:30PM by Bruk.
Re: Stepper motors won't move
August 29, 2017 05:07AM
Check your stepper wiring

Should be wired for bi-polar

controller end    stepper end  
Pin                      Pin
1                          1
2                          4
3                          3
4                          6

There is an issue though

for the 42SHD0001 current is listed as 0.4amp resistance is 30ohm so the dc voltage required is 0.4 * 30 = 12v
BUT you need to drive pololu stepper drivers with 2 to 4 time the dc voltage, so you need absolute min 24v, preferably 36v for these stepper motors.

If you trying to do with on 12v you really need a stepper with much lower resistance under 2ohm, and higher current 1.5amp ish

earlier you said you had 42SHD0217-24B.... so im a little concerned....
It would have been a better option 1.5amp and 2.5ohm, so 3.75v so would work on 12v (Resistance is 2.5 according to other sites, and math works out, I suspect they copied the inductance 5 into the resistance by mistake on the site you listed)

Edited 4 time(s). Last edit at 08/29/2017 05:33AM by Dust.
Re: Stepper motors won't move
August 29, 2017 06:59PM
The paperwork I got was wrong, it wasn't for the 42SHD0001-24B (my motors). Ok, so I guess I need to look for a 36 Volt power supply to run these, any suggestions? Need one of resonable cost.
Thanks for the help, it is getting much clearer now.As soon as I get the powersupply I will let you know how things work out.
Thanks Again Dust.
Re: Stepper motors won't move
August 29, 2017 07:06PM
Dust, Any suggestions on a power supply to get resonably priced?

Edited 1 time(s). Last edit at 08/29/2017 07:30PM by Bruk.
Re: Stepper motors won't move
August 29, 2017 11:47PM
NO, but check your stepper drivers.

max voltage for pololu a4988 is 35v. (not 36...)
Re: Stepper motors won't move
August 30, 2017 01:12PM
Gotcha they are 35volts Max.

Edited 1 time(s). Last edit at 08/30/2017 01:16PM by Bruk.
Re: Stepper motors won't move
September 02, 2017 08:47PM
Dust, Thanks again for the help. i ordered different motors and they seem to work fine. As I said before I am very new to CNC programming so I apologize for being a pain in the arse. I have physical end stops on -X +X and -Y and +Y and they are wired to the Arduino, CNC Shield in the corresponding pins. How do I set them up and make my "Home" in the center of my work area? I have read some of the comments but don't quite understand, I have tried to do it but some how I lock up the system, I can unlock it but that's it.
Re: Stepper motors won't move
September 03, 2017 05:15AM
Cartesian repraps traditionally home to 0,0,0 which is left front down position, only delta home to centre. (0,0,z_max)

you can't home to the middle (as far as im aware)..... you can however force 0,0 to be in the centre, you just set your home location to -x/2 -y/2
eg if your bed is 200x200 you set x and y home position to -100
Re: Stepper motors won't move
September 03, 2017 02:50PM
My actual bed(work area) is 228.6 mm X 228.6 mm, so center should be 114.3 mm X 114.3 mm.
So, How do I set the end stops and a "Home Position"
Re: Stepper motors won't move
September 04, 2017 02:57AM
what firmware are you using? teacup? GRBL?
Re: Stepper motors won't move
September 05, 2017 06:03PM

I get this when I try to Home out.

Edited 1 time(s). Last edit at 09/05/2017 06:09PM by Bruk.
open | download - IMG_20170905_165810163_HDR.jpg (130.5 KB)
Sorry, only registered users may post in this forum.

Click here to login