few question about ramps and arduino
January 01, 2011 06:42PM
Hi,

I'm new here and i have few questions about ramps and arduino mega:

What firmware i need to use with arduino mega?
Do i have change any settings in code?
Do original reprap program work with arduino mega and ramps?

thanks for help and sorry for bad english smiling smiley
Re: few question about ramps and arduino
January 01, 2011 07:57PM
I plan to use the RepRap standard firmware on mine, I don't know about other firmwares that are around.

All going well, all you should need to change is the configuration.h and pins.h files to handle the different layout.

I have issues with the RepRap host on my machione, however I don't have any issues with RedSnapper, which works on the RepRap standard firmware.
Re: few question about ramps and arduino
January 01, 2011 08:28PM
I'm having pretty good success using this tonokip firmware that has the RAMPS pre-configured [github.com] which requires RepSnapper to talk to. I'm using skeinforge to make the gcode and using RepSnapper just to send it to the printer.

However, I'm hoping that ReplicatorG will finish support for the regular RepRap 5D firmware soon.


--
Tony Buser http://tonybuser.com * http://reprap.org/wiki/User:Tbuser#Projects
Re: few question about ramps and arduino
January 02, 2011 05:26AM
Thanks for answers. Does Pololu Electronics (http://reprap.org/wiki/Pololu_Electronics) support standard firmware and changes are not needed?
Re: few question about ramps and arduino
January 02, 2011 01:50PM
The firmware needs to be configured for the electronics used. It is not difficult. You just comment or uncomment the settings you need. Here is the configuration file [reprap.svn.sourceforge.net]

There are firmwares with the configuration set for RAMPS available at [reprap.org]. The list shows which software they confirmed to be compatible with. Host Software = original reprap program
Tony, could you tell me a bit more about your set-up? I have recently finished my Mendel construction and have the RAMPS electronics, but I have yet to get a single stepper to turn.
Re: few question about ramps and arduino
January 04, 2011 09:52AM
What would you like to know? Are you able to connect at all? Read temperature? I'm using this version of RepSnapper [sites.google.com] on OSX and connecting at 115200 baud.


--
Tony Buser http://tonybuser.com * http://reprap.org/wiki/User:Tbuser#Projects
I am on a Linux machine, but still using RepSnapper and the Tonokip firmware. I am able to communicate a bit with the board. Reading temp is in fact all I've been able to do successfully smiling smiley But no stepper movement. Seems like the 12V power is not getting to the steppers. JohnnyR is helping me troubleshoot a bit, but I thought I'd start asking others who are having success. Not sure if something is goofy with my setup, or with my RAMPS. Do you have a picture of your board with everything plugged in. I'd love for it to be something simple like I have something plugged in the wrong place. Thanks!
Re: few question about ramps and arduino
January 05, 2011 09:15AM
It's possible you might need to adjust the potentiometers on the pololu boards to give them more power or you have the wires in the wrong order. Can you hear or feel the steppers getting power at all? When they're powered (at least mine) they make a really faint whine sound. You might want to try the regular RepRap 5D firmware and host because it tends to charge up the steppers constantly which causes them to make more noise when idle.


--
Tony Buser http://tonybuser.com * http://reprap.org/wiki/User:Tbuser#Projects
Thanks. Yeah, I had an issue with my 12V power supply that I seemed to have fixed (Hurray, progress!). Only thing is, now I can only get the motors to move in positive direction. No response to minus or home commands. More troubleshooting fun smiling smiley Reminds me of last year, figuring out how to make my Makerbot do what I wanted it to. In the end, I got it to print me a Mendel, so I'm sure I'll figure this out too smiling smiley
Re: few question about ramps and arduino
January 07, 2011 03:04PM
Check your optos... If you have them hooked up.... perhaps they need to be inverted in the firmware...

Al...


[araspitfire.blogspot.com]
Hello,

I´m new to this forum and new to Reprap Mendel construction. Having finished hardware and soldering a RAMPS Polulo board I ask myself how to install any firmware. Suggestions are very welcome!
I tried installing RedSnapper on OS 10.4 and OS 10.5 - the Program as downloaded from [reprap.org] does not even execute. I read that some firmware works only with skeinforge, other only with Redsnapper.

It´s very confusing to me, is there any safe way to proceed here? Thanks, Elmar
Thanks Al. Yep, the firmware I had grabbed had the optos inverted. Just had to turn that back around. Mechanics all good now, but still not having much success with toolchain. I am trying two paths in parallel, and neither seems to be getting me good end results.
Path 1: Tonokip firmware + RepSnapper. Works fine in manual control, and when printing straight from RepSnapper's (limited) GCode = useless prints. But when I import a GCode made in Skeinforge, I get no extrusion, just the cartesian movements. Grrr.
Path 2: 5D for RAMPS firmware + Ultimaker RepG. Very hopeful about this one, but still not working for me. I had gotten a previous version to connect and move the mendel in the control panel, but it froze when I tried to run a build. Newest version won't even connect.
I should probably stick with troubleshooting one path or the other, if only so I don't have to keep reflashing firmware, but with both being close-but-not-quite, it is very frustrating.
I appreciate hearing about anyone else's successes or failures or suggestions. Thanks all!
Re: few question about ramps and arduino
January 10, 2011 03:04PM
Elmar: Welcome to the Forum smiling smiley
I don't have a Mac here, but asked prusajr in #reprap on IRC. He confirmed that Repsnapper build you linked executes and works for him. Although you are using RAMPS your issue seems to be getting Repsnapper to run on OS10. You will be more likely to get helpful answers, and help others encountering the same issue in the future by posting your question in the Repsnapper forum here [forums.reprap.org]


ja3d: Sounds like you need to turn on Dimension in skeinforge so it adds the E code to the move commands. [reprap.org]

Edited 1 time(s). Last edit at 01/10/2011 03:07PM by johnnyr.
Re: few question about ramps and arduino
January 11, 2011 09:19AM
Can i use Texas Instrument drv8811 instead of using A4983 chips? I have couple drv8811 laying around, and i would like to use them.
Re: few question about ramps and arduino
January 14, 2011 05:12PM
looks promising?
Triffid_Hunter said:
For another option, TI's cheaper DRV8811 is pin-compatible with the TSSOP A3977, but the official stepper boards use the PLCC A3977 so the boards would need a redesign to use it.

in the post [forums.reprap.org]
I have the same issue than ja3d with repsnapper.
It works fine while priting from gcode converted by repsnapper itself, but the gcode is really bad.
And when importing gcode from Skeinforge the extrusion doesn't work...

I also tried 5D for RAMPS firmware with Reprap host, I can control the heating head and read from the sensor but I cannot move anything.

I wish we had better software, which I could eventually developed since I'm a developer but I even don't know where to start.
Re: few question about ramps and arduino
January 19, 2011 11:53PM
no extrusion from skeinforge? enable 'dimension' plugin


-----------------------------------------------
Wooden Mendel
Teacup Firmware
Re: few question about ramps and arduino
February 03, 2011 05:41PM
Hi, i need help wiring my SY42STH47-1684B stepper motor. Which wire goes which pin? RAMPS s is color coded, but i think that stepper motor wires are different coloured than ramps.
Re: few question about ramps and arduino
February 03, 2011 07:16PM
With the stepper pins at the top of the board, the sequence from left to right is Blue, Red, Black, Green.
Sorry, only registered users may post in this forum.

Click here to login