Welcome! Log In Create A New Profile

Advanced

Issue with negative movements

Posted by syncra 
Issue with negative movements
January 25, 2011 02:22PM
Hi there,

I've just built a Huxley type of reprap and connected the x,y,z motors and relative end opto stops to RAMPS.
The bot moves axis in the positive direction but not in the negative, as if the opto stops where interrupted by something in the middle.
I double checked the wire connections and they are right.

Any idea why this might happen?
Many thanks to anybody that can help!
VDX
Re: Issue with negative movements
January 25, 2011 02:55PM
... maybe you have to invert the polarity of the optos ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: Issue with negative movements
January 25, 2011 11:43PM
Change the inverting option in the firmware for the axes that won't go in the negative direction. Also, if you are using the host software it will not allow movements negative of 0 from the control panel.


Cameron

Help improve the RepRap wiki!
Just click "Edit" in the top-right corner of the page and start typing.
Anyone can edit the wiki!
Re: Issue with negative movements
January 26, 2011 01:21PM
Many thanks guys, I really appreciate the ideas.

I actually assumed that some reprap endstops I had where identical to the one I bought from Ultimaker - and they were not!!
they look the same and the connections are the same, but the reprap ones I had do not work with RAMPS (also if they worked with other GEN3), whether the ones shipped by Ultimaker (with the RAMPS) actually work.

I feel a bit stupid but I imagine it's part of the game!

Many thanks again.
Re: Issue with negative movements
January 26, 2011 02:31PM
Why do they not work? Wrong voltages would be the only insurmountable obstacle I can imagine, and even that could probably be worked around with a couple resistors.

If the output is inverted (i.e. 5V when it should be 0V and 0V when it should be 5V) that's (as NewPerfection mentioned) easily fixed by a #define in the firmware configuration file.


--
I'm building it with Baling Wire
Re: Issue with negative movements
January 26, 2011 06:47PM
RAMPS uses a different pinout for the endstops. The reasoning was something to do with keeping the resolution printable so that the reprap could put etch resistant ink on a copper clad board.

If you are using the same cable to connect them to either set of electronics, this is probably the issue. You have probably damaged the endstops if you did.
Re: Issue with negative movements
January 27, 2011 05:06AM
I actually knew about the different cabling on the board - in fact I made the cable for the RAMPS with the signal on one end.
At the endstop end, the ultimaker endstops' pins have exactly the same configuration of the reprap endstops' pins, that's why I assumed they were the same.

My testing says that they are not the same, and only the ultimakers' endstops work with the ultimaker. I have not tried viceversa yet, meaning reprap endtops with ultimaker RAMPS.

I am puzzled and curious, but unfortunately not expert enough to understand about this level of electornics.

Maybe I could take a picture of the two endstops models? Would that be of any interest?
Re: Issue with negative movements
January 27, 2011 06:43PM
If nothing else, it may help to clarify which versions of electronics you are trying to work with. I have a complete RAMPS kit from ultimachine, so I know what endstops they are using, but I'm not familiar with what ultimaker is selling or what endstop you may be trying to use with it. Here is a link to data on the standard end stop, I don't know if any of that will help you. This is what came with my RAMPS kit and they do work just fine.

One other thing I just thought of...
RAMPS has a set of min AND max ports. If you have tried inverting the endstop signal using the firmware configuration, are you sure that the enstops are connected to the correct axis and the correct end of that axis? Although there are 6 ports in all, most people just use the three min ports and leave the max ones empty.
Sorry, only registered users may post in this forum.

Click here to login