MKS Gen_L v1.0 & a Proximity Sensor
April 10, 2017 12:24PM
I am curious to know if anyone has been able to get a Proximity Sensor to work with a (MKS Gen_L V1.0)?
Or
If someone knows how I could get a Proximity Sensor to work with a (MKS Gen_L V1.0)?

I can not seem to get the thing to work with my board. At least in the terms of getting the M119 to show that the signal is flipped. When I send M119 I get only the info I have it set to in Marlin. So it either just says Open or Triggered and does not change when I move the Sensor to the Aluminium. The sensor itself works and has the right voltages. The LED lights up when near the Aluminium bed. I have tried every setting in Marlin that I have found mentioned in multiple discussions and tutorials online and any that I could think of on my own. Nothing seems to work.

I am wondering if it is the board itself. I read in one thread where somewhere that a MKS board had physical pullups resistors on the board. I am not sure which version they had as they just said MKS. Anyways, one person in that thread suggested to desolder them off in order to get the Proximity sensor to work. That is not something I would prefer to do if I have a similar issue. I would rather just prefer to disable it off in Marlin somehow.

So is there a way in Marlin to setup a Proximity Sensor for the (MKS Gen_L V1.0)?

Any help would be greatly appreciated. Thanks
Re: MKS Gen_L v1.0 & a Proximity Sensor
April 10, 2017 06:10PM
"physical pullups resistors" are external to the chip and cannot be disabled in firmware
Re: MKS Gen_L v1.0 & a Proximity Sensor
April 11, 2017 02:47AM
With a NPN NO sensor you need a pullup resistor to make it work. Maybe you just have the wrong sensor?
Re: MKS Gen_L v1.0 & a Proximity Sensor
April 12, 2017 11:39AM
Quote
Dust
"physical pullups resistors" are external to the chip and cannot be disabled in firmware
OK That makes sense.

Quote
o_lampe
With a NPN NO sensor you need a pullup resistor to make it work. Maybe you just have the wrong sensor?
I am pretty sure the Sensor is a NPN NO unless they labeled it wrong.






Honestly I am starting to think the code in my Firmware is just outdated. It seems to be missing a lot as it does not look like what I am seeing online in tutorials and other examples. It only seems to work in Marlin 1.6.1 when I go to edit it. I think I need to find a more up to date Firmware or just somehow learn to write my own. I am currently looking at a tutorial on how to edit the version of firmware that you can download from the main Marlin site hosted by Github. It'll take a little bit of trial and error but hopefully I'll get it working at some point.

thanks for the replies Dust and 0_lampe. It is much appreciated.
Re: MKS Gen_L v1.0 & a Proximity Sensor
April 12, 2017 11:53AM
Hi get the latest Marlin Firmware from here
[marlinfw.org]
Everything you need is in the zip.

I found it difficult to find what I wanted on the github site.

I bought the same sensor (Still waiting for delivery from China) so interested to see how you get on.

Edited 1 time(s). Last edit at 04/12/2017 11:57AM by Desertboy.
Sorry, only registered users may post in this forum.

Click here to login