MINTEMP error with new silicone bed install, runaway heating
April 12, 2017 02:02AM
Hi everyone!

I accidentally posted this to the Controller board instead of here on the RAMPS board. I'm sorry for double posting, but I just couldn't figure out how to delete the original on the other board.

I have attached 3 images below to show my issue.

I have had my prusa i3 clone from RepRapGuru for a few weeks. I decided to install a new aluminum bed, silicone heat pad, and aluminum Y carriage from RepRap Champion (link) this past weekend. I also purchased and installed a MOSFET (link) to reduce the load on the RAMPS 1.4 board.

The problem I encountered was that while the thermistor wires on the silicone bed came pre-installed, they did not come with a 2-pin connector attached to them like the MK2 PCB heatbed that came with the printer kit. I had no way of connecting the thermistor to the RAMPS board short of soldering directly onto the T1 pins.

I went to RadioShack to see if I could buy the necessary hardware to install a connector myself, but they did not have much of anything in stock, especially not what I needed. So, I found a little electronics kit that had a wire of the same gauge (20 gauge) with a 2-pin connector pre-installed. It was exactly what I needed, just not yet connected to my thermistor wires. My reasoning was to solder this new wire onto my thermistor wires and use the connector to plug it into T1 on the RAMPS board.

So, I did that. As far as I could tell, the soldering went perfectly. I made sure that all wires had the same strand count of 7 strands each. I did not clip off any of the strands when stripping the wires. I took great care with the soldering, and made a very strong connection the proper way. I put shrink tubing over both solder points, then a larger shrink tube over all of it. It looked great all around to me. The attached photo named mintemp1.jpg shows this wire; it is the one with the blue shrink tube on it. I plugged this into T1 on RAMPS and turned on the printer, only to receive an immediate error code: MINTEMP. Worse than the error code, the silicone mat started heating up the moment it was plugged in and reached about 80 degrees before I noticed and unplugged the printer.

I will probably cut the wires again and re-attempt the soldering to rule out any issues there, but I'm at a loss beyond that. I tried inserting the connector both ways, although I am aware that polarity is not supposed to matter with this connection. That didn't help. After some research, it seems like the MINTEMP error code indicates that the silicone pad thermistor is not being detected, but I'm still new to all of this, so I don't know that for sure. The power wires for the silicone pad don't seem to have any polarity to them, but I tried connecting them to the MOSFET both ways to rule out that issue. It did not change anything.

Are there any changes that must be made to the firmware when switching from a PCB MK2 heater to a silicone pad? Also, I have a multimeter but I do not have experience in using it, so I do not know how to verify the thermistor wire voltages.

I feel like there are so many people who have made the switch to silicone heat pads, and I have yet to find anyone else struggling with the fact that the thermistor wires come without connectors. There must be something simple I am missing.

Any suggestions would be greatly appreciated, as I am stumped. If there are any videos or resources that specifically show this portion of the silicone pad installation, I have not been able to find them. But if you know of one, please share the link!

Thanks for taking your time to help.
Sorry, only registered users may post in this forum.

Click here to login