Welcome! Log In Create A New Profile


Shortcut, Printhead thermistor and X Mechanical Endstop. Pullups???

Posted by Salaskin 
Shortcut, Printhead thermistor and X Mechanical Endstop. Pullups???
April 14, 2017 06:04PM
This is very weird. The strange thing is that this printer has been working for 1 year now and for some reason I changed the printing head and now I started getting this problem.

The situation is as follows:
1) I connect to the printer with pronterface, no problems there. I am running a Ramps 1.4 config with arduino mega 2560. I installed the latest Marlin Firmware "Marlin-1.0.2-2".
2) I can set the temperature and it works fine, On the hotend and in the bed. It hits the target temp and PID works fine.
3) Now here is the issue. While the heaters are ON and all is working, I hit the "Home X axis button", the X carriage starts to move and as soon as the Mech Endstop is triggered, both my temperatures drop to cero on Pronterface, and I get this error message:

: Extruder switched off. MINTEMP triggered !
Errortongue sticking out smileyrinter stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

4) So I push the X carriage with my hand so that the Mechanical Switch is no longer being pressed... Then I enter M999 on the Pronterface Imput terminal, and everything is working again as if nothing happened.

NOTE: I stopped messing with the printer for 1h and when I came back I tried to repeat the event.
To my surprise it Homed the X axis and still kept on reading the temperature, but I saw that I got a big drop on the temperature, about 40degC.
So I did it again, and as soon as it hit the mechanical switch, another drop, of 80degC.
By the third time, I got the same error message as above.

5) So as I am writing this it becomes more and more obvious that I might be having some parasitic currents messing with my Thermistor readings.

6) Also I was reading about the need to install resistors or to enable the "Pullups" on the Marlin Firmware. It says as follows on the Configuration.h of the "Marlin-1.0.2-2" firmware.

// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.

I have no clue as to what means. Do I have to put resistors? Do I have to do something with the pullups? What are pullups anyway??

I need some guidance please!
open | download - Mech Endstop.jpg (437.4 KB)
Re: Shortcut, Printhead thermistor and X Mechanical Endstop. Pullups???
April 15, 2017 04:26AM
You might have unplugged the X-endstop while fumbling with the new thermistor and then put it back the wrong way?
The yellow cable is signal, red is 5V and black is GND. Also make sure, the cables provide good contact to Ramps. ( especially GND- faults can cause trouble )
Re: Shortcut, Printhead thermistor and X Mechanical Endstop. Pullups???
April 15, 2017 10:22AM
Hello o_lampe,

The connection is wright, It works good for the first 3 attempts, but after the third one I get the massive drop in the Hotend temp reading, that causes the crash.

It's as if I'm getting some kind of buildup current when the Mechanical Endstop is engaged.
And it gets released into the thermistor line, causing the drop in temp.

Now where is this happening? that is the real question.
Is it inside the RAMPS shield? I already bought a new one, I'm waiting for it to arrive
Is it my cabling?
I already swapped the Arduino Mega 2560, and the problem persists..

I have gotten to the point where I'm going to start measuring every single cable with a multimeter, to see what I find.
But that's like finding a needle in a haystack.

Well I don't know what else to do.
wish me luck
Re: Shortcut, Printhead thermistor and X Mechanical Endstop. Pullups???
April 15, 2017 12:29PM
Wiggle the thermistor wires while measuring the resistance, probably going o/c or s/c when in a certain position.
Sorry, only registered users may post in this forum.

Click here to login