Welcome! Log In Create A New Profile

Advanced

Which firmware should I use?

Posted by Sublime 
Which firmware should I use?
March 08, 2011 12:39AM
I have a ramps kit on its way to me now and I'm trying to decide which firmware to go with. I plan on using replicatorG and/or repsnapper.

I have tesla893's and johnnyR's most current versions of Tonokip's firmware as well as the newest Teacup firmware compiled for 2560.

What firmware are you using? Any reason you choose it over others?

Thanks in advance

Just thought I would add that I have min and max endstops

Edited 2 time(s). Last edit at 03/10/2011 04:30PM by Sublime.
Re: Which firmware should I use?
March 11, 2011 08:46AM
Where /how did you get Teacup compiled for Arduino?... I've been using RAMPS for a while now, and have always used tonokips or tesla's fork...

I've run into issues with XY speed being lower than expected at higher feed speeds now though, and am casting about for other options.

Al...


[araspitfire.blogspot.com]
Re: Which firmware should I use?
March 11, 2011 01:26PM
You get it from here. [github.com]

Instructions are here. [reprap.org]

But to get started you need to copy the appropriate config file (config.ramps.dist for ramps, config.h.dist for other) and rename it config.h and modify it to match your hardware. Then copy and rename thermistor.h.dist to thermistor.h and change the table to match your thermistor. Then open it in the arduino IDE and upload it to your board ( If you get a message that your machine does not match the make file it is because the arduino IDE is set on the wrong board )

I have successfully compiled it for my 168 and 2560.
Re: Which firmware should I use?
March 17, 2011 06:49PM
Thanks for the teacup info. Couple of problems with it though.

It does compile but..

using HOST, Temp reporting is incorrect even with correct thermistor table (I may have damaged my hot end now). Heated bed option doesn't work, reading no volts on the pins and again reporting very low temps. Software endstops cannot be disabled (causes compile errors), so hardware endstops don't seem to work either. Honestly this RAMPS setup is a big problem, with windows. I've tried all the options apart from FiveD firmware
Re: Which firmware should I use?
March 17, 2011 07:27PM
There is a special setting in the teacup firmware to set which version of the RepRap host you are using. But most people use replicatorG or repsnapper to send the codes to the board. As for the endstops, I do remember reading something about that in project teacup forum. Its still considered under development and is being updated very regularly. Most of the problems are dealt with promptly on the project teacup forum. Thanks for your input, I hope to hear things start working better for you.
Re: Which firmware should I use?
March 18, 2011 05:18AM
i have seen this quite a few times in quite a few places.
why does config.h for Gen 3 motherboard have temperature sensors and settings ... at all?
there is no temperature sensor or reading that master motherboard has to do in gen 3, so i cant see why those are there.
it only reads them from the slave extruder and thats all?
Re: Which firmware should I use?
March 18, 2011 08:59PM
@noobman

I'm not sure this is the right place for your comment. This does not concern gen 3 electronics. And R.A.M.P.S. does not use a separate extruder controller.
Re: Which firmware should I use?
March 18, 2011 09:00PM
This still leaves an open questions....

I too have the hardware to build a RAMPS on the way and I'm looking for firmware...

Any recommendations?

Thanks!
Re: Which firmware should I use?
March 18, 2011 10:23PM
epengr Wrote:
-------------------------------------------------------
> This still leaves an open questions....
>
> I too have the hardware to build a RAMPS on the
> way and I'm looking for firmware...
>
> Any recommendations?
>
> Thanks!

I use tonokip's firmware, it runs well for me.


Cameron

Help improve the RepRap wiki!
Just click "Edit" in the top-right corner of the page and start typing.
Anyone can edit the wiki!
Re: Which firmware should I use?
March 19, 2011 01:54AM
@hexitex

Looks like the answer to your temp problems can be found [forums.reprap.org]

@newperfection

Are you using tonokips original, JohnnyR's, Tesla893's or someone elses custom version.
Sorry, only registered users may post in this forum.

Click here to login