Welcome! Log In Create A New Profile


Firmware again!

Posted by hexitex 
Firmware again!
March 23, 2011 09:33AM
Ok, I can print with JonnyR tonokip firmware and then I found Tesla's version which is more complete with support for heated bed and a few other codes. Running skinheadForge 40 with the dimension plugin active Jonny's firmware works like a treat, but that doesn't have enough for me so I switched to Tesla's firmware with the same changes in the config.h file to support new maths in SF 40 i.e extruder speed at around 367.355 for 16 micro stepping on Adrian and that works in Jonny's fine but using the same value in telsa's the extruder is going mad and fast - having looked through the code on both firmwares I cannot understand why! I found that tesla had this value: float feedrate = 3000 and jonny's had 1500, so i changed tesla's version but to no avail - it still runs far to fast and long.

It seems I also need stupid proof instructions for getting mechanical endstops to work, I have added the code to use internal pull resistors in the firmware

and wired like this:
sig to com
- to nc
+ to no

but using repsnapper home commands things just bash into the sides, bottom, top, etc - it's driving me mad and putting serious stress on the machine.

Any help would be very welcome - thanks

Re: Firmware again!
March 24, 2011 01:25AM
Re: endstops

sounds like you need to invert your endstop signals.

You can either swap the + and - lines on your switches, or you can do it in the firmware.
Re: Firmware again!
March 24, 2011 07:04AM
Cefiar, I have tried inverting in the firmware to no avail, if I swap the cables around Ramps disconnects from the PC when the switch is triggered?. I am seriously wondering is if anybody has a working Mendel with Ramps, mechanical endstops and Heated bed? I didn't think it would be this hard to get the thing going.


Re: Firmware again!
March 24, 2011 10:34AM
where did you get your ramps board from.?

Re: Firmware again!
March 24, 2011 10:36AM
Ultimachine -do you think there is a board problem? I bought two so could try the other oneconfused smiley
Re: Firmware again!
March 24, 2011 10:43AM
i dont have my huxley, but i have seen a few people use them. so far i have only tested things with it and it all seems to work so far. have you tried to email them about your troubles, though last email i got back from him was slow, he did respond to help me with my issue at the time.

have you used a multi meter to test your pins to make sure there getting the proper voltage.?

i will be using opto endstops myself. once i get my kit in and built

Re: Firmware again!
March 24, 2011 06:51PM
at last, almost there, min endstops working at last (max not)- there was a new tesla firmware which seems to be better. still a funny problem with the gcode being sent though take a look at this and let me know if it looks right

These are my setting to work with SF40, the e_steps is approx
//Calibration variables
float x_steps_per_unit = 80.376;
float y_steps_per_unit = 80.376;
float z_steps_per_unit = 6667.184;
float e_steps_per_unit = 377;
float max_feedrate = 18000;

when repsnapper sends any e value is also sends a multiplier which is not in the gcode file, like e2.117 * 115 why?

just to add, i spotted the downstream multipliers for feed and extrusion but these are both set to 1!

Edited 1 time(s). Last edit at 03/24/2011 07:01PM by hexitex.
Re: Firmware again!
March 24, 2011 07:27PM

Seems that turning chksum in the config file fixed the wild things, must be getting corrupt packets

thanks for all the help
Re: Firmware again!
March 25, 2011 11:33AM
Another thing spotted, and i should have checked this, is that repsnapper home buttons seem to send cmds that ignore the endstop detected, it could have been I have the end stops working all along, when sending G28 (home all) it works just fine. Still not sure how to confirm max end stops are working as repsnapper seems to send bash into the sides cmds, although i would have thought it was the job of the firmware to detect endstops regardless of the cmds sent?
Re: Firmware again!
March 26, 2011 07:27AM
What you are seeing is a change to the code. Im not sure why it was made but the Endstop checking was taken out for everything except the "Home all" code G28.. It is documented some place in the release maybe in the read me?

Its a pity the end stops have been removed from the other instructions tho as I would prefer to be able to Home an individual Axis. So it can be made to avoid hitting or passing over anything being printed.

I have created my own fork to start making a customised version as yet time has not been on my side so its just a fork without change.

I have a prefrence for the Teacup version of the Firmware ~ sadly I have as yet to get this to work with the Windows version of Repsnapper...

I have been reading the Teacup thread and there have been sublte changes to the communications protocols over a period of time. My example is "Start" was changed to "start"

Quoting Traumflug on page 27 of the main Teacup Thread
Example: "Resend:" was changed to "resend:", then to "rs:" and perhaps something another in recent versions. Each of these changes resulted in a few angry disappointed users and of course Teacup was considered to be the faulty part each time. I don't want to blame anybody, but if people want faster and more reliable firmware, they should at least consider bugging host developers for their intentionally breaking/sloppy/useless changes as well.

My one and only point is It would be nice to have some kind of formal matching of working Host SW to working Firmware..

It seems like the Firmware & Hostware are shooting off in many diffrent directions leaving a novice builder in the lurch.

I sugested in the Teacup thread that there should be a table or list of working combinations or a Repository that has a Zip file of both parts that match eg a Host SW and a Firmware version Frozen in time as they worked.. they may have some bugs but they work, the bugs can be documented like a release note.

Doing some thing like this will prevent some of the frustration that I see within the threads.

These kinds of problems do occure on complex software projects they tend to be maintaind by a configration management team. Their job is to ensure that all the parts of a software build match for that point in time so that a stable release of the software can be made for testing.. etc.

RepRap SW is more complex as it is two seperate builds on diffrent platforms that need to match up at that point in time.

We know that there must be matching combinations made. We just need the matching combinations frozen before the next change is made. Else its like tring to win the lottery to get a combiination thats working.!

This is the working combination I use:-

The original Windows Repsnapper with original Tonokip Firmware.

The hardware I am using is 2 original gen3 V1.1 motherboards and 8 Gen3 2.3 stepper controllers.
( I do NOT use extruder controllers even though I have 4 of 7 extruder controller boards built.)!

I just change the pins to suit my hardware build and the XYZ & E resolutions
(all driven from the one motherboard) it just works so this is what I am still using.

This combination occured as both developers stopped devloping ~ hence they became frozen in a working state.

I have been using a heated bed with a seperate controller. Im now looking for a Working combination of Host and Firmware to give me that extra controll. Teacup looks like it has more users with working versions reading the thread.

Im off to a Sony Ericsson Smatphones UK reunion so wont be back here till tomorow ...

Edited 1 time(s). Last edit at 03/26/2011 07:44AM by BodgeIt.

Bodge It [reprap.org]

BIQ Sanguinololu SD LCD board BIQ Stepcon BIQ Opto Endstop
BIQ Heater Block PCB BIQ Extruder Peek clamp replacement BIQ Huxley Seedling
BIQ Sanguinololu mounting BIQ standalone Sanguinololu or Ramps mounting Print It Stick It Cut it

My rep strap: [repstrapbertha.blogspot.com]

Buy the bits from B&Q pipestrap [diyrepstrap.blogspot.com]
How to Build a Darwin without any Rep Rap Parts [repstrapdarwin.blogspot.com]
Web Site [www.takeaway3dtech.com]
Re: Firmware again!
March 26, 2011 10:32AM
i like and i will support your idea bodgeit. i wonder what the best way to do it would be. i would almost think something like where you would select your hardware, then select your host software then it would give you what a choice of downloads if there was any.

Re: Firmware again!
March 27, 2011 10:48AM
I'm dealing with this now. The very first few times I got motors hooked up to RAMPS hooked up to the computer they moved. Only in one direction, but they did move. Now that I've got endstops attached none of the motors want to move anymore. I figured, "Hey, I'll just read through the firmware to see if I can find something wrong" but that's a horrible idea since it's pathetically documented. One comment simply repeated the variable name again.

I get that an open-source software project is going to be schizophrenic, but haven't people been running RepRaps for a while now? And isn't the ENTIRE POINT of the RepRap project to grow the population of printers? Well, you're not going to be able to increase the number of printers after you exhaust the very small population of people who can re-troubleshoot their own complete toolchain. I can handle the mechanics, and to a lesser extent the electronics, but when the software has problems I'm pretty much at a loss. Not many people can fix problems in all three of those areas.

Shouldn't the software be HEAVILY commented? You know, since the reason it exists is to get NEW people to build a printer? And now even the electronics are fragmenting, with Gen 3 and RAMPS still around, but Gen 7, Gen 6, and the ultimachine board, and whatnot. This is only going to get worse if we can't bring some sort of order to it.
Re: Firmware again!
March 27, 2011 02:06PM

I am not sure that giving the devs of the firmware a hard time is a good idea. They do this out of the goodness of their hearts and should not be expected to do it on cmd. Asking with a nice message is a far better way - hell you can even add a <3 smiling smiley but i hear you - its hard work getting a mendel working as described - my wife is pissed off with my lack of presence finding me with arse in the air looking at a printer
Re: Firmware again!
March 27, 2011 02:14PM
i am starting to wonder if the reprap group would start to benefit from some sort of small governing body, that could be supported by crowd funding, i would like to support the community, even if they offered a flatter link for the wiki i would do that, and has some sort of incentive for hardware makers to follow within certain design lines offer some sort of compatible branding from them. that way the hardware constraints would really only be based on what each pin out is, they would be free to design how they see fit.

Re: Firmware again!
March 27, 2011 11:54PM
@makeme I feel and think exactly the same way!

I don't understand how RepRap grow so "big" and that everything is a big mess.
I was soo happy about the RAMPS of ultimachine, because it was sooo cheap compared to Gen3.

Now I'm lost between repsnapper linux, repsnapper windows, Tonokip firmware, tesla firmware, skinforge, replicatorg G, etc...

Nothing work properly, I'm not blaming all the people that work hard on those software, and I'm a software Engineer I could fix those firmware/software myself but I cant because it's just too badly documented, I have just NO idea what to do. I even don't know where to start.

Repsnapper + ramps + stl file on Linux, works properly however the gcode generator doesnt do a good job.
The same config on windows can move the printer, but the gcode generator does not work at all.
The host software + fived doesnt work properly.
ReplicatorG is the same in my case.

Anyway I wondering if I should just sell the whole printer and buy a Makerbot...
Re: Firmware again!
March 28, 2011 12:01AM
this is going to be an issue the community will need to solve soon i think. i like allot of what this group stands for, but at the same time its like herding cats.

Re: Firmware again!
March 28, 2011 12:28AM
Not sure if this works as I do not have my ramps yet, but natetrue has a git account with what I assume is a working combination of replicatorG and tonokip firmware. They can be found here [github.com] and here [github.com] . Its hard to find as he did not fork them so they are not in repG's tree or tonokips tree, but hey it is on my list of "will try" if I can not get teacup to work with replicatorG.
Re: Firmware again!
March 28, 2011 08:03AM
There is something fundamentally wrong with the reprap project full stop, too many hardware and software permutations have broken it. The whole thing is under attack from people making money without regard for whether it works or not, RAMPS being a classic case. There are also a lot of secret keepers - I don't understand how some people have outstanding prints (like Nophead who recommended RAMPS to me) when mine are frankly rubbish - small setting changes in that abomination called Skeinforge have drastic effects, yet there are no out of the box settings that work. It's not like I built a different machine, it's the standard Mendel with the standard extruder - I bought the standard pre-built Ramps kit from Ultimachine expecting there to be a solution to make things to work - nope - the whole combination is utter rubbish. Why?

I am getting at least 10% corrupt packets - a large print has never finished. Things like Repsnapper only being developed for Linux variations is frankly appalling, like most of the world I don't want to run Linux. I would challenge anybody to find fault with my mechanical build. If you haven't bought RAMPS yet don't.

And you know why I changed my mind since my last reply to makeme? One of the stepper drivers CAUGHT FIRE last night - yeah that's right Fking FIRE - if i had not been there it could have very serious like killing people, and if that did happen I promise you those that made money from me would be in a whole world of real shit. I'll post pictures later when I get home. Expect to see the end of RAMPS
Re: Firmware again!
March 28, 2011 09:57AM
Uh, just checking in on this thread. Lots of people having problems.

My own experience has been that the level of documentation is disappointing. However, these things are not plug and play, so I expected to have to do some hunting around for enough documentation to figure it out. I've had to dig into each component to understand it at least a little, and I've ha some hand holding from the community.

I'm working from XP 32 bit. Repsnapper is a little glitchy, but it works. It can produce CGode that will make parts. I've done it. They were terrible. Skeinforge, even with my very limited experience and little tuning, is making much better parts.

RAMPS is working fine for the most part. None of my Pololu drivers has ever been nearly hot enough to catch fire. Not without some kind of help. They seem to have a built-in thermal cutoff. If you drive them too hard, they stop working for a little while. I have no idea how yours managed to ignite. I can only guess that there was a short somewhere.

I do have a little irregularity with connecting the the Arduino Mega, and Repsnapper reports a lot of checksum errors and resent commands.

RepRap is not ready for pushbutton use. You need to understand the machines and know what you're doing to use the machines safely and effectively. Almost all of the components are still in some form of development. Work with it. The parts are all there, but it is a bit of a puzzle. Somebody has put together a great visual assembly guide for the Prusa Mendel, I hope somebody writes a similarly effective learning tool for the software tool chains. The problem is, they are still changing pretty rapidly.
Re: Firmware again!
March 28, 2011 01:06PM
hexitex Wrote:
> Ok, I can print with JonnyR tonokip firmware and
> then I found Tesla's version which is more
> complete with support for heated bed and a few
> other codes. Running skinheadForge 40 with the
> dimension plugin active Jonny's firmware works
> like a treat,

What is SkinheadForge 40? is it a repsnapper replacement? I found nothing about it when googling.
Re: Firmware again!
March 28, 2011 01:17PM
Dale, I think we all knew that these things are not plug and play, but the fact remains that RAMPS has the least number of users and hence the least working software - the maker/designer of the hardware should address this - it's not right to sell this stuff if there is no up to date software that supports the features of the board. Yeah, I can get a working version if i don't want fan & heatbed support but as you know 3d printers generally require them to print larger parts.

Working version is:
jonnyr tonokip firmware - least packet corruptions (tesla version for some reason has about 10% which results in aborted prints)
repsnapper v1 - poor quality sender - I understand this is much better in the latest incarnation for linux, alas i'm not a linux user link most of the world.

everything else just doesn't seem to work to the point where a decent print is achievable.

my stepper drivers were not running hot as they were only at about 25% and ran just fine- so it wasn't a general build up of heat. I'll need a closer look to establish why it caught fire - it was late and the whole thing almost ended up getting a sledge hammer as an add-on bit of hardware. Oh the toolchain is not a problem for me, i understand what needs to be done but the software isn't changing rapidly - it isn't changing at all as far as RAMPS is concerned.
Re: Firmware again!
March 28, 2011 01:19PM
What is SkinheadForge 40?

It just my bit of sillyness - Skeinforge version 40 - it creates gcode files from stl files
Re: Firmware again!
March 28, 2011 02:21PM

Ramps is based on adrians pololu shield which most of the new electronics are based on making it the most used system, not the least as stated, you can even download the official 5d firmware and change the pins to use the reprap host or use johonnyR's edited version found here [github.com] either way it does not stack up to the quality of skeinforges slices or user friendliness of repsnapper. Hence why no one mentions it. Next as a poster above mentioned fires are caused by shorts, did you solder it yourself?

Anyone who is not willing to do debugging and a little thinking should probably stay far far far away from home rapid prototyping. But if you must and just want to buy a machine, WHY would you buy anything but an UP?

I am amazed by how many people jump into reprap without reading what it is and how much work it is to build a working machine that makes high quality prints.
As for nopheads prints, they are some of the best out there. He has been making small tweaks for a couple of years now and if you had read every page of his blog you would see he has gone through like ten revisions of his nozzle and bed. He did not buy something and get pissed off when it did not print like a $30,000 Dimension printer, he built every bit and programmed it himself

As for Windows, TIME to upgrade to a big boys system and run LINUX.

Always FREE
You are not forced to use anything you do not want.
You can play none DRM signed media
When you google a problem you find answers, not more people with the same problem like with windows.
Did I mention NO VIRUSES
and always FREE.

Oh and you no longer need to be comfortable with the command line to use LINUX.
The new MAC OS is built on top of a combination of Linux and FreeBSD.

Hexitex you say " like most of the world I don't want to run Linux "

You are the first person I have ever heard say they like Windows. The world runs windows because they are forced to when they buy a complete computer. Unless they want to spend 5x as much for a mac that runs proprietary software on top of LINUX/freeBSD. Any windows user willing to try LINUX will NEVER turn back. I have switched at least 20 people over in the last year. IT IS EASIER THAN WINDOWS but you may have to learn a few new terms.

For windows users who want to switch over start with UBUNTU or LINUXMINT, If you can't deal with things being new you can run something like ZORIN OS, it has a feature where you can switch between being set up like Windows XP, Windows 7, Vista, Windows 2000, MAC OS X. Oh and trouble free unlike windows.

Did I mention that Ubuntu will boot in under 30 seconds from a normal hard drive and under 10 off a SSD.
I can boot UBUNTU ( 9seconds ) then start a copy of windows 7 in virtual box ( 10 seconds ) and then shut them both down ( 45 seconds total ) before a Normal copy of windows would boot on the same computer.
Re: Firmware again!
March 28, 2011 02:46PM
Sublime Ok I get it you don't like windows and you love Linux - each to their own. BTW I have never had a virus, only a novice on any system including linux will get a virus. And so what if i want to complain to the ether (yes that dead space where the designers and makers of the hardware don't bother the read anything on this forum) are you telling me things actually work with the RAMPS setup on the most popular operating system in the world? I am no idiot, i understood that things might be a bit tricky but i never expected to see the Linux mob rule the space with no release for windows. I've tried the 5D and host software and that had another set of problems.

And i have tried Linux which i didn't like - so there you go. I design software systems (big ones) for a living so don't think i don't understand what is going on, I program in various languages not so much these days but i can if needed. As for nopheads prints, i agree they are great but it's still a mendel at the end of the day, where is his software and settings? open source my arse.

Oh and yes my soldering skills are not good but that is not the reason for the fire as you'll see on another thread

Edited 1 time(s). Last edit at 03/28/2011 02:48PM by hexitex.
Re: Firmware again!
March 28, 2011 03:03PM
Nophead is not using the open source tool chain or hardware available. He is using his own software and hardware that run over ethernet giving him super high speed communication. There is a thread in the forum ragging on him for not making it fully open, but almost no one gives back as much knowledge as he does. And most of his prints best prints are from HydraRaptor.

I will not get into the Linux vs Windows thing anymore. Except to say you have a few pieces of software (the most popular) skeinforge, reprap host, and replicatorG available. Why are you insisting on using the only one that runs better on Linux. Repsnapper does have a fairly recent windows build (last few weeks). If you are a programmer, give back to the community and make it better by porting the newest repsnapper to windows, the code is all there.
Re: Firmware again!
March 28, 2011 07:54PM
i would rather not see this forum end up in another forum shouting match, yes i know there more exciting, but in they end we all end up back at square one.

there are allot of valid points in this thread, some i know i will be dealing with soon, more so for me has i am a hardware guy, but i can generaly muck things up enough to work with both windows and linux, i have found it very beneficial to be versed in more than 1 os, it has saved my hide more than a few times.

i would also like to point out there is curently a challange for a stable toolchain so i would like to see people add to the bounty. i will be adding a 1Lbs spool of pla to the bounty after my next paycheck. http://groups.google.com/group/makergear/browse_thread/thread/b145a746c59248d6/4274e1a81f8a3755#4274e1a81f8a3755

Edited 1 time(s). Last edit at 03/28/2011 07:54PM by dissidence.

Re: Firmware again!
March 28, 2011 08:00PM
Hi hexitex,

I would feel bad you are having so much trouble if you were not so busy making a troll out of yourself.

Yes I read these forums, however I do have other responsibilities and do not do so every day. First and last time I read this thread it looked like 34 hours after the initial post you announced it was solved. At that point it changed topic midstream. For a better answers to your questions it is best to post new topics in new threads.

As Sublime mentioned thanks to Kulitorum there is new Windows flavored build linked from [reprap.org] . As for the packet problem, did you turn off temperature monitoring during print? It is known to cause serial issues during prints, possibly due to the lack of line number on the M105 command.

In the future if you have some problem with one of our products and need support from UltiMachine or me directly, I suggest email us through our webstore, or pm me directly through the forum. I do follow the feed from this forum, but it is mixed in with tons of other feeds and there are only so many hours in the day. We strive to please every customer, and stand behind our products and RepRap in general. There is currently several of us working at UltiMachine, but I am the only one with enough knowledge to help with some of these issues. We will do our best to help.

Re: Firmware again!
March 28, 2011 08:29PM
Sorry, Trolling? I don't see where that happened in my posts - ah you mean reporting my problems and the fact that the hardware almost burnt my fking house down!

Yes my solved comment was a little bit too hasty - when i said solved i meant that i finally figured out to uncomment the chksum and linenums in the tesla version of the firmware so the machine didn't try and distroy itself with moves in the direction of hell. Fact is Jonny, this whole thing is a right mess from a users point of view, there isn't a stable windows toolchain for the RAMPS setup. As it has been noted I should be running the wonderful Linux but i am not - so where am i left with this? I will download the beta release of Repsnapper and do my best to get things moving again but i have to say this; you should maybe put more work into making your hardware work on the most popular operating system in the world as opposed to using the trolling card on people that just want to complete a print.
Re: Firmware again!
March 28, 2011 09:08PM
The stable tool chain you are looking for has nothing to do with RAMPS, it is Host software talking to an Arduino with firmware on it. Ramps is an interface board between the Arduino and cheap off the shelf stepper drivers. How you use them and the firmware required too achieve what you want are up to you. All that is different about RAMPS and Adrians Pololu Electronics is the pin configuration in the firmware and your hardware configuration.
Re: Firmware again!
March 28, 2011 09:17PM
Cool, then show me a working windows toolchain if it is that simple. It 100% isn't. I can adjust pin assignments till the cows come home but it will not help me in actually completing a print. to put it simply the socket code is fcuked.
Sorry, only registered users may post in this forum.

Click here to login