printer resets on "heavy" commands
November 19, 2017 05:29PM
Hey there,

I today switched the mount for my reprapdiscount smart controller display of my Flsun cube and after I did this and turned on the printer again it started behaving wierd:

-on the first attempt the display just started flickering (on and off) and the printer did not start up (caselight did not turn on)
-on the second attempt the display didnt do anything at all
-then after some retries I got it working but I could not run any "heavy" commands like heating up the nozzle or do aout homing (moving one axis was working though) because the printer would simply reset itself

I then tried running the commands with my computer to be clear my board is not broken:

-Auto homing worked fine
-heating up the nozzle seemed to work fine... till 40 degrees then it would not heat up any further (just always a little bit if I repeated the heating command)
-similar with heating up the bed although the bed is run via a mosfet so there is not much current needed to be provided by the bed
-i could run the commands from the display IF the usb cable was connected to my computer without the printer resetting itself but it would not heat up properly either

I have absolutely no clue what is broken now
I appreciate every help of you guys

Edited 1 time(s). Last edit at 11/19/2017 05:30PM by Schild0r.
Re: printer resets on "heavy" commands
November 20, 2017 04:04AM
Sounds like you have made a shortcut in the display cables. The 5V regulator seems to pass out from overheating...
Unplug the LCD cables on the controller, run the printer from USB and see if the problem still exists.
Re: printer resets on "heavy" commands
November 20, 2017 08:34AM
I will try when I am home from work thanks
This morning I tried it with the stock ribbon cables (I one needed longer ones so I ordered them in 26AWG instead of 28AWG in order to compensate for higher conductor resistance) but it made no difference so its not the cables.
I have another display to which I will try in the evening.

The 5V regulator seems to pass out from overheating...

Does the regulator sit on the display or on the board?
Re: printer resets on "heavy" commands
November 20, 2017 03:06PM
So i tried the second display: did not work properly either just flickering or resetting
(but somehow I could heat up the nozzle to 180 degrees but when I inserted the SD card the printer resetted itself)
Then I tried to run the printer from my laptop after disconnecting the display cables from the board: it started up but it did not respond to any command...

So do I have to get a new board? Its the mks gen L btw
Re: printer resets on "heavy" commands
November 21, 2017 05:23AM
The 3.3V regulator is on the LCD controller and it is fed from the 5V regulator on the MKS board. Some older Sd-cards draw too much current, but you said, it worked before.
The longer cables are probably crimped in a different order? Compare the position of the notches ( if any ) on the cable and the red line on the ribbon cable ( indicating pin 1 )
I know of issues, where users had to plug in the cables in reverse direction, because they were crimped the other way round..Some had to cut off the notches or remove the plug housing on their controllers.
Re: printer resets on "heavy" commands
November 21, 2017 12:22PM
It worked 2 months with the new cables... grinning smiley
Sorry, only registered users may post in this forum.

Click here to login