Welcome! Log In Create A New Profile


No Z axis stepper movement

Posted by ibWizard 
No Z axis stepper movement
February 03, 2018 05:04PM
Updated my Ramps 1.4 to 24vdc. Z motors will sometime power on but not move when commanded via the Repetier software. Others time they will not even power on. Sometimes there is the sound of a "pulse" and nothing. Check the wiring against information found on the web (which can vary the pin names 2b, b2 a, 1 and color code of wires). The Z axis doesn't drive any motors. I have to say this has been one of the worst things I ever had to build. I consider myself to be good at troubleshooting hardware, software not so good. Everything worked (to some degree) before. I'm using the same firmware as before the upgrade. Nothing has been cut. I've struggling with this build (on and off) for 5 months. Every time I think it's finished something stops working (and that's just between power cycling or connecting and disconnecting the UScool smiley. I've replaced every board and drivers, which lead to new problems with the already working parts. Currently my RAMPS 1.4 board is running on 24 vdc, Arduino is powered by a LM2596 24 to 12 converter supplying 10 vdc to the Arduino, DVR8825 stepper drivers. I've even tried a Keyestudio Arduino Ramps 24 vdc combo board (it blew up three stepper drivers). Desperate for help.
Re: No Z axis stepper movement
February 03, 2018 05:34PM
Loaded the Ramps14_test, Z axis steppers still don't move. Enable pin stays at 0 vdc. Direction pin reads 4 vdc. Step pin reads 0 vdc. No voltage on any of the stepper pins (B2-B1 or A1-A2). I even swapped drivers (X axis driver with Z axis driver) no change.
Re: No Z axis stepper movement
February 03, 2018 07:05PM
Then you have a hardware fault. as the test firmware blindly moves all axis

Enable is active low... so that should be ok.

Step pin should read more than that,

Check you have continuity from the pololo z-step pin to to D46

Also make sure there are no solder blobs around this area. on the ramps or the mega

also as a sanity check your ramps should be flush on the mega, you shouldnt be able to see any pins between the ramp and mega when it it plugged in.
Re: No Z axis stepper movement
February 06, 2018 08:21PM
Thanks, Dust. Continuity confirmed between the step pin and D46. There are no solder blobs. This board worked fine before the 12 to 24 volt change
Re: No Z axis stepper movement
February 06, 2018 10:10PM
check vmot pin has 24v on it
Sorry, only registered users may post in this forum.

Click here to login