Welcome! Log In Create A New Profile


ramps 1.6 + servos ?

Posted by davidmarli 
ramps 1.6 + servos ?
April 19, 2018 01:52AM

I just bought a ramps 1.6. It seems great, but when I plug my bltouch in servo, nothing lights on...
With my multimeter, there is no 12v between + and - but 0v...
So is there something to do to have power on servos ?

I see 2 pins with no connectors J4 (betwwen the two green connector) is that the solution ?
I find nothing about this ramps 1.6

Thank a lot.
Re: ramps 1.6 + servos ?
April 19, 2018 04:56AM
Servos can be very power hungry, that's why they can be fed from an external 5V source instead of the weak internal 5V reulator. This is usually selectable by a jumper ( which seems to be missing in your case )

BTW: I've never heard of RAMPS1.6, would be nice to add some more info...
Re: ramps 1.6 + servos ?
April 19, 2018 05:25AM
ramps 1.6 is not open source... so no documentation.. (Shakes fist at manufacturer!!)

On a normal ramps there is no voltage on the +5v pins of the servo lines until it gets jumpered to vcc

most servos are not 12v... so I would be careful trying to get 12v there...

The image I see does show a track going from the +v line to somewhere.. but cant see where...
Re: ramps 1.6 + servos ?
April 19, 2018 05:28AM

Its a bigtreetech only board.

violates gpl, no documentation

avoid at all costs
Re: ramps 1.6 + servos ?
August 30, 2018 07:55AM
Created an account just to reply to this!

After a bit of multimeter probing, I found that they moved the servo power jumper right next to the E0 servo header. Putting the jumper over the center pin and the pin closest to the E0 header supplies the servo header with 5v.
Re: ramps 1.6 + servos ?
April 13, 2019 06:38PM
Created an account just to thank you !

That works ! Thank You!
Re: ramps 1.6 + servos ?
June 21, 2020 03:42PM
Hello everyone,

I was looking for this information. Thank you.

But; I plugged jumper to my Ramps 1.6 board correctly for 3D touch sensor. When I powered on, the arduino board started smoking. See the picture in attached.
I think I have to supply the sensor using an external power but the documents was not saying not to supply it using internal power of the board.
It looks like there's no problem with the Ramps board.

Anyone has any idea?
open | download - Image.jpeg (298.2 KB)
Re: ramps 1.6 + servos ?
June 21, 2020 04:30PM
... seems, your +5V-regulator was "overwhelmed" and fumed ... so you'll need external power ... and something more than 0.5 Amps eye rolling smiley

Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: ramps 1.6 + servos ?
June 21, 2020 06:29PM
Almost 1 year ago I shorted out the AMS1117 3 times though I found this adjustable voltage regulator module.
I replaced Ramps D1 with a 12volt 3amp Dc-Dc step down converter so I could power the Ramps using 24VDC and the Dc-Dc 12v converter would supply the Arduino.

Then I replaced the 5 volt AMS1117 regulator with the same regulator this time set to 5volt 3amp to replace the AMS1117-5.0

The AMS1117-5.0 dies with a simple quick short this part is extremely fragile.

I found the DC-DC Step Down Buck Converter 1.5V 3V 5V 9V 12V and Adjustable at 3 amps on E-Bay

Edited 2 time(s). Last edit at 06/21/2020 08:10PM by Roberts_Clif.

Computer Programmer / Electronics Technician
Re: ramps 1.6 + servos ?
June 22, 2020 06:17PM
Hello all,

Thanks for your replies. I would like to understand if I made something wrong here. Do you think it’s all about the incorrect specifications of clone Arduino Mega or is it a mistake to supply the sensor over Arduino at all?

All the documentation related to 3D touch sensor and Ramps board referring Ramps servo pins to supply the sensor. I think I have to test the sensor using a breadboard and measure the necessary current.
Re: ramps 1.6 + servos ?
June 22, 2020 06:28PM
I'm getting pretty good at replacing those voltage regulators on the Mega board. Nice to have the skill, but boneheaded to keep blowing them up! spinning smiley sticking its tongue out
Re: ramps 1.6 + servos ?
June 27, 2020 12:18PM

I've two of this boards. On both the middle row of the servo pins are shorted to ground. So if I try and put the jumper to route 5V from the Arduino there, the Voltage regulator will blow up.

On one of the boards I cut through the wire coming from the middle row up to the 3 pin jumper. With this the shortcut was removed, so it lies with the 3 Pin jumper not with the servo pins.

Beforehand I moved the black housings of the jumpers slightly up, to peek under them but there was no shortcut to be seen. Actually no solder was to be seen either, seems the holes are rather small.

As a 5V pin is nearby I soldered a jumper just next to the servo pins on the bottom side of the PCB. Works as advertised winking smiley I guess I'll never need the option to feed the 5V servo power from the digital I/O port (the other option on the 3 pin jumper).

I wonder if the servo block is rarely used or if I really had the misfortune to get two PCB's with the same error.

I've attached the pictures, for the cut and the new jumper, maybe can use it. The second PCB had the same result (shortcut on the 3 pin jumper) and was treated the same.
open | download - IMG_20200624_224412_1.jpg (761.9 KB)
open | download - IMG_20200624_224451_1.jpg (974.1 KB)
Re: ramps 1.6 + servos ?
June 27, 2020 01:09PM
This was what exactly I’d say. I checked the pins of J5. I have seen that, when I plug the jumper on the pins with 5V and VCC label, I actually bridge 5V and GND on Ardunio. Therefore, a blow up is so much normal now on Arduino. You can see in first two pictures of attachment.

I have two Ramps 1.6 board and both the same. What should be the correct jumping pins?

Regarding your good idea Henry Jones, I plugged power pins of servo to directly to AUX pin. What about that? You can see in last attached picture.

Edited 1 time(s). Last edit at 06/27/2020 01:29PM by higherstrike.
open | download - ACF458B5-0FA0-4044-9C46-8831BE1F17F2.jpeg (919.7 KB)
open | download - A39A6A39-EAE1-476F-95D5-D9601CC129A3.jpeg (781.1 KB)
open | download - 85925743-5C00-45D4-AC72-F6B098FD7129.jpeg (1013.2 KB)
Re: ramps 1.6 + servos ?
June 28, 2020 03:22PM
Hello higherstrike,

for me it seems to be a fault in the board itself. In the PCB document it seems to be ok, so the fault is either in production or in the soldering process. Both usually unlikely but obviously present.

Your solution is good, as long as you only need one servo to power (BT-Touch Sensor maybe). But remember to remove the jumper from J5 completely, otherwise you'll still fry the voltage regulator. With the fault present there is no "correct jumping pins" the feature to route power to the servo pins ist not working.

Good evening.
Re: ramps 1.6 + servos ?
June 30, 2020 04:16PM
Hello again,

It’s all clear. Thank you very much for your help.
I ordered new Arduino board and some piece of AMS1117 5V regulator. I’ll use the new board for my 3D printer and I’ll use this board for prototyping.
I hope there is no failure on other components.

Best Regards,
Re: ramps 1.6 + servos ?
November 09, 2020 03:40PM
@Henry_Jones, i recently bougth a ramps 1.6 and was searching about the 5v jumper because its different from 1.4, so fortunately ive found to this post before turn it on... I checked shortcurt on 5v and Gdn pins an there it is the shortcircuit... Im wondering use the @higherstrike solution or add an 7805 regulator to the circuit... any way this is the only post ive seen about this problem and looks like a fabrication fault...
Re: ramps 1.6 + servos ?
November 11, 2020 04:16AM
Hello blkzera,

It's been working fine on my configuration since above time. I have no external power source or regulator for 3D touch sensor. It is connected as seen in below pictures.

Best Regards
Re: ramps 1.6 + servos ?
November 11, 2020 10:41PM

It should be working fine, i wondering myself if who bougth this 1.6 version dont the 3D Touch or we are so unlucky, because i couldt fine another post about this problem, anyway, im waiting for the other parts from the machine, 3dtouch included it would be nice if we could solve the shortcurt problem for use the standard config... i wish i have a ramps 1.6 to make a teardown and try to find it... Anyway glad to found this problem before burnout my arduino.

Best Regards
Sorry, only registered users may post in this forum.

Click here to login