Welcome! Log In Create A New Profile


Lost Z height issue.

Posted by verb.zero 
Lost Z height issue.
June 01, 2018 08:39AM
I am working on calibrating my printer, I am trying to troubleshoot my Z axis but at this point I am lost. I have changed out about 6 pololus, and changed the settings in my firmware got a bigger power supply. I am using a RAMPS 1.4 board. The issue I am having is when my print FIRST STARTS after the printer has finished homing. The printer does a Z lift at what I’m guessing is about 3000 acceleration.( I will post my Marlin setting below). Anyways when the printer does the “accelerated lift” at the start of a print my Z motors freak out and I lose my Z height / Bed level. I have adjusted my DEFAULT_AXIS_STEPS_PER_UNIT so that the Z will run better but then my prints come out… squished? My prints loose Z height when I adjust this. If I run the Z acceleration more the 250 the motors freak out. I have tried adjusting the screw on the pololus and that is not working either. So could this be a symptom of a RAMPS going out or my motors maybe? The rest of the of the motors with 3000 acceleration work fine.

Here is what I am using Marlin 1.0.x


#define HOMING_FEEDRATE {800, 800, 200, 0} // set the homing speeds (mm/min)

// default settings

#define DEFAULT_AXIS_STEPS_PER_UNIT {80,80,4000,100} // default steps per unit for Ultimaker
#define DEFAULT_MAX_FEEDRATE {200, 200, 5, 25} // (mm/sec)
#define DEFAULT_MAX_ACCELERATION {3000,3000,200,10000} // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

#define DEFAULT_ACCELERATION 3000 // X, Y, Z and E acceleration in mm/s^2 for printing moves
#define DEFAULT_RETRACT_ACCELERATION 3000 // E acceleration in mm/s^2 for retracts
#define DEFAULT_TRAVEL_ACCELERATION 3000 // X, Y, Z acceleration in mm/s^2 for travel (non printing) moves

// The speed change that does not require acceleration (i.e. the software might assume it can be done instantaneously)
#define DEFAULT_XYJERK 10.0 // (mm/sec)
#define DEFAULT_ZJERK 0.4 // (mm/sec)
#define DEFAULT_EJERK 5.0 // (mm/sec)
Re: Lost Z height issue.
June 01, 2018 10:10AM
"Marlin 1.0.x" thats an antique, why not run a current version

No mention of what type of lead screw your using... an important factor when discussing Z axis

but most likely your simply trying to move them to fast.

Lower your Z max feed rate from 5 to 2, if that works try 3...
Re: Lost Z height issue.
June 01, 2018 10:15AM
It's the max. feedrate you have to reduce. My Prusa came with M5 leadscrews ( 4000steps/mm like yours ) and I had to reduce feedrate from 5 to 2 .
Re: Lost Z height issue.
June 01, 2018 10:21AM
Alright I will try that when I get home, I ended up using 1.0.x because I was trying to get a configuration.h file from MRice to work since I build his Wilson TS. I couldn't so i just plug in his variables and troubleshooting it from scratch.
Re: Lost Z height issue.
June 02, 2018 11:58AM
:: SOLVED :: Thanks for advice it seems to work correct now ya'll are awesome

Edited 1 time(s). Last edit at 06/02/2018 11:58AM by verb.zero.
Sorry, only registered users may post in this forum.

Click here to login