Welcome! Log In Create A New Profile


RAMPS 1.4 stepper driver failure?

Posted by M1k3 
RAMPS 1.4 stepper driver failure?
June 12, 2018 05:40AM
Hi All, I'm new here, my name is mike and about 6 months ago I bought an Anet A6.

Because this was not the quality printer I wanted, I made some pretty big modifications:

- Added aluminum frame based on the Anet AM8 (https://www.thingiverse.com/thing:2263216)
- Added Bowden setup with original E3D V6

Since the mainboard of Anet is also pretty crappy, I wanted to change this to RAMPS 1.4 (especially because you can change the current of the stepper drivers)

So yesterday i tried connecting everything to the ramps board to test 1 driver (DRV8825).

What happens now is i power the RAMPS board and connect to it through serial connection at 250000 BAUD.

After this i send "G1 X30 F3000" and i hear the stepper energizing (very soft humming) and it looks like it's trying to move.

Then after about 3 seconds the stepper is not energized anymore and the led on the RAMPS board (close to mosfets) starts blinking really rapidly.

The only way to reset the board is to totally cut the power (Also USB to RAMPS) and restart the system, it also doesn't respond to serial when it is in this "panic" state. (Also the reset button on the RAMPS doesn't do anything) the LED keeps blinking.

I couldn't find people with similar problems, but it might be that you have an idea what could be the problem?

I'm running on 1/32 microstepping (All three jumpers connected). and the Vref is set to 0.7 volts.

Thanks smiling smiley

Edited 1 time(s). Last edit at 06/12/2018 05:42AM by M1k3.
Re: RAMPS 1.4 stepper driver failure?
June 12, 2018 12:52PM
Are you sure the DRV8825 is placed in the right orientation on Ramps? I grilled a few, because I placed them the same as A4988 ( potmeter looked in the same direction )
Re: RAMPS 1.4 stepper driver failure?
June 12, 2018 01:29PM
Yes, the potentiometer is facing the power input of the RAMPS board.

I just found out the following:

The wiring is right, the two pairs are next to each other on the ramps board (black-red and blue-green).

if i move the axis on the LCD screen by 0.1mm increments the stepper whines untill i reach 2.0mm and then RAMPS crashes (LCD freezes)

Also, there is no resistance whatsoever on the stepper axle, i can just turn it without resistance. except if i turn the axis by 10mm at once, than the stepper is fixed, but after the "crash" it relaxes.

Any ideas?
Re: RAMPS 1.4 stepper driver failure?
June 12, 2018 02:35PM
Quick update, i ran the ramps1.4 test sketch RAMPS1.4_TestCode.pde

Here everything runs perfect, stepper moves perfect (lots of torque!) and the LED's of the mosfets turn on and off.

This makes it pretty clear my problem is in the Marlin settings, what could be set wrong in marlin for this to happen? i'm using the #define MOTHERBOARD BOARD_RAMPS_14_EFB setting.
Re: RAMPS 1.4 stepper driver failure?
June 13, 2018 03:32AM
Problem solved! it wasn't the drivers, it wasn't the ramps and it wasn't the Arduino.

Eventually, the culprit was Marlin, I downloaded the marlin bugfix build, and I might have screwed up the config, or there is a problem in the bugfix build for my specific situation.

What I also found was that on the bugfix build I used about 58% of the Arduino memory, and on the "stable" build, I used about 49%...weird stuff smiling smiley
Sorry, only registered users may post in this forum.

Click here to login