Welcome! Log In Create A New Profile


Cant set 1/8 stepping - DRV8825

Posted by welo78 
Cant set 1/8 stepping - DRV8825
October 12, 2018 01:46AM
Hi recently I bought a second Ramps 1.6 (ramps 1.4 with mosfets and stuff) to have a spare and oh boy did I bought it right in time. My last board (same as the new one) shorted out while trying to figure out the vref on DRV8825 drivers.

I changed the board, drivers (it fried two of my TMC2130 drivers), cables all just not the extruder motor. On this new board I cant get 1/8 stepping and idk why. I checked the board for solders and it looks OK. I removed the MS3 jumper, even tried different jumpers but it seems like I still get some incorrect stepping.

Previously, before shorting out the first board my settings were: 1/8 stepping, 1900 steps and it worked perfectly.

Now i get horrible under extrusion which seems to be the problem of wrongly used microsteps. I have set the stepping to 1/4 and 1900 steps and it still underextrudes by about 10-15%.

Can anybody tell me what the hell is going on ? Both of the boards are clones ...
Re: Cant set 1/8 stepping - DRV8825
October 12, 2018 05:04AM
Some of the cheap ramps boards have pcb tracks between the micro stepping jumpers, so they are always connected

remove the driver module and the jumper and test with a multi meter that there is no connection between the two jumper pins

PS Dont use metal screw drivers when adjusting vref, use a shaved tooth pick if you don't have plastic or ceramic screw drivers

Edited 2 time(s). Last edit at 10/12/2018 05:13AM by Dust.
Re: Cant set 1/8 stepping - DRV8825
October 13, 2018 02:05AM
I used to use a single LiPo battery to shortcut and melt away these damn bridges.
Sorry, only registered users may post in this forum.

Click here to login