Welcome! Log In Create A New Profile

Advanced

trouble with extruder stepper motor

Posted by BobWorkman 
trouble with extruder stepper motor
February 21, 2019 04:10PM
my setup:
mega2560 board (x2)
Ramps 1.4 (x2)
A4988 stepper drivers (2 full sets + spares)
Geared extruder with large gear removed for troubleshooting.
Z stepper motors disconnected from threaded rod for trouble shooting.

I use an LED stepper substitute driver tester from [reprap.org]
I have 4 built on pref board.

I also use a RepRap Easy Driver test board [reprap.org]

all stepper motors have been tested for functionally and all driver boards have been adjusted and tested using above equipment and a spare stepper motor.

I use Repetier on a PC in Manual control mode to control actions.

The problem:
All axis steppers function well.
My extruder runs fine in the feed direction but makes grinding noises and does not move in the retract direction.

Trouble shooting:
I have tested with 2 different mega2560 & Ramps hardware setups and both Marlin 1.1.9 and 1.1.4 with same results.

I have plugged in a different stepper motor, swapped one z axis stepper and extruder stepper,
problem remains with extruder driver.

Changed out A4988 and problem still there.

Just to avoid the "standard query" the system was fully powered down and disconnected from PC before any changes where made.

Logic says the problem must be in the Arduino or its software, the Ramps board, the Stepper drivers, wiring or the stepper motors.
I am at a loss as to why this is happening as I have changed everything.

I am wondering if there is some setting for the extruder that I have wrong.
As the configuration.h edits have been ported from 1.1.4 to 1.1.9 and 1.1.4 had worked previously I don't think that should be the case

any Ideas???
Re: trouble with extruder stepper motor
February 21, 2019 04:35PM
What do you have for the DEFAULT_MAX_FEEDRATE values


Electronics Technician / Computer Programmer
Re: trouble with extruder stepper motor
February 21, 2019 11:10PM
default_max_feedrate is (200, 200, 3, 25)


addendum to original post.
I flipped the connector for the stepper motor which reverses the direction of the stepper motor and the problem reversed as well. I.E works on retract growls on advance.
Re: trouble with extruder stepper motor
February 26, 2019 10:05AM
So I found the answer.

Since the only thing I had not changed out was the PC based software (Repetier) I fired up a copy of Ponterface
an of course everything worked right. Much confusion because I have been using Repetier for all my printing and have been very happy with it.
Based on Robert's question I started playing with feedrates and found that reducing the manual retract rate solved the problem.
I dug out my old computer, new computer had been working ok but I wondered about what settings had been, checking the settings showed
that indeed they were different... either an update or an error - human or machine- had altered the feed rate settings.
My stepper are actually slow so maybe default setting for newer steppers where to high.

Anyway everything is alright now.
Sorry, only registered users may post in this forum.

Click here to login