Welcome! Log In Create A New Profile


Weird problem with RAMPS 1.2 - SOLVED

Posted by oz 
Weird problem with RAMPS 1.2 - SOLVED
June 13, 2011 02:44AM
I have nearly completed my reprap mendel. Decided to use ramps electronic and buy one together with arduino mega 2560 and opto endstops 2.1 rev1 (it uses negative logic, 1= open 0= close). Now i have soldered (soldered it myself and tested it for shortcuts) electronic and testing functionality.
Only one FW which looks somewhat functional is "preconfigured" tonokip tesla or last kliment version. FiveD after downloadig just stuck all axis and do nothing.
As HW use samsung netbook, with ubuntu 11.4. I have compiled repsnapper on it. Configured FW and compiled it in arduino 2.2 sw. Comunication speed is set to 57600 (both repsnapper and FW).
Now problems:
Steppers move smothly 1/4 of power looks enough, more power leads only to higher noise level... (At last.)
System ignore endstops, when i try "homing", axis continues moving until crash... Tried un-inverting endstops and result is, axis stop moving to negative direction. I have read somewhere, that repsanppers "homing" do not work with endstop signal ok, so mayby it is not major problem.
Much worse is "power pulsing". When i move axis, and something prevent axis to move (crashes to one side etc. but it occurs sometimes without it), system starts periodically send power into stepper motors. (Frequence was diffrent on accelerated and nonacceleretad FW). Even when im able to move axis this "pulsing" continues and partially breaks movement of axis. Its like periodic jerking...
btw. I have connected only 3 pololus now, no extruder od thermistor connected.
Any help here?

Edited 1 time(s). Last edit at 06/30/2011 06:32AM by oz.
Re: Weird problem with RAMPS 1.2
June 13, 2011 03:19PM
I recommend you check out the advice given on this thread for the power pulsing issue.
What fixed it for me was to turn down the current by turning the tiny screw on the pololu counter-clockwise. Just a half-turn did it in my case.
Re: Weird problem with RAMPS 1.2
June 13, 2011 06:53PM
The Pololus will pulse when the current setting is really high, and they go into protection mode. Have a really close look at the potentiomenters on the drivers. You may need a magnifying glass, as they are really small. It looks like this sort of (+) and it has a flat side. Ideally, the flat should be between the 07:00 O'clock and 10:00 O'clock positions, unless you have some really powerful stepper motors that need more current.
Re: Weird problem with RAMPS 1.2
June 14, 2011 02:14AM
My setting is not high. (+- 1/2 of range). But ill try lower current and maybe use bigger heatsinks.

Second problem is ignoring of endstops. I have https://shop.grrf.de/opto-endstop-v21-rev1-3er-diykit-p-319.html?zenid=94419db6a29591617f0b0fc86239f734
Tried inverting optostops in FW, but repsnapper just ignore it...

Only one thing i have in sprinter firmware changed is configuration.h (pins.h looks ok)

const bool ENDSTOPS_INVERTING = false;
const bool ENDSTOPS_INVERTING = true;

Edited 2 time(s). Last edit at 06/14/2011 02:46AM by oz.
Re: Weird problem with RAMPS 1.2
June 14, 2011 10:31AM
Ok pulsing seems ok now (with potentiometer set on "9:00").
All 3 axis moving smothly.
Tough, homing do not work at all....
Using home button (or home all) just move axis like 1mm out of endstops (+ direction). Moving in "-" direction does notthing. Endstops looks ok, becouse if i insert something into them (0=close) i can move in negative direction without problem...

Should i set "const bool ENDSTOPS_INVERTING = false; "
But i know i have inverting endstops. LED is on if open, off if close...
Re: Weird problem with RAMPS 1.2
June 14, 2011 07:24PM
Yes, change inverting to false. LED should be On if Open.
Sorry, only registered users may post in this forum.

Click here to login