Welcome! Log In Create A New Profile


Semi-random build crashes

Posted by RyanB 
Semi-random build crashes
June 13, 2011 02:45PM
Problem: Almost all of my parts crash somewhere in the middle of the build. I say it's "semi-random" because I can never tell at what stage it will crash, but if I try the same part again, it usually does it at the exact same line of gcode.

My setup: Prusa Mendel, RAMPS 1.2, Mega 2560 clone, Sprinter firmware, ATX PS (I've tried a 4.5A & a 10A, both have same result), Repsnapper to control, Skeinforge and Repsnapper to generate gcode (same problem with both), Windows 7 Dell Precision laptop.

Symptoms: Just stops in the middle of a build. I check the Repnapper log and it seems to always be a regular G1 move that is the last command sent. Repsnapper acts like it is still printing and won't let you do any manual moves until you restart Repsnapper. I have a fan wired in parallel w/ the extruder to see when it's on, and if the extruder is on when it crashes, the heater stays on until you power the RAMPS off. My Pololus are all set to about 25%, and everything runs cool (while it runs).

Things I've tried: different PS; switching to fully shielded USB cable & re-routing; turning off fluorescent lamp on same circuit; generating new gcode w/slightly different settings; disabling power saving settings on host laptop. The repeated fails at the same line seem to indicate something other than electrical noise. Nothing seems to help. What else should I try?

Edited 1 time(s). Last edit at 06/13/2011 02:46PM by RyanB.
Re: Semi-random build crashes
June 13, 2011 06:48PM
Have a look in the device manager, in the USB Host controller in particular. Make sure power management is not turned on. In other words, DO NOT allow windows to manage power setting for this device.

There seem to be a few complaints relating to Dell. I wonder if it is just coincidence.
Sorry, only registered users may post in this forum.

Click here to login