TMC2209 fried - It was inserted correctly
April 29, 2020 09:52AM

I installed two tmc2208 for Z and extruder and two tmc2209s for X and Y axis yesterday in UART mode. I made sure the drivers (made by Bigtreetech) were inserted correctly, checked the DIR and EN pins and all. Infact, I quadruple checked.
Since my Arduino's onboard 5v regulator is fried, I use the USB's 5v to trigger a relay in my PSU (Not an ATX). Upon connecting the USB cable and then flipping the PSU switch, I heard a loud pop and the printer reset. The printer display was very dim and was not showing any characters, only backlit
Me still being in denial about the noise, thought maybe something else is wrong. Turned everything off, and tried to smell for smoke near the board and PSU. Nothing. I took the drivers out and inspected both the chips under my usb microscope. Aaaaand yep, both tmc2209 had a hole in their chip. tmc2208 are completely fine and working. I switched to my old tmc2100 on X and Y and I have no issues there.

Edit: I think I should also mention that I tried one tmc2208 in standalone mode on Z axis first to make sure everything was okay. When I turned the printer on with only a tmc2208, I noticed that the Z motors became active as soon as printer was on. I know this because I have a board cooling fan that only turns on when motors are on. This didn't happen with A4988 that was on Z before.

I cannot for the life of me figure out what went wrong and why these two fried. The only possible clue that I have found is this:
No idea if what was said there is true or not. I do know both tmc2208 and tmc2209s are 3-5v logic, according to Bigtreetech specs. If the github post is the reason, why didn't tmc2208 fry as well?

I want to order more tmc2209s but I don't want them to fry like this again, so could someone here help me figure out what went wrong please?

Edited 6 time(s). Last edit at 04/29/2020 10:41AM by White.Renard.
Sorry, only registered users may post in this forum.

Click here to login