Welcome! Log In Create A New Profile


Confusing Stepper Motor Behavior

Posted by ethanguidry 
Confusing Stepper Motor Behavior
February 09, 2021 01:32PM
I am trying to control stepper motors for a 3d printer with a RAMPS 1.4 board connected to an Arduino Mega 2560. I have uploaded Marlin firmware to the board and am currently using Pronterface to test the board's components. At first, the stepper motors would not move at all when commanded. They would just slightly twitch and them hum, but not rotate. Then, I checked the wiring connections and ensured they were correct, but the problem persisted. Then, I measured the voltage supplied by the stepper drivers, which was 0.79 Volts. Based on my stepper motors, Nema 17, the maximum voltage I calculated was 1.36 Volts. After adjusting the potentiometer screw the maximum amount, the voltage supplied is 1.19 Volts. Now, the motors WILL rotate when given the 0.1 and 1 command in Pronterface, but return to the twitch and whine behavior when given the 10 or 100 command. What is the cause of this?
Re: Confusing Stepper Motor Behavior
February 10, 2021 01:45AM
What speed, steps/mm and microstepping are you using? Maybe you are trying to run the motors too fast. Have you already tried with a much lower speed?
Re: Confusing Stepper Motor Behavior
February 12, 2021 10:31AM
I've attached a picture of my Marlin configuration.h settings. I'll admit I'm a rookie with all this stuff, so my understanding of these things is pretty limited. Thank you!
open | download - Capture.JPG (111.7 KB)
Re: Confusing Stepper Motor Behavior
March 03, 2021 07:36AM
Have you fitted the 3 micro stepping links under each stepper driver on the ramps board
Re: Confusing Stepper Motor Behavior
March 03, 2021 07:50AM
what stepper motors, as there are some that are not compatible

needs to be Bipolar or correctly wired as bipolar Unipolar
Not compatible with 5 wire stepper motors

see [learn.adafruit.com] wiring for details.

Also you say wiring is correct, but many miss read the diagram

RAMPS stepper motor plugs have 4 pins. first two pins 1 and 2 are the first stepper coil, last two pins 3 and 4 are the second stepper coil.
Re: Confusing Stepper Motor Behavior
March 04, 2021 02:29AM
I still suspect that the problem may have to do with the high step rates, which from your screenshot account to 20k-24k steps/sec at max feed rates, whereas the RepRap Wiki gives a maximum of about 10k steps/sec for a RAMPS/Mega/Marlin setup. Have you tried lowering the max speeds (feed rates)?
Sorry, only registered users may post in this forum.

Click here to login