Welcome! Log In Create A New Profile


RAMPS 1.3 Extruder Misbehaving

Posted by nickp 
RAMPS 1.3 Extruder Misbehaving
July 21, 2011 11:03PM
Hi all,

I'm having a problem with my RAMPS 1.3 electronics and the extruder motor. Whenever I tell it to move, it jitters one way for about half a second and then half a second later it begins to jitter the other way. I've tried plugging the Pololu board into another socket, and the behavior doesn't repeat even with the same board and motor. It occurs on either extruder socket (changed in firmware). I'm using Sprinter firmware with the pins configured based on the board schematic. Does anyone have any tips?

Re: RAMPS 1.3 Extruder Misbehaving
August 01, 2011 01:45AM
I had a similar problem with my Z axis, until I reduced the Z feed rate limit.

Sprinter's defaults work well for a finely tuned printer, but not so well for one that's still being tuned.
Re: RAMPS 1.3 Extruder Misbehaving
August 03, 2011 12:17PM
If you are using RepSnapper try reducing extruder speed in the control panel the default in RepSnapper is too high for the default e steps/mm in Sprinter.
Re: RAMPS 1.3 Extruder Misbehaving
August 03, 2011 12:20PM
I figured it out; I was using a stepper motor with a hugely different mix of voltage/current requirements. I'd recommend steering clear of using SparkFun stepper motors to drive your extruder =) Buying another, higher torque motor solved the problem for me.
Sorry, only registered users may post in this forum.

Click here to login