Re: Erfahrung mit ShaperCube
07. February 2011 16:18
"Scotch 2090" heist das spinning smiley sticking its tongue out


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Erfahrung mit ShaperCube
07. February 2011 16:24
Nicht MEINE! tongue sticking out smiley


Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Erfahrung mit ShaperCube
07. February 2011 16:27
Blaues Malerklebeband... Egal welches spinning smiley sticking its tongue out Also feine Krepp mit guten Klebeeigenschaften.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Erfahrung mit ShaperCube
07. February 2011 16:35
Abend!

Ich verwende ABS und habe eine Plexiglas Platte. Ich dachte es würde auch ohne Heizplatte gehen. Aber zum Glück habe ich mir das schon besorgt aber noch nicht eingebaut:



Und Ihr meint ohne Heizplatte geht es nicht???
Re: Erfahrung mit ShaperCube
07. February 2011 17:05
ABS geht nicht ohne... machst du ein 0,5mm Stahlblech auf den Tisch, was du fest klemmst mit Briefklemmern, da klebst du Kapton drauf, und darauf druckst du dann... Klar, mit Heizung an (110°). Wenn du fertig bist, nimmst du das Blech dann runter, biegst das ein bisschen, und die Teile springen ab. Dann kannst du auch auf das Raft verzichten.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Erfahrung mit ShaperCube
07. February 2011 17:18
Jau, mach ich gleich morgen. Muss mir nur noch ein neues 7A Netzteil von Conrad besorgen...

Gibt es eigendlich hier im Forum ein Tutorium was man alles mit Rensnapper einstellen kann und muss?
Momentan tappe ich da noch im dunkeln...

Schönen Abend und ich schreib dann mal rein wie es dann läuft...

Grüsse
Menekee
Re: Erfahrung mit ShaperCube
07. February 2011 17:28
Die meisten verwenden Skeinforge und einen der 3 Hosts..

Dann haben die Hosts aber nur noch die Funktion, das sie den von Skeinforge erstellten G-Code an die Maschine weiter leiten.

ReplikatorG
Repsnapper
Adrian´s Host (standart beim Mendel)

Alle 3 haben so ihre Tücken smiling smiley Nur das im ReplikatorG Skeinforge schon eingebaut ist, und der eine eigene Firmware verwendet.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Erfahrung mit ShaperCube
07. February 2011 17:39
Hallo Wolfgang,

gut, da muss ich mich eben einarbeiten und Stück für Stück herusfinden was ich wo einstellen muss.
Dann lade ich mir mal Skeinforge herunter, bin mal gespannt was der so kann.

Lieben Dank!
Menekee
Re: Erfahrung mit ShaperCube
09. February 2011 05:15
Hallo Leute,

ich hab da mal ne Frage... Ihr habt sicher schon eine entsprechende Lernkurve durchgemacht und könnt mir vielleicht helfen:

Das Drucken gelingt mir nicht so ganz. Die Teile werden immer schief. Die ersten 5-6 Layer waren gut, dann auf einmal eine Verschiebung
bzw. Versatz um einige Millimeter (siehe Bild):



Für den Beginn nutzte ich nur Redsnapper.

Gängigkeit der Achsen?
Motorpoti zu hoch / zu niedrig?
Geschwindigkeit?
Zahnrimen?
Elektronik?
Software?

Hab alles noch mal geschmiert und mir scheinen die Achsen gut gängig zu sein

Die nächsten Teile sind noch schlimmer geworden - kein Layer liegt mehr auf dem anderen... :-(

Woran kann das liegen?

Grüße
Menekee
VDX
Re: Erfahrung mit ShaperCube
09. February 2011 05:27
... entweder dreht das Ritzel durch, oder die Motoren verlieren massiv Schritte - evtl. zu wenig Strom?


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: Erfahrung mit ShaperCube
09. February 2011 05:35
Hmm, wenn ich die x Achse mit 1mm schritten ansteuere dann merke ich das er nicht jedes mal um diesen Betrag verfährt.
Sie scheint etwas zu blockieren. Dann wär es sicher klar das die Layern nicht übereinander liegen, nehme ich an?

Die Y Achse geht gut.
Re: Erfahrung mit ShaperCube
09. February 2011 05:49
Danke Viktor,

es war der Poti von dem Motortreiber - der war zu hoch!
Re: Erfahrung mit ShaperCube
11. February 2011 03:22
Hallo Leute,

mitlerweile funktionier der Cube ganz anständig. Für den Anfang habe ich schon einige gute Stücke produziert.
Jetzt wollte ich mal Skeinforge ausprobieren, aber anscheinend mache ich was ganz falsch!

Ein Teil, was ich schon mit Repsnapper erfolgreich gedruckt habe wollte ich mit Skeinforge mal probieren.
Skeinforge generiert mir die G Dataeien, aber Repsnapper spinnt dann irgendwie.

Die Achsen fuhren nur sehr sehr langsam und die Temp stieg über 300°C. Ich dachte schon ich hätte meine Düse geschrottet.

Was mache ich generell falsch?

Grüße
Menekee
Re: Erfahrung mit ShaperCube
11. February 2011 05:12
Guck mal besser da rein wo wir uns die ganze Zeit über die Einstellungen für Skeinforge unterhalten.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Erfahrung mit ShaperCube
18. February 2011 18:19
Abend!

Leider ist hat sich ein Motortreiber verabschiedet beim Versuch mein Rampsschield zu reparieren.

Vorgeschsichte:

Auf einmal hat die Düse nicht mehr geheizt. Ich dachte das der Heizdraht kaputt sei. Da habe ich mal Ausgang D8 geprüft und siehe da...keine Spannung. Dann in der Firmware von D8 auf D9 umgestellt und leider da auch nichts mit Spannung.

Vermutlich einer der Mosfets defekt. Da habe ich versucht diese um zu löten und habe den "verdächtigen" gegen vermutlich noch "guten" ausgetauscht. Den vermeindlich "guten" habe ich dann erst gar nicht mehr gelötet und das hat mir, so vermute ich, mir einen Stepper zerschossen.

Gut, morgen bekomme ich ein neues ramps shield und ersatz Stepper - aaaber nicht die A4983 sondern A3979 Stepper.

Laut [reprapshop.com] sind diese kompatibel, können jedoch keine 1/8 Stufung.
Beim ersten Zusammenbau habe ich aber wie laut Anleitung alle A4983 Stepper auf 1/8 eingestellt:

Meine Frage:

Muss ich jetzt alle Jumper einsetzten umm eine 1/16 Auflösung zu machen und muss ich dann das in der Firmware berücksichtigen?

Alternativ könnte ich die noch restlichen drei A4983 an x,y und z reinstecken und nur den Extruder mit dem neuen A3979 bestücken.
Aber auch hier die gleiche Frage mit der Jumper Belegung...

Man o Man...

Grüße
Menekee
Re: Erfahrung mit ShaperCube
18. February 2011 18:39
ja, mußt du beides machen, alle jumper rein, und auch in der Firmware die Schritte anpassen.. Obwohl, wie wird der andere denn beschaltet ?

Sind die denn Pinkompatibel ?

A4983
MS1 Ms2 MS3
Low Low Low Full step
High Low Low Half step
Low High Low Quarter step
High High Low Eighth step
High High High Sixteenth step


A3979
MS1 MS2 Microstep Resolution Excitation Mode
L L Full Step 2 Phase
H L Half Step 1-2 Phase
L H Quarter Step W1-2 Phase
H H Sixteenth Step 4W1-2 Phase


Da würde ich aber mal gucken ob die Pinkompatibel sind... was haben die mit dem MS3 denn gemacht ?


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Erfahrung mit ShaperCube
18. February 2011 19:11
Abend Wolfgang!

Also die von Shapercube habe mir die A3979 als kompatibles ersatz angeboten da die A4983 zur zeit bei denen ausverkauft sind.
Sie sollen auf jeden fall so rein passen.

Hier kann man sehen das nur 1/8 Schritte Vorgesehen sind:
[wiki.shapercube.com]

Vielleicht gibt es gute Gründe dafür. Auf Nachfrage reagieren die nicht immer und so muss ich sehen wie ich zurecht komme.
Ich stelle mir das so vor das wenn 1/16 Schritte eingestellt sind, das - ohne die Firmware zu ändern - im endeffekt nur die hälfte der Strecke zurückgelegt werden würde.

Hast du einen Tip wo ich das in der Firmware ändern muss?

Wenn ich die noch drei heilen A4983 für x,y unz z nehme und nur den Extruder mit A3979 bestücke dann müsste ich ja nur den Extruder Wert ändern... so denke ich mir das mal...

Grüße
Menekee
Re: Erfahrung mit ShaperCube
18. February 2011 19:18
Gugst du auch hier :-)

[twitter.com]

Und hier ein Ausschnitt aus ... [host.hackmelbourne.org]

" Pololu make a carrier board for the A4983 that has become increasingly popular. As an alternative, someone has produced an open source design for a carrier for the A3979 that uses the same pinout config as the A4983 carrier from Pololu."

2-mal bearbeitet. Zuletzt am 18.02.11 19:30.
Re: Erfahrung mit ShaperCube
18. February 2011 19:45
... ich versuche mal selber es heraus zu finden:

Der Code unten stammt aus der Firmware... der Wert 1600 ist eingestellt und kann optional auf 3200 geändert werden - also eine verdoppelung.
Kann es sein das wenn ich den A3979 nehme der nur 1/16 kann, das ich die Werte auf 3200 ändern muss??


// define the parameters of our machine.
#define X_STEPS_PER_MM 40 // 80
#define X_STEPS_PER_INCH (X_STEPS_PER_MM*INCHES_TO_MM)
#define X_MOTOR_STEPS 1600 // 3200
#define INVERT_X_DIR 0

#define Y_STEPS_PER_MM 40 // 80
#define Y_STEPS_PER_INCH (Y_STEPS_PER_MM*INCHES_TO_MM)
#define Y_MOTOR_STEPS 1600 // 3200
#define INVERT_Y_DIR 0

#define Z_STEPS_PER_MM 1280
#define Z_STEPS_PER_INCH (Z_STEPS_PER_MM*INCHES_TO_MM)
#define Z_MOTOR_STEPS 1600
#define INVERT_Z_DIR 0
Re: Erfahrung mit ShaperCube
18. February 2011 20:34
jup... das sind die Schritte pro Umdrehung. Normal machen die Motoren 200 (full)Steps/U . jeder Vollschritt wird dann aber nochmal in 8 oder 16 Teile unterteilt. Also macht er dem entsprechend mehr Schritte.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Erfahrung mit ShaperCube
19. February 2011 10:29
Alles gelötet, eingebaut - läuft!

Ein Treiber A3979 war leider kaputt und habe deshalb den Extruder mit einem A4983 bestückt.
Ich finde mit der 1/16 Stunfung läuft es viel besser und auch leiser...

Weiss nicht warum die standartmäßig eine 1/8 Stufung vorsehen...

Grüße und Danke
menekee
Re: Erfahrung mit ShaperCube
20. February 2011 13:45
Pechvogel?

Heute hat meine Düse den Geist aufgegeben. Also Zement weg, neues Heizdraht und Thermistor rein - alles wieder ok.
Nach einigen Stunden springt plötzlich die Tempanzeige auf 357°c und dann immer wieder auf 155°c.

Also alles aus und kalt werden lassen und die Temp.Anzeige immer auf 155°c trotz Raumtemperatur. Hatte den Thermistor in verdacht und einen ganz neuen an den Rams T0 angeschlossen...immer nur 155°c!

Sonst fuktionieren alle Achsen und Motoren und die Düse (sie heizt) wie gewohnt.

Könntne ein Bauelement defekt sein? Vielleicht die Kondensatoren die dahinter liegen?
Re: Erfahrung mit ShaperCube
20. February 2011 15:55
Muss mich korrigieren.

Sie Zeigt als Mindest Temp 155 an geht nicht mehr drunter. Drucken kann ich trotzdem da oberhalb z.b 240 °c geht.
Seltsam, was mag nur sein?
Re: Erfahrung mit ShaperCube
20. February 2011 17:44
Ich weis jetzt nicht mehr genau, werden die termistoren mit steigender Temperatur hochohmig oder niederohmig...

Ich würde sagen du hast dir eine Hochohmige Brücke in den Temistor gebastelt. Irgend sowas.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Erfahrung mit ShaperCube
22. February 2011 01:18
Hier die Auflösung:

bei der Reparatur der Heizdüse muss der Heizdraht und Thermistor einen Kurzschluss gehabt haben.
Das hat die Analogeingänge des Boardes beschädigt...

Grüße
Re: Erfahrung mit ShaperCube
22. February 2011 01:58
So was hatte ich auch mal, da ging das Board gar nicht mehr. Ich hab die Firmware neu aufgespielt, und Glück gehabt.
Einen Versuch ist es Wert...


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Erfahrung mit ShaperCube
22. February 2011 03:23
Hallo Wolfgang,

eben versucht, leider immer noch der selbe Fehler. Ist aber nicht weiter tragisch da ab 155°c alles funktioniert.

Habe mir jetzt zwei Boards, 2 Shields und 8 Treiber bestellt. Will mir so immer Ersatzelektronik bereit halten. Ich finde es einfach nervig wenn ein Komponent ausfällt und ich Tage oder länger auf ein ersatzteil warten muss.

Habe ich bereits alles zwei mal, dann kann ich bei einem Störfall einfach diese ersätzen und die Beschaffung der Ersatzteile in aller Ruhe erledigen.

Grüße
Re: Erfahrung mit ShaperCube
22. February 2011 03:49
schmeiß das Board nicht weg, den Arduino kann man ja austauschen. Da ist bestimmt der ein oder andere der dir das abnehmen würde. Ich kenne jemand der sucht ein Extruderboard...


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Erfahrung mit ShaperCube
22. February 2011 03:49
Quote

Habe mir jetzt zwei Boards, 2 Shields und 8 Treiber bestellt.

Gleich doppelte Ersatzteile? Na, das zeugt ja von grandiosem Vertrauen in die eingesetzte Elektronik. winking smiley


Generation 7 Electronics Teacup Firmware RepRap DIY
     
VDX
Re: Erfahrung mit ShaperCube
22. February 2011 04:04
... oder es zeugt von weiser Voraussicht, falls er für sich oder einen Freund/Bekannten noch so ein Teil aufbauen möchte winking smiley


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen