FIS
Stecken geblieben
11. November 2013 12:14
Hallo zusammen,


das täte mich mal interessieren,

hi und da bleibt mein Mendel hängen, der große macht das nicht,..

wieso bleibt der Mendel hängen..

Mendelmax 1.5 meine Kreation
Raspi mit OctoPrint auf last version (2013 Oktober)

teile gehen, teile bleiben hängen,

beim Printen bleiben Teile hi und da hängen,
zeichnen tue ich die Teile selber mit Rhino oder Cheetah aufn Mac
dann Slicn mit dem neuesten Cura

und per WLAN rüber zum Mendel.

einige Sachen lassen sich Drucken, ohne irgendwelchen Mux,
andere dagegen bleibt der Extruder oder Hottend einfach stehen..

bei dem OctoPrint hab ich gesehen, dass da einfach Disconnect ist,

neustarten, Stromweg, Stromein, dann connect mit dem Otto
Ich habe Probiert einfach wiedermal das gleiche andersrum zu Positionieren,
aber irgendwie mag er nicht alles



wieso macht er das ?

SG
Re: Stecken geblieben
11. November 2013 12:53
"bleibt der Extruder oder Hottend einfach stehen.." Welcher Extruder - das scheint eher das Problem als die Software zu sein?
FIS
Re: Stecken geblieben
11. November 2013 13:00
Extruder ist eine art direkt, wie bei dem makerbot,

Hottend ist das E3D

jaja, aber wieso , irgendwie stockt er dann, dann macht er noch so ein wackler, und aufeinmal ist komplett alles still,
aber das Hottend ist heiß,
und kühlt sich genau da ab wo es hängen bleibt...

aber nicht bei allen Modellen,

nur bei einigen wenigen...

SG
Re: Stecken geblieben
11. November 2013 13:59
Also so was -> [e3d-online.com]

Ich schätze mal - du sagst nichts darüber - du verwendest PLA und das Problem ist bei "zerklüftete" Bauteilen mit vielen retracts.
Welche Materialstärke - > 1.75mm PLA ist da empfindlicher als 3mm PLA. Und es kommt auf den Hersteller des Filaments an.
FIS
Re: Stecken geblieben
11. November 2013 14:24
Ja ich nutze den e3d

mit dem auch 1,75 Material,

Nema Motoren 1,8


Ich habe den E3D mit 1,75 direkt


wieso baut der Mennel dann die anderen STL - gcode Files, und andere wieder bleibt er einfach stehen..

das material lässt sich schön durchschieben,

SG
Re: Stecken geblieben
11. November 2013 14:52
"das Problem ist bei "zerklüftete" Bauteilen mit vielen retracts." -> dazu hast du nichts gesagt
1.75mm "Voll Metall Extruder" ist sehr kritisch. Es kann gut gehen, oft aber nicht. Hängt vom Druckteil und vom Filament Hersteller ab
FIS
Re: Stecken geblieben
11. November 2013 16:32
aha, und darum bleibt der Drucker einfach stehen?
FIS
Re: Stecken geblieben
11. November 2013 16:33
was ist denn besser,

so ein e3d oder so ein Buzzscnozzle?

SG
Re: Stecken geblieben
12. November 2013 01:56
Was bleibt denn stehen?

Kommt aus dem Hotend kein Material mehr heraus (Extruder blockiert, etc.) oder
bewegen sich die Achsen nicht mehr (der gesamte Drucker bleibt stehen)?


Gruß
Boris
--
DIY Mendel90
Gen7 1.4.1 mit Repetier Firmware 0.91 + Repetier Host
Gen7 Extension Board mit LCD, SD-Card, Bluetooth und FAN-Control
FIS
Re: Stecken geblieben
12. November 2013 07:02
der gesamte Drucker bleibt stehen

ich habe hier mal den Gcode beobachtet,

KOMISCH,
immer wenn die Fehler kommen, bleibt auf einmal der Printer stehen,

dann steht beim OctoPrint aufeinmal Connect,
als würde der Gcode das Ausschalten des Octo-App bewirken, oder so eine art NOT aus..

was kann das sein,

hier unten der GCODE:

SG


Send: N903 G1 X80.83 Y102.07 E683.75292*89
Recv: ok
Send: N904 G1 X80.82 Y102.14 E683.75607*85
Recv: Error:Line Number is not Last Line Number+1, Last Line:902
Recv: Resend:903
Send: N903 G1 X80.83 Y102.07 E683.75292*89
Recv: ok
Send: N904 G1 X80.82 Y102.14 E683.75607*85
Recv: Error:Line Number is not Last Line Number+1, Last Line:902
Recv: Resend:903
Send: N903 G1 X80.83 Y102.07 E683.75292*89
Recv: ok
Send: N904 G1 X80.82 Y102.14 E683.75607*85
Recv: Error:Line Number is not Last Line Number+1, Last Line:902
Recv: Resend:903
Send: N903 G1 X80.83 Y102.07 E683.75292*89
Recv: ok
Send: N904 G1 X80.82 Y102.14 E683.75607*85
Recv: Error:Line Number is not Last Line Number+1, Last Line:902
Recv: Resend:903
Send: N903 G1 X80.83 Y102.07 E683.75292*89
Recv: ok
Send: N904 G1 X80.82 Y102.14 E683.75607*85
Recv: Error:Line Number is not Last Line Number+1, Last Line:902
Recv: Resend:903
Send: N903 G1 X80.83 Y102.07 E683.75292*89
Recv: ok
Send: N904 G1 X80.82 Y102.14 E683.75607*85
Recv: Error:Line Number is not Last Line Number+1, Last Line:902
Recv: Resend:903
Send: N903 G1 X80.83 Y102.07 E683.75292*89
Recv: ok
Send: N904 G1 X80.82 Y102.14 E683.75607*85
Recv: Error:Line Number is not Last Line Number+1, Last Line:902
Recv: Resend:903
Send: N903 G1 X80.83 Y102.07 E683.75292*89
Recv: ok
Send: N904 G1 X80.82 Y102.14 E683.75607*85
Recv: Error:Line Number is not Last Line Number+1, Last Line:902
Recv: Resend:903
Send: N903 G1 X80.83 Y102.07 E683.75292*89
Recv: ok
Send: N904 G1 X80.82 Y102.14 E683.75607*85
Recv: Error:Line Number is not Last Line Number+1, Last Line:902
Recv: Resend:903
Recv: ok
Send: N905 G1 X80.76 Y102.82 E683.79031*95
Recv: Error:Line Number is not Last Line Number+1, Last Line:902
Recv: Resend:903
Send: N903 G1 X80.83 Y102.07 E683.75292*89
Recv: ok
Send: N904 G1 X80.82 Y102.14 E683.75607*85
Recv: Error:Line Number is not Last Line Number+1, Last Line:902
Changing monitoring state from 'Printing' to 'Error: Line Number is not L...'
Recv: Resend:903
Recv: ok
Recv: Error:Line Number is not Last Line Nu
Recv: Error:Line Number is not Last Line Number+1, Last Line:904
Recv: Resend:905
Recv: ok
Recv: Error:Line Number is not Last Line Number+1, Last Line:904
Recv: Resend:905
Recv: ok
Recv: Error:Line Number is not Last Line Number+1, Last Line:904
Recv: Resend:905
Recv: ok
Recv: Error:Line Number is not Last Line Number+1, Last Line:904
Recv: Resend:905
Recv: ok
Recv: ok
Recv: Error:Line Number is not Last Line Number+1, Last Line:905
Recv: Resend:906
Recv: ok
Recv: Error:Line Number is not Last Line Number+1, Last Line:905
Recv: Resend:906
Recv: ok

Autoscroll
Re: Stecken geblieben
12. November 2013 08:01
Also KOMISCH finde ich das nicht. Ist doch eindeutig ein Fehler in der Kommunikation.
Laut dem LOG ist die Zeile 904 nicht angekommen und der Drucker wartet auf diese Zeile

Ich kenne Octoprint leider nicht, aber da wird wohl eher der Fehler liegen.


Gruß
Boris
--
DIY Mendel90
Gen7 1.4.1 mit Repetier Firmware 0.91 + Repetier Host
Gen7 Extension Board mit LCD, SD-Card, Bluetooth und FAN-Control
Re: Stecken geblieben
12. November 2013 09:33
Das ist ein immer wieder bei OctoPrint auftretender Fehler. Versuch mal folgendes:
Settings -> Features -> Swallow the first "ok" ...
Ansonsten hier mal in Ruhe alles lesen ob's noch weitere Tipps gibt. Hab's nur mal eben überflogen.

Zuvor ggf. noch auf die neueste Version updaten. winking smiley


Grüße, Franz


MendelMax 1.5
3mm PLA | 0,35mm Nozzle | Ramps 1.4
Repetier-Firmware | Repetier-Host
FIS
Re: Stecken geblieben
12. November 2013 10:26
ah, DANKE,

ich hab eine zweite SD karte gemacht und die jetzt in den Raspi gesteckt,

es scheint mal zu funktionieren mit dem Swallow

vielen DANK

lg
FIS
Re: Stecken geblieben
20. November 2013 03:43
Hallo,

der bleibt hi und da wieder stecken, zum Glück aber mache ich kleine Teile,

d ist das nicht relevant...
blöd wird's nur wenn ich größere Teile mache


Marlin 1.00
Octo 7.5.0
Sanguinolu 1.3b oder a

MendelMax 1,5 modi

E3D Hotend mit einem Direkt Extruder - wie Makerbot


was könnte ich noch Probieren

er schaltet den Otto einfach auf AUS,
und hört dann auf. ist doch klar...

aber wieso schaltet er den Octo Print Vorgang einfach aus?

beim reconnect muss ich wieder von vorne anfangen

blöder Fehler..

hat jemand eine Idee?


SG
Re: Stecken geblieben
20. November 2013 12:02
Fehler doch nicht behoben? Ist's jetzt ein neuer oder sieht dein Log immer noch so aus wie letztes mal? kannst ihn ja hier nochmal posten.

Wenn alles nix hilft am besten foosel, die Programmiererin von Octoprint, befragen. Wie du das so machst, dass sie dir helfen kann findest du hier winking smiley


Grüße, Franz


MendelMax 1.5
3mm PLA | 0,35mm Nozzle | Ramps 1.4
Repetier-Firmware | Repetier-Host
Re: Stecken geblieben
23. November 2013 15:34
Hallo FIS,

meine Antwort wird wahrscheinlich nur begrenzt helfen.
Ich nutze Cura. Das Bediehnfenster sieht verdammt ähnlich aus wie bei Octoprint.
Ähnlichkeiten vorhanden ?
Cura druckt aber bestimmte teile auch nicht mit genau den selben Erscheinungen.
Wenn ich den G-Code exportiere und mit Repetier drucke läuft alles wunderbar -- Warum ???

Uwe94

Drucker / Fräse Eigenbau | Arduino + Eigenbau Stepper mit Ramps (angelehnt) | Marlin
| 1,75 mm ABS/PLA |0,5mm Nozzle
Re: Stecken geblieben
23. November 2013 20:00
Ähnlichkeiten beim Bedienfenster von Cura und Octoprint - vielleicht deshalb:

Quote
from Octoprint Website:
OctoPrint started out as a fork of Cura for adding a web interface to its printing functionality and was originally named "Printer WebUI". It still uses large parts of Cura's communication code for talking to the printer, but has been reorganized to only include those parts of Cura necessary for its targeted use case.
winking smiley
FIS
Re: Stecken geblieben
30. November 2013 19:10
hmm,

ich hatte das gleiche Problem mit manchen teilen,
aber komisch an der ganzen Sache ist,

seit ich das 7.5.0 Octoprint nutze, eben das letze auf der webweite aber noch ONE dem Cura Plugin,

ist da so ein Punkt wie oben beschrieben!

Swallow the First "OK" after...

wenn ich das einfach aus und einschalte, und mit demselben Stück einfach neu beginne, dann funktioniert das aufeinmal
ohne jeglichen stopfehler
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen