Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
06. June 2016 01:29
Hallo,
ich bin gerade bei der Inbetribnahme meines Sparkcube XL mit dem original Setup. Ich habe 3 Probleme, bei denen ich nicht weiter komme und etwas Hilfe benötige .

1.
Der mechanishe Aufbau ist fast komblett abgeschlossen bis auf die Druckblatte. Die X- und Y-Achse lassen sich schon verfahren und die Endstops (Hall Effekt) funktionieren auch. Hinten rechts werden die Endstops richtig angefahren.
Wenn ich aber auf „Home Z“ drücke, bewegt sich der Drucktisch nach oben. Also entfernt er sich vom z-max-endstop der ja unten montiert ist. Wo dran kann das liegen? Ich habe die Firmware aus der Dropbox von sparklab auf den Due geladen.

2. Wenn ich im Repetier Host auf Verbinden drücke, bekomme ich die Meldung „no start signal detected – forcing start“. Den Port habe ich so eingestellt wie in der Arduino Software. Die Baudrate steht auf 115200.

3. Wenn ich über das Druckermenü den Extruder aufheizen möchte, fangen die Lüfter an zu laufen aber der Extruder bleibt kalt. Am Ausgang vom RADDS Board liegt auch keine Spannung an. Dort müsste doch auch eine LED leuchten oder? So ist es auf jeden fall bei den Lüftern.

Ich hoffe mir kann hier jemand weiter helfen. Ich stehe gerade etwas auf dem Schlauch. smiling smiley

Viele Grüße
Tobias
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
06. June 2016 03:18
Zu 1. Wahrscheinlich hast Du die Motoren verpolt. Die Richtung für das Homen kannst Du aber auch in der Software ändern.
Meiner fährt z.B. Gewollt beim Homen nach oben, da ich das Druckbett immer gegen die Düse (Justage mit 10Gang-Poti) fahre.
Mich hat das ewige rumgefahre generft und zudem hab ich dann nicht die Toleranz der Spindel zu beachten

Zu3. Das Hotend benötigt einen Sensor. Ist der angeschlossen und zeigt die Temperatur?

Gruß
Andreas


Einen Sparkcube 1.1XL für größere Objekte, einen Trinus3D im Gehäuse und einen Tantillus R im Bau und einen Qidi Tech Q1 Pro im Zulauf.
Sparkcube: Komplett auf 24V - DDP 8mm + 1,5mm Carbonplatte - Octopus max EZ - EZ2209 - Nema 17/1,7A 0,9 Grad - BL Touch - Filamentsensor - Titan Booster Hotend - Sparklab Extruder - Klipper/Mainsail - HDMI 7 V1.2 Touchscreen - Simplify3D
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
06. June 2016 03:39
Hallo Andreas,

zu 1. Das umpolen der Motoren hab ich mir auch schon gedacht. Was mich nur wundert, dass es bei der X- und Y-Achse richtig ist. Alle Motoren sind vom gleichen Hersteller, daher bin ich davon ausgegangen, dass es in der Software richtig sein muss. Die Farben der Motoren sind alle gleich verdrahtet. Hab ich schon mehrfach geprüft. Ich werde es mal testen und in der Software umstellen. Wenn ich die Motoren umpolen möchte dann muss ich im Stecker die beiden A und die beiden B vertauschen oder? einfach den Stecker drehen würde nichts bringen oder liege ich da falsch?

zu 3. Der Sensor ist angeschlossen und zeigt im Display ungefähr Raumtemperatur an und reagiert auch, wenn ich mit der Hand dran bin. Verpolen kann man da nichts oder?

1-mal bearbeitet. Zuletzt am 06.06.16 14:30.
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
06. June 2016 11:06
Stecker drehen bringt nix, denn du müsstest zur Richtungsänderung eine Spule drehen. Wenn ich mich recht erinnere ist schwarz/grün und rot/blau je eine Spule.

Nein, verpolen kann man nix. Du hast aber 3 Anschlussmöglichkeiten zum Test. Mas machen die anderen beiden Ausgänge?

Gruß
Andreas

2-mal bearbeitet. Zuletzt am 08.06.16 00:55.


Einen Sparkcube 1.1XL für größere Objekte, einen Trinus3D im Gehäuse und einen Tantillus R im Bau und einen Qidi Tech Q1 Pro im Zulauf.
Sparkcube: Komplett auf 24V - DDP 8mm + 1,5mm Carbonplatte - Octopus max EZ - EZ2209 - Nema 17/1,7A 0,9 Grad - BL Touch - Filamentsensor - Titan Booster Hotend - Sparklab Extruder - Klipper/Mainsail - HDMI 7 V1.2 Touchscreen - Simplify3D
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
06. June 2016 14:31
Problem 1 gelöst smiling smiley . Ich habe in der Software INVERT_Z_DIR auf 1 gesetzt. Jetzt fährt er den max_endstop richtig an und oben ist Null.

zu3: Das Hotend bleibt an allen drei Anschlussmöglichkeiten kalt sad smiley

zu2: Hat da noch jemand eine Idee?
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
06. June 2016 14:41
zu3: Wenn ich direkt 12V auf das Hotend gebe wird es warm. Also ist da ein Fehler auszuschließen.

1-mal bearbeitet. Zuletzt am 06.06.16 14:42.
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
06. June 2016 15:28
Ich tippe auf ein Konfigurationsproblem. Schau mal, ob die Zuweisung passt. 3 defekte FETs ist eher unwahrscheinlich.

Gruß
Andreas


Einen Sparkcube 1.1XL für größere Objekte, einen Trinus3D im Gehäuse und einen Tantillus R im Bau und einen Qidi Tech Q1 Pro im Zulauf.
Sparkcube: Komplett auf 24V - DDP 8mm + 1,5mm Carbonplatte - Octopus max EZ - EZ2209 - Nema 17/1,7A 0,9 Grad - BL Touch - Filamentsensor - Titan Booster Hotend - Sparklab Extruder - Klipper/Mainsail - HDMI 7 V1.2 Touchscreen - Simplify3D
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
06. June 2016 19:20
Quote
Boui3D
Stecker drehen bringt nix, denn du müsstest zur Richtungsänderung eine Spule drehen. Wenn ich mich recht erinnere ist schwarz/grün und rot/blau je eine Spule.

Doch!
Das hat den gleichen Effekt wie die Invertierung in der Firmware.

KaptinT:
Du schreibst, dass das Bett noch nicht angeschlossen ist. Aber wahrscheinlich stehts in der Firmware drin. Also musst du zumindest den Bett-Thermistor anschließen. Sonst erkennt die FW einen Fehler und der Extruder heizt auch nicht auf.

Gruß
Stefan
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 00:53
Guten Morgen,

ich habe gestern Abend noch etwas weiter gebastelt und neue Erkenntnise gewonnen. Ich habe provisorisch das Heizbett angeschlossen. Beide Thermistoren zeigen eine Temperatur an und reagieren, wenn ich sie mit der Hand erwärme.
Dann habe ich versucht das Bett mal auf 30°C aufzuheizen aber nichts passierte. Die LED am SSR blieb auch aus, aber auf dem RADDS Board leuchtete am Anschluss für das 2. Hotend eine LED. Also habe ich testweise das Heizbett auf den Ausgang gelegt und siehe da, mein Heizbett wurde auf 30°C aufgeheizt und die Temperatur gehalten.

So wie ich das versteh, ist irgendwas mit der Pinbelegung durcheinander. Kann das sein, dass nicht alle Arduino Due die gleiche Pinbelegung haben? Ich habe den Arduino Due zusammen mit dem RADDS Board bei sparklab gekauft und bin eigentlich davon ausgegangen, dass die Firmware von Sparklab mit dem Elektronik-Set problemlos zusammen laufen. Der Arduino ist irgendein Nachbau. Was mir noch komisch vorkommt, dass der Arduino Due nur einen Micro-USB hat und nicht zwei. Ich habe keine Ahnung ob da auch meine Verbindungsprobleme mit der Repetier Host Software her kommen.

1-mal bearbeitet. Zuletzt am 07.06.16 01:07.
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 00:55
Ist das so?

Die Anschlüsse sind doch rot, blau, grün, schwarz 1+, 1-, 2+,2- und wenn ich drehe 2-,2+, 1-,1+. Das bedeutet, dass ich beide Spulen drehe. das sollte also nix ändern.
Wo ist gerade mein Denkfehler?


Gruß
Andreas

1-mal bearbeitet. Zuletzt am 08.06.16 00:56.


Einen Sparkcube 1.1XL für größere Objekte, einen Trinus3D im Gehäuse und einen Tantillus R im Bau und einen Qidi Tech Q1 Pro im Zulauf.
Sparkcube: Komplett auf 24V - DDP 8mm + 1,5mm Carbonplatte - Octopus max EZ - EZ2209 - Nema 17/1,7A 0,9 Grad - BL Touch - Filamentsensor - Titan Booster Hotend - Sparklab Extruder - Klipper/Mainsail - HDMI 7 V1.2 Touchscreen - Simplify3D
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 02:55
Also Vincent ist da - wie ich es vernehme - sehr pingelig.
Ich hab zwar auch schon Arduinos mit veränderter Pinbelegung gesehen (Nano) aber noch nicht beim Due

Gruß
Andreas


Einen Sparkcube 1.1XL für größere Objekte, einen Trinus3D im Gehäuse und einen Tantillus R im Bau und einen Qidi Tech Q1 Pro im Zulauf.
Sparkcube: Komplett auf 24V - DDP 8mm + 1,5mm Carbonplatte - Octopus max EZ - EZ2209 - Nema 17/1,7A 0,9 Grad - BL Touch - Filamentsensor - Titan Booster Hotend - Sparklab Extruder - Klipper/Mainsail - HDMI 7 V1.2 Touchscreen - Simplify3D
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 03:08
Das war bei meiner Firmware auch am Anfamg.
Bei Repetier kann man das unter der pins.h ändern. Da bis zum RADDS runterscrollen und Heatbed suchen.

Kann wenn du willst heute Nachmittag ein Screenshot schicken.


MfG
Jonas


Sparkcube v1.1xl


Meine Thingiverse Dinge: [www.thingiverse.com]
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 03:09
So richtig vorstellen kann ich mir das eigentlich auch nicht, ich hab irgendwo schon gelesen das Vincent alle Arduinos vorher kurz testet. Aber was kann es sonst sein? Irgendwas ist da ja verdreht spinning smiley sticking its tongue out

Welchen USB Port benutzt man am Due? Den "Native Port" oder den "Programming Port"? Wo liegt da genau der Unterschied?

Ich hab mein Problem auch schon im Sparklab Forum beschrieben, aber dort leider noch keine Reaktion erhalten. Ich werde nochmal etwas weiter testen und ansonsten Vincent mal anrufen.



Schon mal vielen Dank für die Unterstützung thumbs up
VG Tobias
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 03:11
@Jonas: Das wäre sehr nett von Dir thumbs upsmiling smiley
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 03:34
Hi,
@Boui3D:
Es kommt auf die Reihenfolge an, in der die Spulen bestromt werden. Die ändert sich, wenn man den Stecker umdreht. Probiers halt einfach mal (vorsichtig) aus.

@KaptinT:
Wenn das Heizbett über ein Relais betrieben wird kann man es auch über einen Extruderausgang ansteuern und spart sich so die extra Stromversorgung am Heizbettausgang am Radds. Darauf sollte aber in der Doku ausdrücklich hingewiesen sein.

ich würde auch mal Vincent kontaktieren und ihm am besten gleich Fotos schicken, so dass er deine Verkabelung nachvollziehen kann.

Gruß
Stefan
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 03:43
@Alterego: Ja das hatte ich mir auch schon überlegt, ob das nicht sogar Sinn macht smiling smiley
Du meinst die Doku von Vincent?

Dann muss ich nur noch mein Hotend zum laufen kriegen.
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 04:08
Quote
Alterego
Hi,
@Boui3D:
Probiers halt einfach mal (vorsichtig)aus

Den merk ich mir. Mit zum Motor abgewandtem Gesicht und Finger auf dem Bestellknopf. grinning smiley

Gruß
Andreas


Einen Sparkcube 1.1XL für größere Objekte, einen Trinus3D im Gehäuse und einen Tantillus R im Bau und einen Qidi Tech Q1 Pro im Zulauf.
Sparkcube: Komplett auf 24V - DDP 8mm + 1,5mm Carbonplatte - Octopus max EZ - EZ2209 - Nema 17/1,7A 0,9 Grad - BL Touch - Filamentsensor - Titan Booster Hotend - Sparklab Extruder - Klipper/Mainsail - HDMI 7 V1.2 Touchscreen - Simplify3D
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 07:26
Der Wickelsinn ist entscheidend. Deshalb dreht man die Anschlüsse der Spulen.

Stell dir einfach ne Spule vor...die du selbst im Uhrzeigersinn gewickelt hast. Da legst du jetzt eine Spannung an und hast jetzt oben den Nordpol und unten den Südpol.

Jetzt wickels du die gleiche Spule gegen den Urzeigersinn und schließt die Kabel gleich der ersten an. Und schon sind die Pole vertaucht.

Würdest du die Kabel jetzt bei der ersten Spule vertauschen, hätte das den gleichen Effekt.


[www.facebook.com]

Power is nothing.....without control!
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 11:30
Ich hab dir mal einen Screenshot von meiner Config gemacht und diese angehängt. Dann kannst du diese mal mit deinem Setup vergleichen. Ein Vertauschen der PIN´s kann ich mir eigentlich nicht vorstellen.

Auszug: Configuration.h


Auszug: Pins.h


4-mal bearbeitet. Zuletzt am 07.06.16 11:34.


Mein erster Drucker: Sparkcube XL, Sparklab Extruder, E3D V6 (ABS, PETG) + E3D lite (PLA) mit Skimmy´s Magnet-Schnellwechselsystem, FSR ABL, DPP, RADDS + RAPS 24V
Mein Zweiter: Thomas V2, [forums.reprap.org], Eigenbau Dual X, Linearführungen, Z-Achse mir Riemenantrieb, RADDS + RAPPS + DM542, 48V, Repetier
Anhänge:
Öffnen | Download - 2016-06-07_17h27_57.png (11.6 KB)
Öffnen | Download - Configuration.h (69.4 KB)
Öffnen | Download - 2016-06-07_17h32_24.png (41.8 KB)
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 12:17
Ich habe es so und es klappt.




MfG
Jonas


Sparkcube v1.1xl


Meine Thingiverse Dinge: [www.thingiverse.com]
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 15:58
Hallo und schon mal vielen Dank an alle! Mit Hilfe der pins.h habe ich jetzt alles soweit erstmal zum laufen bekommen.

Jetzt habe ich nur noch das Problem das ich mich mit dem Repetier Host nicht verbinden kann sad smiley Hat da noch jemand einen Tip für mich?
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 16:08
Beide USB Ports probiert?
Baudrate passend in Repetier und auf dem DUE?


MfG
Jonas


Sparkcube v1.1xl


Meine Thingiverse Dinge: [www.thingiverse.com]
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
07. June 2016 19:18
Quote
Stud54
Der Wickelsinn ist entscheidend. Deshalb dreht man die Anschlüsse der Spulen.

Stell dir einfach ne Spule vor...die du selbst im Uhrzeigersinn gewickelt hast. Da legst du jetzt eine Spannung an und hast jetzt oben den Nordpol und unten den Südpol.

Jetzt wickels du die gleiche Spule gegen den Urzeigersinn und schließt die Kabel gleich der ersten an. Und schon sind die Pole vertaucht.

Würdest du die Kabel jetzt bei der ersten Spule vertauschen, hätte das den gleichen Effekt.


Stud54, du hast es viel besser erklärt. Ich meinte im Prinzip das Gleiche.


@Boui3D: Ja, merks dir oder vergiss es. Du hast nur weiter oben die Fehlinformation gepostet, dass Stecker drehen nichts bringt. Das wollte ich klarstellen.


Gruß
Stefan
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
08. June 2016 00:52
Guten Morgen,

mein Arduino Due, den ich bei Sparklab bestellt habe, hat nur einen USB Anschluss. Ich glaube es ist der "Native Port".
Anstelle des "Programming Port" in Form einer USB Buchse habe ich dort eine Stiftleiste, wo man glaube ich einen Programmieradapter anschließen kann.
Welchen Port benutz ihr um den Due mit dem Repetier Host zu verbinden?

Baudrate habe ich gleich eingestellt. Auch habe ich verschiedene Baudraten getestet wie z.B. 250000 und 115200 und noch ein paar andere. Hat einer von euch noch eine Idee?

Viele Grüße
Tobias
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
08. June 2016 01:02
So sieht mein Arduino Due ungefähr aus nur in Rot


Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
08. June 2016 05:14
Quote
Alterego
@Boui3D: Ja, merks dir oder vergiss es. Du hast nur weiter oben die Fehlinformation gepostet, dass Stecker drehen nichts bringt. Das wollte ich klarstellen.

Ach herrje Du Spaßbremse. Sorry, wenn Du perfekt bist.
Ich ärgere mich nur, weil ich es schon selbst durch drehen korrigieren musste, die auch im Beitrag "Erweiterungsplatine RADDS" nachweisbar kommuniziert habe, mir es aber nicht mehr einfiel, ich aber nun einer Fehlinfo aufgesessen bin. (Boah was ein Schachtelsatz)
Schrittmotoren waren beruflich noch nie ein Thema für mich. Dumm gelaufen. Man darf auch mal verlieren.

Aber auch wenn Du das nun auskostest. Ich gebe nie eine Info raus, die Schaden verursacht. Hier hätte man sich halt den Weg über die Software sparen können aber wenn das alles ist. So what!

Ein Gutes hat es. Nun ist es fest verankert.

Gruß
Andreas


Einen Sparkcube 1.1XL für größere Objekte, einen Trinus3D im Gehäuse und einen Tantillus R im Bau und einen Qidi Tech Q1 Pro im Zulauf.
Sparkcube: Komplett auf 24V - DDP 8mm + 1,5mm Carbonplatte - Octopus max EZ - EZ2209 - Nema 17/1,7A 0,9 Grad - BL Touch - Filamentsensor - Titan Booster Hotend - Sparklab Extruder - Klipper/Mainsail - HDMI 7 V1.2 Touchscreen - Simplify3D
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
08. June 2016 08:46
Du musst über den Native Port gehen. Der programming ist dafür da, dass man den Bootlader neubrennen kann.




MfG
Jonas


Sparkcube v1.1xl


Meine Thingiverse Dinge: [www.thingiverse.com]
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
08. June 2016 09:08
Normal geht man über den Programming Port beim Due. Der native Port beim Due ist immer ein wenig zickig. Zudem muss man den nativen Port dann auch bei Repetier einstellen. Bauraten sind beim nativen Port auch egal. Wenn man den Due unter Windows anschließt muss man mal im Gerätemanager glucken. Wenn da Bossac steht in einmal auf den Resetknopf drücken. Dann sollte da irgendwann ArduinoDue oder so stehen.

Was mich allerdings wundert, warum verkauft Vincent solch Teile? Über den nativen USB werden noch viele Leute rumfrusten.

Edit: Den Bootloader kann man zudem auch nicht über den Programming Port neu brennen. Dafür sind die 6 Pins mitten auf der Platine.

1-mal bearbeitet. Zuletzt am 08.06.16 09:14.


Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
08. June 2016 09:50
Bei mir konnte ich keine Verrbindung über den programming port herstellen.

Aber wieso steht dann da programming ATmega16?


MfG
Jonas


Sparkcube v1.1xl


Meine Thingiverse Dinge: [www.thingiverse.com]
Re: Anfänger Probleme Sparkcube XL: z-Achse homen / Connection error / Extruder bleibt kalt
08. June 2016 10:33
Kann man bei Repetier mittlerweile den nativen Port auswählen?
Ich glaube der Atmega da drauf ist der serielle Konverter. Bin mir gerade aber nicht sicher.


Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen