Willkommen! Anmelden Ein neues Profil erzeugen

Erweiterte Suche

Gangunterschied Z-Achse

geschrieben von Physikant 
Gangunterschied Z-Achse
23. January 2019 06:48
Hallo Leute!

Ich habe vor Jahren einen Mendel90-Kit von nophead bestellt (dh. Melzi v1 Hybrid mit mega1284, Gewindestangenachsen und 2 Nema17 Z-Motoren).
Jetzt musste ich feststellen, dass es ab und zu einen gewissen Gangunterschied zwischen den Z-Achsen gibt. Fahre ich einmal runter und wieder hoch, steht die eine Seite der Z-Achse eine halbe bis ganze Umdrehung weiter als die andere. Erst richtig aufgefallen war es mir, nachdem ich einen Mod konstruiert und gedruckt habe, bei dem ich die beiden Gewindestangen durch gedrehte Gewindespindeln ersetzt habe. Da hier die Steigung wesentlich höher ist, war der Drucker damit unbrauchbar und ich bin zurück zum Original-Setup von nophead gewechselt. Dennoch habe ich immer wieder Probleme mit dem Gangunterschied der beiden Seiten der Z-Achse.
Die Motoren auf beiden Seiten sind baugleich und parallel an den A4988 des Melzi angeschlossen.
Kann mir jemand sagen, was ich da am besten machen kann?

Vielen Dank schonmal!

Grüße,
Niko
Re: Gangunterschied Z-Achse
23. January 2019 08:45
Hey Niko,

welchen Motorstrom hast Du auf Z und welchen dürfen die Stepper abbekommen?

Gruß
Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Gangunterschied Z-Achse
23. January 2019 15:45
Hi Julien,

der Strom war wohl schon von Nophead so eingestellt, die Referenzspannung beträgt zwischen 0,49 und 0,5 V (bei allen 4 Motortreibern), was mit den 50 mOhm-Widerständen auf diesem Melzi einem Motorstrom von 1,225V entspricht. Motoren sind die SY42STH47-1684A, die einen Nennstrom von 1,68A haben.

Grüße,
Niko

1-mal bearbeitet. Zuletzt am 24.01.19 02:37.
Re: Gangunterschied Z-Achse
24. January 2019 05:36
Sind die Z-Motoren in reihe, oder parallel geschaltet?

/Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Gangunterschied Z-Achse
24. January 2019 06:35
Die sind parallel geschaltet.

-Niko
Re: Gangunterschied Z-Achse
25. January 2019 05:53
Hallo Niko

Könnte es sein, dass die Kupplung an der Motorwelle oder an der Spindel durchrutscht?

Gruß Michael


Konstruktionen: [www.thingiverse.com]
Videos: [www.youtube.com]
Mein Club: [hackerspace-ffm.de]
Drucker:
Wersybot - seit 2012 smiling smiley
JGAurora A5
Re: Gangunterschied Z-Achse
25. January 2019 06:10
Hallo Michael,

das bezweifle ich. In Nopheads Design ist der Koppler zwischen Welle und Spindel zunächst mit einem Gummi versehen und dann ordentlich verschraubt. Von Hand lässt sich hier auch mit Gewalt nichts bewegen.
Die Spindelmutter ist eine gewöhnliche Schraubenmutter. Ich denke auch hier nicht, dass sich da viel tut, denn das wäre ein grundsätzlicher Designfehler des Mendel90.
Insbesondere habe ich ja für meine Änderung auf eine gedrehte Spindel alle Komponenten umdesignt und getauscht und das Problem blieb bestehen. Ich schließe daher ein mechanisches Problem aus.

Grüße,
Niko
Re: Gangunterschied Z-Achse
25. January 2019 07:04
Hallo Niko

Die gedruckte Kupplung von Nophead habe ich auch noch immer, funktioniert tadellos.

Schau doch mal, ob bei dem Motor, der Schritte verliert, vielleicht ein Kabelbruch/Wackelkontakt besteht.
Ansonsten mal den Motor austauschen oder vertauschen.

Gruß Michael


Konstruktionen: [www.thingiverse.com]
Videos: [www.youtube.com]
Mein Club: [hackerspace-ffm.de]
Drucker:
Wersybot - seit 2012 smiling smiley
JGAurora A5
Re: Gangunterschied Z-Achse
06. February 2019 11:05
Hallo Niko,

hast du inzwischen herausgefunden, was die Ursache war?

Da ich mich an keinen Fall erinnern kann, in dem Gangunterschiede aufgetreten sind, wäre sehr interessant zu wissen, wie es dazu gekommen ist.

Gruß Michael


Konstruktionen: [www.thingiverse.com]
Videos: [www.youtube.com]
Mein Club: [hackerspace-ffm.de]
Drucker:
Wersybot - seit 2012 smiling smiley
JGAurora A5
Re: Gangunterschied Z-Achse
08. February 2019 02:23
Ich habe neue Schrittmotoren bestellt, die sind aber noch nicht da. Bislang habe ich keine Ahnung, was das Problem ist, mechanisch sehe ich keine Ursache. Ist der eingestellte Strom am Melzi vielleicht zu klein? Ich weiß nicht, wie man diesen Wert korrekt wählt ...
Re: Gangunterschied Z-Achse
08. February 2019 14:17
Am Treiber stellst Du keinen Strom ein, sondern nur die Referenzspannung. Über diese ergibt sich, welchen Strom der Treiber an die Motoren weitergibt, das ist aber je nach Treiber unterschiedlich (Google Suche hilft, bei Deinen A4988 von Watterott steht es ja in der Beschreibung).
Was für einen Strom Du maximal einzustellen hast (oder besser gesagt nur 70% davon) wüsstest Du, wenn Du diesen Beitrag gelesen hättest, das steht nämlich im Datenblatt des Motors (Hausaufgabe -> raussuchen).

Wenn ich Deinen ersten Post aber noch einmal durchlese, bestärkt sich der Verdacht, dass Du beim Rückbau auf die alten Spindeln etwas verspannt hast. So langsam hört sich das nach einem mechanischen Fehler an. Probiere folgendes: beide Z-Motoren vom Board abstecken sodass sie weder mit der Elektrik noch mit einander verbunden sind und per Hand drehen. Ist einer der beiden schwergängiger als der andere?

/Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Gangunterschied Z-Achse
08. February 2019 15:05
Hallo Julien,

meine Hausaufgaben habe ich diesbezüglich gemacht! Ich weiß sehr genau, wie ich bei meinem Melzi mit welcher Referenzspannung welchen Strom am Treiber einstellen kann. Auch kenne ich den Nennstrom der beiden Motoren und dass bei Parallelschaltung die Ströme wohl das doppelte betragen müssen. Allerdings sagt mri das ja erstmal wenig, wieviel ich letztendlich als Strom für den Treiber wähle, denn es werden wohl kaum die (2 * 1,68 A = ) 3,36A sein. Nophead hatte 1,225A eingestellt gehabt, er muss sich dabei doch was gedacht haben?

Die beiden Spindeln sind gleich leichtgängig. Zudem war das Problem ja sowohl mit den Original-Gewindestäben als auch mit den neuen Gewindespindeln (und dann auch wieder nach dem Rückbau auf die Originalstäbe) vorhanden, was wohl gegen eine mechanische Verspannung spricht ...

Grüße,
Nikolas
Re: Gangunterschied Z-Achse
08. February 2019 15:40
Allgemeiner Hinweis für Schrittmotoren in unseren Geräten zur Stromeinstellung: So viel wie nötig, so wenig wie möglich.
Darum wird NopHead die so klein gehalten haben.

Die Z-Achse braucht meistens durch die hohe Übersetzung den geringsten Strom, trotzdem würde ich einfach mal die maximalen 2A (also 1A pro Motor statt1,68A) einstellen und gucken was passiert (dabei den Treiber bitte sehr gut kühlen, sonst definitiv Schrittverluste!). Auch wenn die Geräte (Deins und NopHeads) gleich aufgebaut sind, kann es zu unterschiedlich starken "Verspannungen" in der Montage der Geräte kommen, möglicherweise reichen deine geringen Ströme dann nicht mehr. Probiere einfach die 2A, dann wissen wir mehr.

Gruß
Julien


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide

Drucker: Eigenbau I3 - V6-Clone - Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Gangunterschied Z-Achse
09. February 2019 05:33
Die 1,225A von Nophead sind schon ok.

Was ist bei Max feedrate u. Max acceleration auf der Z-Achse eingestellt ?

Gruß
Peppi
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen