Verständnisfrage Bedleveling
24. April 2019 11:22
Hallo,

ich verwende schon seit einiger Zeit die Bedleveling Funktion. Dabei ist mir immer wieder mal aufgefallen, das sich mein Drucker anders verhält. Der Die Funktion für das Bedleveling habe ich in meinem Programm drin und das wird auch alles sauber ausgeführt. Der Drucker misst schön alle 9 Messpunkte. So weit eigentlich völlig o.k. Eingestellt habe ich das ganze im warmen Zustand des Bettes, wie auch des Extruders. Sollte meiner Meinung nach auch passen (jeder Druck, erfolgt mit der selben Temperatur).
Das Bauteil wird ordnungsgemäß gedruckt. Es gibt nichts zu beanstanden. Nun ein paar Stunden später oder so, starte ich den Druck erneut. Der Drucker fängt wieder das Leveln an wie beim ersten mal. Nun kann es allerdings sein (ist nicht immer der Fall), dass der erste Layer zu tief ist. Filament wird dann natürlich auch nicht richtig gefördert. Und genau hier verstehe ich etwas nicht. Wenn er das ganze doch gemessen hat, sollte doch eigentlich so etwas nicht passieren? Ich sehe beim Druck auch, dass die Z-Achse regelt. Also das ganze scheint schon aktiv zu sein.
Das nächste, was ich nicht ganz verstehe. Der Sensor zum Level, verwende ich auch zum Homen der Z-Achse. Habe nun einmal das selbe Bauteil mit aktiver Bedleveling Funktion und einmal ohne ausgegeben. Verwende ich die Funktion nicht, so ist meine Z-Achse wenn sie das Drucken auf Z=0.2 (da startet sie immer egal, ob Leveling aktiv oder nicht) höher. Somit wird der Druck nicht sauber auf das Bett gelegt. Normalerweise sollte doch 0.2 immer 0.2 abstand zum Bett sein? Und nicht einmal mehr und das andere mal weniger?

Kann hier jemand etwas Licht ins dunkle bringen? Vielen Dank!
Re: Verständnisfrage Bedleveling
06. May 2019 05:26
Hallo Marcel (ich gehe mal davon aus, dass das dein name ist ;-)


ehrlich gesagt, habe ich etwas Schwierigkeiten zu verstehen, was du meinst.

Ich habe noch kein automatisches Bedleveling eingesetzt, aber ich versuche auf den zweiten Absatz einzugehen.....

Verstehe ich das richtig?

- Du führst ein Home auf der Z-Achse aus.
- Das Druckbett ist dann von dir so eingestellt, dass 0,2 mm Abstand zwischen Druckbettoberfläche und sauberer Düse besteht?
- Dann startest du den Druck.

Mit welcher Layerhöhe?
Mit welcher Layerhöhe der ersten Schicht?

Die Layerhöhe, bzw Layerhöhe der ersten Schicht kommt ja zu der Höhe, auf die du das Bett gelevelt hast dazu.

Gehe ich mal von PLA auf BuildtakClone aus.

Wenn ich das Bett auf 0,2 mm level und mit 0,2 mm Layerhöhe druckem und 0,2mm 1stLayerHöhe drucke, dann haftet bei mir nix.

Ich muss dann den 1st Layer mit ca. 1% - 25% drucken.

Ich level daher lieber auf 0,1mm (bei mir genau! 1 Blatt Papier) und stelle den 1st Layer auf 25% bis 50%, bei 0,2 mm Layerhigh.

Trifft das auf deine Beschreibung zu?


Beste Güße,
Andre
Re: Verständnisfrage Bedleveling
06. May 2019 06:58
Hey anjoku,
nicht ganz. Der Abstand Duese Bett ist eigentlich 0. Es passt nur ein Blatt dazwischen. Das ist meine Z=0. Home ich und fahre z0, dann ist hier die richtige Pos wie vorhin eingestellt. Das Blatt passt gerade noch drunter.
Layerhoehe bei meinem Druck ist 0.2. Somit startet er den Druck auf z= 0.2+Blattdicke.

Diese Vorgehensweise ist immer die selbe. Habe ich nun die leveling Funktion aktiv, so ist der Abstand z= 0.2+Blattdicke eine andere wie ohne leveling. Auf der Anzeige steht jeweils z=0.2. Der Abstand zwischen Bett und Extruder, ist aber unterschiedlich.
Re: Verständnisfrage Bedleveling
06. May 2019 07:27
Ok, ....auch wenn ich jetzt kleinlich bin.....Wenn ein Blatt dazwischen passt ist sind das immer noch 0,1 mm oder etwas mehr.

Aber die restlichen zusammenhänge verstehe ich - noch - nicht.

Bei mir steht ja ABL noch an, dann werde ich sicher nachvollziehen können, was du genau meinst :-)

Beste Grüße,
Andre
Re: Verständnisfrage Bedleveling
07. May 2019 05:42
Dafür müsstest du dir mal deinen ABL Code in der Firmware anschauen - oder alternativ im Start-GCode.

Meine Annahme ist, dass er beim ABL den Tastwert + Offset einträgt - und da kommen noch mal deine z0 (Blatt) + 0.2mm drauf. Und schon druckst du in die Luft.
Probier doch mal zwei verschiedene Start Gcodes.
Ver 1 - Ohne ABL (Nehme an G29?) mit deiner Blattkalibrierung + 0.2mm
Ver 2 - Mit ABL OHNE Blattkalibrierung und 0.2mm.

Eine weitere Sache ist noch:
Schließ das Gerät mal an PC / Octoprint an. Starte nen G29 ABL Befehl und lass ihn durch laufen. Nun ein G1 (oder G0) Z1 eingeben. Dann schrittweise in 0.1mm Schritten die Z-Achse gegen 0 fahren, Blatt Papier darunter legen. Bestenfalls Bett + Düse im heißen Zustand, ohne geladenes Filament, schon während dem ABL Vorgang
Folgendes kann nun passieren:
- Das Blatt wird bei Z0.x festgehalten - Dein ABL ist ohne Offset oder gar negativ. Eher unwahrscheinlich
- Das Blatt wird exakt bei Z0 festgehalten - dein ABL ist ohne Offset und genau.
- Das Blatt lässt sich bei Z0 mit schleifendem Geräusch an der Düse bewegen - Dein ABL hat einen Offset der sehr genau ist
- Das Blatt lässt sich bei Z0 frei unter der Düse hindurchschieben - Dein ABL hat einen Offset, welcher aber zu hoch ist

Von deiner Beschreibung her sollte es einer der letzten beiden Fälle sein. Ich hab jetzt beim Überfliegen nicht gesehen, was für einen Drucker und welche Bauform du hast. Dieses Verfahren dürfte aber für alle Bauformen gelten.


Alle Angaben ohne Gewähr grinning smiley
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen