Vertex K8400 uneindeutiges Fehlerbild
16. March 2021 17:57
Hallo zusammen,

habe das mal hier eingestellt, da ich mir nicht sicher bin, wo der Fehler liegt. Entweder bei der Hardware oder bei der Firmeware.
Aber jetzt erstma langsam von Anfang an.

Drucker: Vertex K8400 2 Druckköpfe
Fimeware: M:1.0 V:1.4 H:2 (also die neuste die es gibt (von 2017...)) Link zum Treiber
Slicer: Simplify3D

Mechanik habe ich kontrolliert. Die ist in Ordnung.
Habe das Mainboard ausgebaut und auf Brandstellen untersuch (keine gefunden) und von Staub befreit.
Firmeware neu aufgespielt

Aber folgendes Fehlerbild bleibt bestehen:
    [1] Drucker resettet sich einfach mittem im Druck
    [2] Drucker fährt (x- und Y-Achse) an eine andere Stelle und druckt weiter.
    [3] Z-Achse verfährt mittem im Druck. Druckkopf kollediert mit dem Objekt.
    [4] Wenn ich die Z-Achse manuell verfahre startet sich der Drucker neu. Nicht jedes mal aber häufig. Nach dem Neustart steht eine Unsinnege Temperatur im Display


    [5]Während des Druckens werden irgendwelche Zeichen im LCD-Display dargestellt

Die Mechanik kann ich ausschließen, da der gezeigte Testdruck um ca. 20° gedreht auf dem Druckbett plaziert war. Nach dem Versatz ist die rückwärtige Wand immer noch in der selben Flucht.



Jetzt meine Frage. Denke, das es entweder die Firmeware oder die Hauptplatine ist. aber wie kann ich das weiter eingrenzen. Würde ungerne eine neue Platine kaufen ohne das es etwas bringt...

Danke und Grüße, Tim
Re: Vertex K8400 uneindeutiges Fehlerbild
17. March 2021 11:30
Willkommen im Forum Tim,

dein Fehlerbild könnte auch vom Netzteil kommen,
du hast die neue Firmware aufgespielt, auch hier ist die Möglichkeit das etwas nicht korrekt abgelaufen ist,
die Frage ist warum.
Netzteil auf korrekte Eingangsspannung (Schalter) und Ausgangsspannung (messen) prüfen, sollte 15V sein (lt. deinem Link ein Meanwell 15V 150W passiv gekühlt).
Prüf dabei auch die komplette Verkabelung vom Netzteil zum Board nicht das es hier einen Wackelkontakt gibt, eventuell ist ein Kabel lose oder mit der Isolierung geklemmt in den Schraubklemmen.
Sollte das passen, nochmals die neue Firmware aufspielen und EEPROM resetten.
Drucker testen.
Weiterhin Fehlerhaft dann würde ich die alte Firmware aufspielen, EEPROM resetten und den Drucker testen.

Eventuell kannst du somit feststellen an was es genauer liegt.

Gruß Wintex
Re: Vertex K8400 uneindeutiges Fehlerbild
17. March 2021 14:05
Hallo Wintex,

vielen Dank für deine Antwort.

Der Fehler war auch vor dem Aufspielen der Firmware da. Wollte nur sichergehen das da alles sauber ist.

Spannung am Netzteil ist in Ordnung. Schöne 15V smiling smiley
Das Erdungskabel konnte ich ein wenig nachziehen. Mal sehen, ob das was gebracht hat. Ansonsten habe ich die ältere Firmware aufgespielt.

Gerade läuft ein Probedruck. Mal sehen ob es sauber durchläuft.

Sollte das der Fall sein, werde ich wieder auf die neue Firmware wechseln und nochmal drucken. Wenn dann der Fehler wieder auftaucht...

Gruß und Dank, Tim
Re: Vertex K8400 uneindeutiges Fehlerbild
17. March 2021 17:38
Stichwort Erdungskabel. GND der Versorgungsspannung und Erde Steckdose und Gehäuse NIE miteinander verbinden.


Liebe Grüße aus Kaltenkirchen.
Frithjof
Meine Seite
[www.facebook.com]
Re: Vertex K8400 uneindeutiges Fehlerbild
18. March 2021 06:55
Quote
DerTim

Sollte das der Fall sein, werde ich wieder auf die neue Firmware wechseln und nochmal drucken. Wenn dann der Fehler wieder auftaucht...

Sollte man mit etwas Hilfe sogar die Marlin 1.9 für den Drucker selber kompilieren und installieren können, gibt ja dafür auch ein paar Seiten bzw. Wiki im Netz bzw. jemanden in diesem Forum der diesem Drucker schon die Version gegönnt hat.
Einfach die Suche im Netz "Marlin Vertex 8400"
Man hat ja dann auch eine Basis auf die man zurückgreifen kann.

2-mal bearbeitet. Zuletzt am 18.03.21 06:57.
Re: Vertex K8400 uneindeutiges Fehlerbild
20. March 2021 17:37
Hallo zusammen,

vielen Dank für eure Antworten.

Leider hat es genau ein Druck lang funktioniert. sad smiley

Habe heute einen drei Stunden lang dauernden Druck gestartet. Nach 1,5 Std die Fehler im Display und nach ca. 2 Std startete sich der Drucker neu...

Werde jetzt mal nen Kühlkörper auf den Microkontroler kleben und dann mal schauen. Vielleicht überhitzt das ding ja.

Das mit der Marlin Version 1.9 werde ich erst mal zurück schieben. immerhin lief der Drucker ja mal mit beiden Versionen längere Zeit stabil.

Grüße, Tim
Re: Vertex K8400 uneindeutiges Fehlerbild
21. March 2021 15:57
Der Spannungswandler auf dem original Board liefert eine zu geringe Spannung für die CPU, bzw an der untersten Grenze. Das geht lange gut und steigt dann irgendwann aus. Warum hab ich nie ergründet.
Überprüfe mal die Spannung auf der 5V Schiene.
Ich hatte damals den Spannungswandler abgeklemmt und durch einen anderen ersetzt.

1-mal bearbeitet. Zuletzt am 21.03.21 15:57.


P3Steel Toolson MK2 / TMC2209 + TMC2100 / Marlin 1.1.8 / Ramps 1.4 / 24V / S3D
Re: Vertex K8400 uneindeutiges Fehlerbild
21. March 2021 16:34
Die Spannung ist dabei nicht zu niedrig, der Wandler ist einfach überlastet - und DANN sinkt die Spannung...
Passiert gerne, wenn man zu viel kram am 5V-Regler hat (Servos, Snesoren, etc.), oder die Vorwiderstände dafür zu niedrig gewählt sind und ein Controllerpin mehr als 40mA abgeben muss (was schon echt grenzwertig ist...).

Dann bricht die Spannung ein und der Controller startet neu, passt schon, was MJ sagt.
Was hängt denn bei Dir alles am Mainboard?

/Julien

1-mal bearbeitet. Zuletzt am 21.03.21 16:35.


Wer rasiert mit mir KingKong? Der wichtigste Guide - Triffid Hunter's Calibration Guide


Drucker:
HyperCube EVO (Derivat) in 2502x300 - geschlossen für ABS - Duet2WiFi - Eigenbau Wasserkühlung
Eigenbau I3 - V6-Clon- Profilrahmen - Ramps 1.4 24V - TMC2208 - Simplify3D - Octoprint - Marlin 1.1.8
Re: Vertex K8400 uneindeutiges Fehlerbild
22. March 2021 00:33
Hallo,

Quote
Julien
Was hängt denn bei Dir alles am Mainboard?

Nur das, was dran soll. Pro Achse ein Schrittmotor und Endschalter. Dann die beiden Druckköpfe inklusive des zugehörigen Schrittmotors. Bei den letzten Drucken war immer nur ein Druckkopf aktiv. Die zweite Spule ist nicht mal belegt.

Demnach könnte es etwas bringen, wenn ich den Microcontroller zusätzlich mit 5V über den USB-Port versorge?

Werde das mal messen und testen.

Grüße, Tim
Re: Vertex K8400 uneindeutiges Fehlerbild
22. March 2021 01:41
Ich habe den Drucker schon länger nicht mehr, daher alles aus der Erinnerung heraus.
Die Betriebspannung des Atmegas darauf ist min 4,5V. Nach dem Spannungsregler ist, soweit ich mich entsinne eine Diode, welche die 5V auf 4,3V 4,18V runterzieht. confused smiley hatte nämlich nichts der Gleichen angeschlossen und dasselbe Problem.
Muss mal schauen ob ich dazu noch Aufschriebe habe. Ich hatte in Summe 3 Boards davon, alle mit dem selben Effekten und den selben Fehlern nach einer gewissen Zeit. Am Ende ist es rausgeflogen und wurde durch ein klassisches Ramps ersetzt.

Wie gesagt, messe mal die 5V, am besten mal nur das Board und sonst nichts dran, dann ist die Fehlerquelle auch ausgeschlossen.


_____________________

Ist wie in einer "gut sortierten" Bastelwerkstatt, bloß nichts wegwerfen.

Das ist mein Tread im Forum hier. Kommt dir das Fehlerbild bekannt vor?
Dort siehst du auch ein Bild mit der oben genannten Diode.
Die eigentlichen Beiträge aus dem Vertex-Forum finde ich nimmer

Lösung habe ich teilweise noch gefunden: Ich hab den bestehenden Regler abgezwickt aber auf der Board belassen. Dann einen anderen dort angelötet und dessen Spannung so eingestellt, dass am Ende 5V auch 5V waren. Danach lief es gut bis andere Probleme auftraten.




2-mal bearbeitet. Zuletzt am 22.03.21 02:08.


P3Steel Toolson MK2 / TMC2209 + TMC2100 / Marlin 1.1.8 / Ramps 1.4 / 24V / S3D
Re: Vertex K8400 uneindeutiges Fehlerbild
22. March 2021 11:44
Hallo MeisterMJ12,

habe gerade das bereits bestellte neue Mainbord stoniert. angry smiley Die Fehlerbeschreibung deinerseits ist zu ähnlich. Habe keinen Bock, das das nochmal passiert.

Werde jetzt "einfach" ein anderes Mainboard kaufen und dann in den Drucker einbauen. Mal sehen, was es da so gibt. Ein Heizbett steht eh schon länger auf meiner Wunschliste. Ein entsprechendes Netzteil mit 24V habe ich schon in der Bastelkiste.
Mal sehen was es wird. Denke hier im Forum werde ich wohl fündig, welches System am besten funzt. grinning smiley

Gruß und Dank an alle die mir geholfen haben.

Grüße, Tim

PS. Empfehlungen nehme ich natürlich gerne an.
Re: Vertex K8400 uneindeutiges Fehlerbild
22. March 2021 11:59
Das ist ein guter Plan. Als Nächstes hat bei mir dann immer die Heizung auf Dauerheizen den Dienst quittiert.

Im Prinzip bist du frei in der Auswahl, es ist ein normaler kartesischer Drucker, d.h. 8bit ist völlig ausreichend.
Kannst ein klassisches Ramps nehmen (muss man nur etwas umbauen für 24V, kein Akt) oder was aus der skr-Reihe oder oder oder.
Am einfachsten nimmst eines das häufig verwendet wird, dann ist die Doku besser ;-)


P3Steel Toolson MK2 / TMC2209 + TMC2100 / Marlin 1.1.8 / Ramps 1.4 / 24V / S3D
Re: Vertex K8400 uneindeutiges Fehlerbild
22. March 2021 12:11
Gibt es da eine Homepage die da ein bischen Hilfestellung gibt.

Was wird denn Häufig genommen? Was ist zuverlässig? Was lässt mich meine bisherigen Schrittmotoren weiterverwenden...

grinning smiley
Re: Vertex K8400 uneindeutiges Fehlerbild
23. March 2021 04:20
Am einfachsten ist ein MEGA mit RAMPS. Tausendfach dokumentiert, aber leider nicht ohne Umbau für 24V geeignet. Die MKS Gen L (nicht SGEN L!) haben die Kombi auf einem Board vereint und sind weitestgehend kompatibel zum RAMPS (somit simpel mit einer Firmware auszustatten) und auch 24V-tauglich, günstig sind die auch. Haltbar ist so 'ne Sache, bei manchen Revisionen gab es nach einiger Zeit Probleme mit der 5V-Versorgung, ließ sich aber fixen. Darauf einen Satz TMC2209 von Watterott (am einfachsten im Standalone-Betrieb) und alles ist gut. Die alten Steppermotoren kannst du weiter verwenden, du brauchst nur für 24 V passende Heizelemente. Bei mehr als 200 Watt für das Bett würde ich zu einem SSR raten, wird sonst etwas knapp mit den Leiterbahnen.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen