Gen7 Repetier-Host xx Befehle warten
03. June 2013 12:07
Hallo zusammen,

Bekomme immer wieder diese Meldung wenn ich mich mit dem Host verbunden habe.
Wie bringe ich diese Befehle wieder weg?
Wo ist da das Problem?



Geschwindigkeit ist auf Firmware und Host gleich, habe auch schon mehrere getestet.

Danke Christian
Re: Gen7 Repetier-Host xx Befehle warten
03. June 2013 13:22
Das Problem habe ich nach dem Einschalten des Rechners und Druckers auch immer. Ich löse das so:
- Repetier-Host Verbindung trennen
- Resetknopf auf der Gen7 drücken
- Repetier-Host Verbindung herstellen

funzt smiling smiley

Gruß
Boris


Gruß
Boris
--
DIY Mendel90
Gen7 1.4.1 mit Repetier Firmware 0.91 + Repetier Host
Gen7 Extension Board mit LCD, SD-Card, Bluetooth und FAN-Control
Re: Gen7 Repetier-Host xx Befehle warten
03. June 2013 13:45
Hallo Boris,

danke für den Tipp.
Aber kann´s das sein ??

Gruss Christian


Sparkcube V1.1
Radds mit Repetier Firmware + Repetier Host + Repetier Server
E3D v.6, 24 Volt
Dauerdruckplatte ALU
Lüfter, Led Beleuchtung,
Repetier Server Pro
Raspberry Pi 7" Touchscreen Display
Re: Gen7 Repetier-Host xx Befehle warten
04. June 2013 03:32
Gestern habe ich festgestellt, dass dieses Problem nicht auftritt wenn man das Netzteil vom Drucker erst einschaltet wenn der Rechner schon an ist.


Gruß
Boris
--
DIY Mendel90
Gen7 1.4.1 mit Repetier Firmware 0.91 + Repetier Host
Gen7 Extension Board mit LCD, SD-Card, Bluetooth und FAN-Control
Re: Gen7 Repetier-Host xx Befehle warten
05. June 2013 06:09
Hallo Boris,

also bei mir geht da nichts.
Immer wieder diese Meldung.
Ich bringe die auch nur weg wenn ich die Firmware neu aufspiele.

Gruss Christian


Sparkcube V1.1
Radds mit Repetier Firmware + Repetier Host + Repetier Server
E3D v.6, 24 Volt
Dauerdruckplatte ALU
Lüfter, Led Beleuchtung,
Repetier Server Pro
Raspberry Pi 7" Touchscreen Display
Re: Gen7 Repetier-Host xx Befehle warten
19. April 2014 07:07
Hi,
ich habe das gleiche Problem mit Repetier-Host und Teacup auf einem Gen7 1.5. Bei mir bringt alles nichts. Trennen/Reset/Verbinden und neu flashen nicht. ich bin echt ratlos.
Hat irgendjemand das Problem im Griff, denn ich weis nicht mal ob das Problem vom Host oder von der Elektronik ausgeht. Immer mal wieder geht es auch.

grüße josa
Re: Gen7 Repetier-Host xx Befehle warten
20. April 2014 05:55
Lass mich raten: Repetier Host schickt schon Befehle, bevor der Bootloader fertig und die Verbindung hergestellt ist. Der Gen7-Bootloader wartet 3 Sekunden, um ein hochladen der Firmware auch ohne Auto-Reset zu erlauben. Pronterface hat das bis vor ein paar Monaten auch ignoriert, es konnte gar keine Verbindung hergestellt werden. So ist das eben, wenn Software-Entwickler nur RAMPS im Schädel haben und Benutzer noch nicht einmal den geschickten G-code anschauen können. Hat bei Pronterface 11 Monate gedauert, bis mal jemand dahinter gekommen ist.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Gen7 Repetier-Host xx Befehle warten
21. April 2014 16:59
Quote

Lass mich raten: Repetier Host schickt schon Befehle, bevor der Bootloader fertig und die Verbindung hergestellt ist.

Falsch geraten. Die Firmware ist ohne Bootloader direkt aus der IDE per isp geflasht worden.

Grüße josa
Re: Gen7 Repetier-Host xx Befehle warten
22. April 2014 02:12
Ich hab jetzt auch seit 2 Wochen mal den RepetierHost insatlliert und bei mir steht das auch immer da.
Ich glaube das sind die Befehle um das EEPROM auszulesen.
Ich drück immer unten auf OK dann sind Sie weg spinning smiley sticking its tongue out
Bei übrigens in Verbindung mit dem STB-Board...

1-mal bearbeitet. Zuletzt am 22.04.14 02:14.
Re: Gen7 Repetier-Host xx Befehle warten
27. April 2014 14:28
Wenn ich ok drücke steht zwar dannach "Leerlauf" da. Wenn ich dann aber wieder Befehle abschicke werden sie trotzdem nicht bearbeitet und es steht wieder "warte auf x..."

Grüße josa
Re: Gen7 Repetier-Host xx Befehle warten
30. April 2014 17:08
Ich habe neue Erkenntnisse, was das problem angeht. Ponterface will gar nicht verbinden. Ich glaube, dass der usb2rs232 converter auf den Gen7 aus irgendeinem Grund nicht gescheit mit dem AVR verbunden ist. Der Wandler aber mit dem Computer verbunden ist und seine ID schickt, und Repetier daraus schließt, dass ein Board verbunden ist. Ponterface dagegen aber schaut, ob auch ein Signal zurück geschickt wird. Stimmt das so?
Ich habe aber die Signalstrecken durchgemessen und es ist überall da eine Verbindung da, wo eine sein sollte.
Den AVR kann man auch ohne probleme per ISP programmieren, kaputt ist der also auch nicht.
Re: Gen7 Repetier-Host xx Befehle warten
01. May 2014 07:54
Anstatt zu raten, was diese Hosts so machen, kann man auch einfach ein Terminal-Programm für die serielle Schnittstelle verwenden. PuTTY, GtkTerm, CoolTerm. Ein paar Sekunden nach dem Reset sollte das Wort "start" erscheinen.

Bis vor ein paar Monaten hatte Pronterface eine Macke, es konnte sich nicht mit Elektroniken verbinden, die den Gen7-Bootloader verwenden.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Gen7 Repetier-Host xx Befehle warten
01. May 2014 09:34
Quote

Anstatt zu raten, was diese Hosts so machen, kann man auch einfach ein Terminal-Programm für die serielle Schnittstelle verwenden. PuTTY, GtkTerm, CoolTerm. Ein paar Sekunden nach dem Reset sollte das Wort "start" erscheinen.

Danke, das habe ich aber auch schon gemacht. Früher war es der fall jetzt nicht mehr. Ich habe jetzt am Board nochmal mit dem Durchgangsprüfer drüber geschaut und auch ein zwei kalte Lötstellen, an den Lötbrücken, bei denen ich etwas schlecht lötbaren Drat verwendet habe, gefunden.

Anstatt hier auf mir rumzuhacken, weil ich fragen stelle. Ich habe probehalber mal Blink geflasht und Repetier verbindet trotzdem. Glaubst du mir jetzt?

Quote

Bis vor ein paar Monaten hatte Pronterface eine Macke, es konnte sich nicht mit Elektroniken verbinden, die den Gen7-Bootloader verwenden.

Ich habe nicht mal einen Bootloader. Ich flashe direkt per ISP.

EDIT:
Jetzt geht es, die ide kriegt es irgendwie nicht so gut auf die Reihe per ISP zu flashen. Ich habe jetzt das HEX-File aus dem TEMP-Ordner geholt und miteinem anderen Programm geflasht.

1-mal bearbeitet. Zuletzt am 01.05.14 10:32.
Re: Gen7 Repetier-Host xx Befehle warten
02. May 2014 06:48
Quote
josa
Anstatt hier auf mir rumzuhacken, weil ich fragen stelle.

Wenn Leute erfolglos in der Landschaft herum klicken anstatt sich Werkzeugen zu bedienen, mit denen man Fehler auch erkennen kann, was soll man da tun, als eindeutige Antworten zu geben? Tut mir leid, dass das bei Dir als "rumhacken" ankommt. Vielleicht hätte ich Dich besser weiter klicken lassen sollen.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Gen7 Repetier-Host xx Befehle warten
02. May 2014 12:29
Quote

Wenn Leute erfolglos in der Landschaft herum klicken anstatt sich Werkzeugen zu bedienen, mit denen man Fehler auch erkennen kann, was soll man da tun, als eindeutige Antworten zu geben? Tut mir leid, dass das bei Dir als "rumhacken" ankommt. Vielleicht hätte ich Dich besser weiter klicken lassen sollen.
Meine Vermutung hat aber gestimmt!
Re: Gen7 Repetier-Host xx Befehle warten
05. May 2014 02:09
Quote
josa
Meine Vermutung hat aber gestimmt!

Welche Vermutung.
Ich hab jetzt auch mal meinen 2 Drucker mit einem Ramps1.4 mit Repetier verbunden.
Da gibt es das NICHT!!!
Nur bei meinen Drucker mit dem STB-Board.
Da ich mit dem Board eh ein wenig Probleme habe würde mich sehr Interessieren wie du das jetzt genau hinbekommen hast.
Bin jetzt nicht so vertraut mit Terminal und Bootloader...
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen