Repetier Firmware 0.91, versatz immer bei Layer 24
26. February 2014 06:52
Hallo Leute,

ich habe das Problem, dass bei meinem 3D Rostock Drucker bei dieser Box_0.4mm.stl Datei immer ab Layer 24 ein Versatz in der X Y Z Achse passiert.


Der Fehler ist Reproduzierbar! Ich habe erst an Schrittverlust gedacht. Das ist auszuschließen. Ich habe dann die Firmware 0.83 wieder geflasht. Dann trat der Fehler nicht mehr auf. Jetzt weiß ich nicht mehr weiter. Ich möchte ganz gerne die neue Firmware benutzen. Vielen Dank schon mal für die Hilfe.

Hier noch meine Konfiguration.

115200 >Baudrate
773.048 >Filament printed [m]
641429 >Printer active
0 > Max. inactive time [ms,0=off]
0 >Stop stepper after inactivity [ms,0=off]
44.4444 >Steps per mm
80.000 >Max. feedrate [mm/s]
40.000 >Homing feedrate [mm/s]
30.000 >Max. jerk [mm/s]
0.000 >X home pos [mm]
0.000 >Y home pos [mm]
0.000 >Z home pos [mm]
100.000 >X max length [mm]
100.000 >Y max length [mm]
211.700 >Z max length [mm]
400.000 >Acceleration [mm/s^2]
400.000 >Travel acceleration [mm/s^2]
304.800 >Diagonal rod length [mm]
125.700 >Horizontal radius [mm]
70 >Segments/s for travel
180 >Segments/s for printing
0 >Tower X endstop offset [steps]
0 >Tower Y endstop offset [steps]
0 >Tower Z endstop offset [steps]
210.000 >Alpha A(210):
330.000 >Alpha B(330):
90.000 >Alpha C(90):
0.000 >Delta Radius A(0):
0.000 >Delta Radius B(0):
0.000 >Delta Radius C(0):
0 >Bed Heat Manager [0-3]
255 >Bed PID drive max
80 >Bed PID drive min
196.000 >Bed PID P-gain
33.000 >Bed PID I-gain
290.000 >Bed PID D-gain
255 >Bed PID max value [0-255]
90.000 >Extr.1 steps per mm
300.000 >Extr.1 max. feedrate [mm/s]
5.000 >Extr.1 start feedrate [mm/s]
5000.000 >Extr.1 acceleration [mm/s^2]
1 >Extr.1 heat manager [0-3]
140 >Extr.1 PID drive max
60 >Extr.1 PID drive min
7.4400 >Extr.1 PID P-gain/dead-time
0.4500 >Extr.1 PID I-gain
30.9300 >Extr.1 PID D-gain
255 >Extr.1 PID max value [0-255]
0 >Extr.1 X-offset [steps]
0 >Extr.1 Y-offset [steps]
1 >Extr.1 temp. stabilize time
150 >Extr.1 temp. for retraction when heating
0 >Extr.1 distance to retract when heating [mm]
255 >Extr.1 extruder cooler speed [0-255]

22.01.2014.epr
Re: Repetier Firmware 0.91, versatz immer bei Layer 24
11. September 2014 17:43
Hallo!
Ich habe das selbe Problem mit einem Kossel. Layerzahl weiss ich nicht, aber es gibt immer einen Versatz an der exakt selben Stelle.

Interessant ist, dass der Versatz kleiner geworden ist, als ich den Druck von einer anderen uSD Karte ausführte. Kann es sein, dass sich die Firmware beim Lesen irgendwie verschluckt?
Re: Repetier Firmware 0.91, versatz immer bei Layer 24
19. October 2014 04:35
Hallo,

ich schließe mich hier mal an. Ich habe bei meinem gerade fertiggestellten Rostock mini ein ähnliches Problem zwar nicht bei Layer 24 aber es scheint sehr gleichmäßig zu passieren:





Ich hoffe jemand hat eine Idee. Ich habe Repetiert 0.92 im Einsatz.

mfg

David

1-mal bearbeitet. Zuletzt am 19.10.14 08:22.
Re: Repetier Firmware 0.91, versatz immer bei Layer 24
21. October 2014 15:39
Der der einen Namen hat, und man ansprechen kann, bekommt die Antwort.

Hallo David,

das sieht nach Schrittverlusten aus , auf der Y und/oder Z Achse.

Bitte kontrolliere ob die Achsen wirklich sauber und leicht laufen. Über die gesammte Länge.

Dann prüfen ob die "Pololus Motorendstufen" richtig eingestellt sind.
Das ist hier schon mehrfach beschrieben worden. Bitte Suchfunktion bemühen, danke.

Repetier Host ist für den Fehler eher nicht interessant.

Viel Erfolg.

Liebe Grüße
Helmut
Re: Repetier Firmware 0.91, versatz immer bei Layer 24
22. October 2014 14:18
Danke für deine Antwort Hermelinn,

ich vermute mal das die Motoren vielleicht zu viel Leistung ziehen da es welche sind mit 1,7A ? Nun habe ich noch drei Pololu DRV8825 hier leider finde ich nirgends ein genaues Bild wo ich die Vrev Spannung messen soll, diese sollte ich doch wenn ich alles richtig verstanden habe auf ca. 0,85v einstellen oder irre ich da?

Bei meinem Makerfarm habe ich die Motoren nach Gehör Achse für Achse eingestellt was auch sehr gut funktioniert hat, beim Rostock fällt mir das um einiges schwerer.

Die Motoren sind diese hier

mfg

David
Re: Repetier Firmware 0.91, versatz immer bei Layer 24
22. October 2014 16:49
Die Drv8825 habe ich nun doch einfestellt bekommen auf 0,85v, ich hoffe das das korrekt ist.

MFG

David
Re: Repetier Firmware 0.91, versatz immer bei Layer 24
22. October 2014 17:11
Hallo David,
ich betreibe die A4988.
Die machen bei einer ref.Spannung von 0,4V ca. 1A, bei 0,8V 2A
Ich betreibe meine 2A Motoren mit ca. 0,350V.

Ich kenne die ref.Spannung von Deinen Drivern nicht.
Bemühe mal Freulein Google.
Oder drehe die Driver zurück bis nix mehr geht, und dann in kleinen Schritten wieder hoch, bis die Motoren sauber laufen.

Beim Extrudermotor kann es evtl. etwas mehr sein

Die Motoren müssen nicht an der Obergrenze betrieben werden. Die liefern auch im unteren Strombereich ausreichend Drehmoment.
Da wird nur unnötig Strom in Wärme gewandelt, ohne Leistung zu bringen

Dann sind Deine Schrittverluse sicher weg,.

Viel ist nicht immer gut.

Liebe Grüße
Helmut

2-mal bearbeitet. Zuletzt am 22.10.14 17:15.
Re: Repetier Firmware 0.91, versatz immer bei Layer 24
25. October 2014 02:10
@winne1973

Sieh mal hier:

[github.com]
und hier:
[www.thingiverse.com]

Herzl. Grüße
Re: Repetier Firmware 0.91, versatz immer bei Layer 24
26. October 2014 04:07
Welche Elektronik nehmt ihr denn? Arduino Mega 2560 + Ramps 1.4 ?
Re: Repetier Firmware 0.91, versatz immer bei Layer 24
27. October 2014 05:33
Hi,
prüft in eurer Firmware ob der Schalter für das ständige Prüfen der Endstops ausgeschaltet ist.
im Repetier :
#define ALWAYS_CHECK_ENDSTOPS 0
Ich war da auch schon mal am Verzweifeln und hatte den halben Drucker incl. Elektronik auseinandergerissen bis ich da drauf gekommen bin angry smiley

Ansonsten ein gerne auftretendes Problem bei der Druckerei über USB Kabel

Viel Erfolg
Gerhard
Re: Repetier Firmware 0.91, versatz immer bei Layer 24
27. October 2014 16:36
Hallo,

ich wollte mich nur mal schnell zurück melden, vielen Dank an Hermelinn, nachdem ich die Treiber auf 0,85v Vrev eingestellt habe komme ich auf dieses Ergebnis:





Wenn ich die Treiber runter regel werden die Motoren relativ laut, also werde ich sie erstmal so lassen.

Soweit schon mal ganz gut, auf jeden Fall sind die "Treppenstufen" weg.

Vielen Dank

mfg

David

1-mal bearbeitet. Zuletzt am 27.10.14 16:37.
Re: Repetier Firmware 0.91, versatz immer bei Layer 24
27. October 2014 19:40
Hallo David,

schön dass es jetzt geht.
Aber die Themp. von den Treibern im Auge behalten.
Mal mit den Fingern prüfen. Sollten nicht heiss werden. Das gilt auch für die Motoren.

Viel Spass

Liebe Grüße

Helmut
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen